So I had Antergos Installed before in my Asus-K550J and I had no such problems with the fan control.

Now I’m using Arch and my fan is allways on max speed which isn’t that bad, but I would prefer to have it at normal speeds according to the temperature and it also makes a lot of noise.

So since it worked in Antergos I would like to know if anyone here knows what does Antergos has that makes the fan control work.

My specs are as follow:

  • intel core i7-4710HQ 2.5Ghz
  • Nvidia Geforce GTX 850m
  • 12Gb of memory
  • 4.11.3-1-ARCH
    #1 SMP PREEMPT Sun May 28 10:40:17 CEST 2017 x86_64 GNU/Linux

The output of #sensors :

asus-isa-0000
Adapter: ISA adapter
cpu_fan: 25500 RPM
temp1: +35.0°C

coretemp-isa-0000
Adapter: ISA adapter
Package id 0: +36.0°C (high = +84.0°C, crit = +100.0°C)
Core 0: +33.0°C (high = +84.0°C, crit = +100.0°C)
Core 1: +36.0°C (high = +84.0°C, crit = +100.0°C)
Core 2: +33.0°C (high = +84.0°C, crit = +100.0°C)
Core 3: +31.0°C (high = +84.0°C, crit = +100.0°C)

acpitz-virtual-0
Adapter: Virtual device
temp1: +35.0°C (crit = +103.0°C)

By now I have tried many things and so far nothing worked…

I think it might be important to note that I’m using Bumblebee.