• gcc-libs conflicts with gcc-libs-multilib


    :: Synchronizing package databases...
     antergos is up to date
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
     Foreign packages: / 9 / 9
    
    ==> Software upgrade (new version) :
    core/gcc                   6.3.1-2    -> 7.1.1-2
    extra/fuse-common          3.0.1-1    -> 3.0.2-1
    extra/python2-setuptools   1:35.0.2-1 -> 1:36.0.0-1
    extra/python-setuptools    1:35.0.2-1 -> 1:36.0.0-1
    multilib/gcc-libs-multilib 6.3.1-2    -> 7.1.1-3
    multilib/lib32-gcc-libs    6.3.1-2    -> 7.1.1-3
    
    ==> New package :
    core/gcc-libs              7.1.1-2    (required by gcc)
    
    ==> Continue upgrade ? [Y/n]
    ==> [V]iew package detail   [M]anually select packages
    ==> --------------------------------------------------
    ==> y
    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...
    warning: removing 'gcc-libs' from target list because it conflicts with 'gcc-libs-multilib'
    error: failed to prepare transaction (could not satisfy dependencies)
    :: gcc: requires gcc-libs=7.1.1-2
    
    
    

    Both gcc-libs and gcc-libs-multilib were updated a couple of days ago and no bug reports have been issued. It looks like the multilib is a reverse conflict. What does this mean?
    https://www.archlinux.org/packages/core/x86_64/gcc-libs/
    https://www.archlinux.org/packages/multilib/x86_64/gcc-libs-multilib/

    I have the multilib repository enabled for my Brother printer. The drivers are supplied from AUR. Any solutions? With the deprecation of 32 bit support, does this mean that the multilib repository will be no longer?

  • @triode13 said in gcc-libs conflicts with gcc-libs-multilib:

    I have the multilib repository enabled for my Brother printer. The drivers are supplied from AUR. Any solutions? With the deprecation of 32 bit support, does this mean that the multilib repository will be no longer?

    No.

    Replace libtool with libtool-multilib & keep gcc-libs-multilib

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • Hi,

    I ran into this one as well, fixed with…

    sudo pacman -S gcc-multilib

    then just rerun the update

  • Thanks everyone. Looks like gcc needs to be all multilib or not otherwise dependency conflicts arise.

conflicts2 gcc-libs1 Posts 4Views 1579
Log in to reply