• Live USB hangs on splash screen


    I have twice downloaded the lastest ISO (antergos-17.5-x86_64) from the Antergos website, created a bootable USB in Windows using Rufus, booted into the USB where I get the options such as “Boot from harddrive”, “Boot into live USB”, etc. I am attempting to install Antergos, so I choose to boot into the live USB and it always (in both UEFI and Legacy) loads up to the splash screen and then hangs without anything happening:

    (I keep getting errors when uploading an image locally or from Imgur, so apologies for the link)

    Has anyone come across this before, or have any idea why it may be happening? If not, is there anywhere I can find previous releases to try an one?

    Thanks

  • If you go to SourceForge, I think there are older ones there:slight_smile:

    Hope this helps!

    Keep trying, never give up. In the end, you will find that it was all worth it

    (NOTE: This is still @A-User, I just changed my username and picture)

  • @A-User said in Live USB hangs on splash screen:

    If you go to SourceForge, I think there are older ones there:slight_smile:

    Hope this helps!

    I can’t seem to see any there - just the latest 17.5 build. Sorry, I don’t use SourceForge much…

  • I just came across the same thing…

    Sorry, but I personally don’t have any other advice to offer.

    Keep trying, never give up. In the end, you will find that it was all worth it

    (NOTE: This is still @A-User, I just changed my username and picture)

  • Maybe you have a flaky USB thumb drive or a bad download. Rufus was always solid when I used it. The only times I’ve ever had problems booting into a live environment is with USB. Verify the MD5 Sum, and burn to DVD.

usb52 splash2 live31 hangs10 Posts 5Views 184
Log in to reply