• Wayland not working on X1 carbon laptop


    I’ve tried adding a .desktop file as per this thread:

    https://forum.antergos.com/topic/5546/gnome-not-running-with-wayland-sessions-confusion

    I’ve also installed and switched to GDM from lightDM.

    But, when I click on the new .desktop from GDM all I get is a blank screen.

    I’m using the following graphics cards, output from lspci | grep -e VGA -e 3D:

    00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
    00:13.0 Non-VGA unclassified device: Intel Corporation Device 9d35 (rev 21)
    

    Is Wayland compatible with my laptop?

    I’d really like to get it working for the per-monitor scaling so I can use it with my monitor at home :)

  • This is an antergos bug. I’ve the same issue than you.
    I try installing archlinux (not antergos) with gnome in a vm and I was automatically using wayland.
    I don’t know why it’s not working in antergos.
    I tought it was lightDM too, maybe there is some config file to do somewhere …

  • A VM installation is not default using the same hardware specs then a “real” installing, if wayland fails this can be caused by different things i do not see a Antergos Bug here, a lot users using standard installation with intel graphics and wayland without issue.
    If wayland s not starting on Gnome, it is caused mostly by hardware not working with it, then also GDM is using Xorg as fallback. For Gnome there are Session options inside for Gnome (wayland) and Gnome-Xorg (Xorg).
    Also GDM has a option for using wayland or not for it self.

    /etc/gdm/custom.conf

    # GDM configuration storage
    
    [daemon]
    WaylandEnable=false
    # Uncoment the line below to force the login screen to use Xorg
    #WaylandEnable=false
    
    [security]
    
    [xdmcp]
    
    [chooser]
    
    [debug]
    # Uncomment the line below to turn on debugging
    #Enable=true
    

    As i can see if wayland fails it is not a good option to force it otherway caus of bad performance or other issue on using it then.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad Ok I guess I’ll just have to accept my hardware doesn’t work with it?

    I managed to make do with a bash script to sort out hot plugging a monitor, so I’ll probably leave it for now.

    I’m not sure if this has any relevance but I can start Weston from lightDM and from terminal no problem.

  • This is related to Gnome, also KDE seems to work lot better with wayland…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad I have a core i3 4th generation so it seems a bit strange that my standard installation with intel graphics is not compatible.
    I also have the same config file as you.

  • i have nvidia prop. driver and no wayland… I try to use wayland before with nouveau driver and i can start but result in glitchy behavior and freezes… also on two intel graphic powered machines i use Xorg caus of glitches and freezes…
    And i got 4 VM installations with different DE all working fine with wayland.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

wayland33 carbon1 laptop27 Posts 7Views 276
Log in to reply