• dbus


    update AUR the multibootusb and give me:

    Failed to prepare transaction
    could not satisfy dependencies:
    dbus-c++:removing dbus breaks dependency 'dbus>=1.2.0'
    

    Only choice the [ Close ]
    Can you help me?

  • Missing information such as:
    I delete some AUR package?

    But also, you can try updating the package database:

    yaourt -Syua
    
  • @judd i try but always at the and of progress …

    ==> 
    
    loading packages...
    resolving dependencies...
    looking for conflicting packages...
    :: dbus-x11 and dbus are in conflict (libdbus). Remove dbus? [y/N] 
    error: unresolvable package conflicts detected
    error: failed to prepare transaction (conflicting dependencies)
    :: dbus-x11 and dbus are in conflict
    ==> WARNING: Your packages are saved in /tmp/yaourt-tmp-oplo
    ==> Restart building multibootusb ? [y/N]
    ==> -------------------------------------
    ==> 
    
    ==> ERROR: unable to update
    
  • @astrolavos said in dbus:

    :: dbus-x11 and dbus are in conflict

    @Community-Moderators
    @developers
    :telephone_receiver: :telephone:

  • @astrolavos said in dbus:

    multibootusb

    multibootusb requires dbus-x11 (which is dbus with --enable-x11-autolaunch). I do NOT recommend using it.

    Anyway, if you MUST use multibootusb, you must replace dbus with dbus-x11. If you do not know how, I’m really sorry but I won’t tell you because the next step will be you complaining about something else being broken (sorry if this sounds a bit rude, I do not know how to explain it better).

    As a general rule, it is always a very bad idea to replace a core package with an aur one.

    Cheers!

  • @astrolavos the solution is uninstall the multibootusb and install the new version multibootusb 8.8.0-2 without install dbus-x11.

    yaourt -Rns multibootusb
    

    install multibootusb 8.8.0-2

    yaourt multibootusb
    
    1 aur/multibootusb 8.8.0-2 [installed] (56) (3.90)
        Boot multiple live Linux distros from a usb flash drive.
    ==> Enter n° of packages to be installed (ex: 1 2 3 or 1-3)
    ==> -------------------------------------------------------
    ==>
    

    choose 1 for install multibootusb 8.8.0-2

    ( Unsupported package: Potentially dangerous ! )
    ==> Edit PKGBUILD ? [Y/n] ("A" to abort)
    ==> ------------------------------------
    ==>
    

    choose Y and delete from this line only the “dbus-x11”

    depends=("python-pyqt5" "pyqt5-common" "python-dbus" "mtools" "util-linux" "parted" "p7zip" "python-six" "python-pyudev" "dbu$ "dbus-x11")
    

    save and continue, that’s it!

  • Hi,

    Reading AUR comments, they do not seem to agree if dbus-x11 is necessary or not.

    Compiling it with dbus (core) instead of dbus-x11 could cause some breakage in the app, but until nobody confirms or denies it…

dbus2 Posts 8Views 585
Log in to reply