• Gestor de actualizaciones (Pamac) y db.lck


    No actualiza, se queda durante minutos con la barrita de abajo moviéndose de izquierda a derecha y el mensaje " En espera de otro gestor de paquetes para salir…"

    En consola:

    sudo pacman -Syu
    :: Sincronizando las bases de datos de los paquetes…
    error: no se pudo actualizar antergos (no se pudo bloquear la base de datos)
    error: no se pudo actualizar core (no se pudo bloquear la base de datos)
    error: no se pudo actualizar extra (no se pudo bloquear la base de datos)
    error: no se pudo actualizar community (no se pudo bloquear la base de datos)
    error: no se pudo actualizar multilib (no se pudo bloquear la base de datos)
    error: no se pudo sincronizar ninguna base de datos
    error: no se pudo iniciar la operación (no se pudo bloquear la base de datos)
    error: no se pudo bloquear la base de datos: El fichero ya existe
      si está seguro de que no se está ejecutando
      un administrador de paquetes, puede quitar /var/lib/pacman/db.lck
    

    Igual con sudo pacman -Syyu y sudo pacman -Syyuu

    sudo yaourt -Syua
    ==> Pacman está en uso, espere por favor.
    
    yaourt -Syyu --devel --aur
    ==> Pacman está en uso, espere por favor.
    yaourt -Sua --force 
    ==> Pacman está en uso, espere por favor.
    sudo pacman -Sy gnupg archlinux-keyring antergos-keyring
    :: Sincronizando las bases de datos de los paquetes…
    error: no se pudo actualizar antergos (no se pudo bloquear la base de datos)
    error: no se pudo actualizar core (no se pudo bloquear la base de datos)
    error: no se pudo actualizar extra (no se pudo bloquear la base de datos)
    error: no se pudo actualizar community (no se pudo bloquear la base de datos)
    error: no se pudo actualizar multilib (no se pudo bloquear la base de datos)
    error: no se pudo sincronizar ninguna base de datos
    error: no se pudo iniciar la operación (no se pudo bloquear la base de datos)
    error: no se pudo bloquear la base de datos: El fichero ya existe
      si está seguro de que no se está ejecutando
      un administrador de paquetes, puede quitar /var/lib/pacman/db.lck
    
    sudo pacman -Sy antergos-keyring
    :: Sincronizando las bases de datos de los paquetes…
    error: no se pudo actualizar antergos (no se pudo bloquear la base de datos)
    error: no se pudo actualizar core (no se pudo bloquear la base de datos)
    error: no se pudo actualizar extra (no se pudo bloquear la base de datos)
    error: no se pudo actualizar community (no se pudo bloquear la base de datos)
    error: no se pudo actualizar multilib (no se pudo bloquear la base de datos)
    error: no se pudo sincronizar ninguna base de datos
    error: no se pudo iniciar la operación (no se pudo bloquear la base de datos)
    error: no se pudo bloquear la base de datos: El fichero ya existe
      si está seguro de que no se está ejecutando
      un administrador de paquetes, puede quitar /var/lib/pacman/db.lck
    
    sudo pacman-key --populate archlinux antergos       OK
    sudo pacman-key --refresh-keys                                   OK
    

    Instalación de Octopi:

    ==> Continuar la instalación de alpm_octopi_utils? [S/n]
    ==> [v]isualizar los contenidos del paquete, [c]omprobar el paquete con namcap
    ==> --------------------------------------------------------------------------
    ==> s
    
    ==> Pacman está en uso, espere por favor.
    

    Aprendiendo que no es poco

  • sudo rm /var/lib/pacman/db.lck

    https://forum.antergos.com/topic/7009/need-help-to-fix-db-lck-issues

    Aprendiendo que no es poco

actualización1 pamac36 db.lck2 Posts 2Views 125
Log in to reply