• Need help to fix db.lck issues...


    Hi all,

    This issue has been ongoing for a while and I can’t seem to find a permanent fix.
    I can temporarily fix it for the active session by removing the lock file, but whenever I reboot (usually not the next time but the time after) I have to manually remove the lock in order to update.

    How can I make this more of a permanent solution rather than by manual intervention?

    Thanks in advance.

    [[email protected] ~]$ sudo pacman -Syu
    [sudo] password for fotonut: 
    :: Synchronizing package databases...
    error: failed to update antergos (unable to lock database)
    error: failed to update core (unable to lock database)
    error: failed to update extra (unable to lock database)
    error: failed to update community (unable to lock database)
    error: failed to update multilib (unable to lock database)
    error: failed to synchronize any databases
    error: failed to init transaction (unable to lock database)
    error: could not lock database: File exists
      if you're sure a package manager is not already
      running, you can remove /var/lib/pacman/db.lck
    [[email protected] ~]$ 
    
    
  • $ sudo rm /var/lib/pacman/db.lck
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • But db is blocked mostly because of another updateprogram is running e.t.c. some user also mark this to pamac, and if so next update of pamac should fix this:
    https://github.com/manjaro/pamac/issues/257

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • The new Pamac 4.3.6 should fix the bug

    https://github.com/manjaro/pamac/issues/257

    I made that thread 👍

    Antergos Gnome - Lenovo G4070
    Antergos XFCE (Ex-Mate) - Dell D630
    Antergos Cinnamon - Asus E-11
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc
    Puppy Linux Lxpuptahr USB live - All machines

  • @Caiosama205 Ues the new update seemed to fix the prob. Thanks to all!

issues53 db.lck2 Posts 5Views 566
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.