• Display not working after new Antergos install


    I am getting a black screen upon startup. I have an NVIDIA geforce graphics card in my laptop and I chose the proprietary graphics driver option upon install. I can drop back into a shell just fine but I don’t have much experience with displays in Linux so I couldn’t figure out where the issue was.

    Laptop is HP Pavilion NVIDIA geforce graphics card.
    XFCE Desktop Environment
    Xorg.0.log:
    https://pastebin.com/03HjcK93

  • @taoz said in Display not working after new Antergos install:

    …I chose the proprietary graphics driver option upon install…

    It was a bad choice for your 940M card. Now, there’s no other choice than re-install from scratch, but this time thoroughly following this AnteWiki article.

  • Ah I see. I had seen something about bumblebee but unfortunately only after I had installed and was looking for solutions. Thanks for the help. I had also enabled LTS kernel and actually was able to boot with full GUI when I chose the LTS option on boot. I take it the LTS option uses the default driver rather than the proprietary one?

  • @taoz said in Display not working after new Antergos install:

    I had seen something about bumblebee…

    Bumblebee is only an optional for Optimus cards. It is needed if you want to use proprietary Nvidia driver.

    But you may perfectly run on Intel GPU, with installed by default xf86-video-intel driver.

    I’d only highly recommend to uninstall the nouveau driver, xf86-video-nouveau. It causes inifinite troubles on Optimus computers.

  • @just Thank you again for the reply and writing the guide. I’m up and running now thanks to you. In retrospect probably should have put this question in the newb corner.

  • @taoz OK. Thanks for marking the topic as [Solved].

  • If I payed extra money for a more performant nvidia gpu, I would not want to only use the auxilliary performance free intel chip.
    J.

display32 start-up4 newbie11 Posts 7Views 607
Log in to reply