• Problem with GRUB after instaling the Windows 10 Creators update


    Hi Guys,

    I was always reading forum and finding the answers without posting but this time unfortunatelly I’m stuck with a problem so I would really apreciate Your help.

    Problem:
    When I tried to install the Windows 10 Creators Update (unfrotunatelly I have to use this system in work most of the time) on first reboot my Grub stopped to work and I see the error that Grub started the Rescue mode.

    Fortunatelly I found the solution for that and I’m using the following commands (after ls I found that gpt4 is my Linux root drive):
    set root=(hd0,gpt4)
    set prefix=(hd0,gpt4)/boot/grub
    insmod normal
    normal
    and this is working so I completed the instalation of Windows Update.

    Unfortunatelly I found that after the restart/power down I have to use the command once again. I googled a bit and found that I forgot to update grub entries which I did with following command:
    grub-mkconfig -o /boot/grub/grub.cfg

    Unfortunatelly after reset I still see the Grub Rescue … so I have to type commands again.

    So the question from me. Is there any easy solution than typing all the time same 4 commands so I will not have a problem with boot order ?

    Thanks for everybody who reached to this moment of this text.

  • I might be wrong (know nothing about Windows) but I could come up with 2 ideas:

    1. Install GRUB (from within the said linux OS
      grub-install /dev/sdx (replace x accordingly)
      and regenerate your GRUB
      grub-mkconfig -o /boot/grub/grub.cfg

    2. Use the boot repair tool
      https://help.ubuntu.com/community/Boot-Repair

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I really could be wrong here, but I don’t think Boot-Repair works in Arch systems, only in Ubuntu ones🙁

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • @A-User said

    Boot-Repair

    No, take a look here…
    …“Can recover access to any OS (Windows, MacOS, Linux…) if your PC contains Debian, Ubuntu, Mint, Fedora, OpenSuse, ArchLinux, or derivative.”.
    https://sourceforge.net/p/boot-repair/home/Home/

    The point is that I myself am not sure if I m directing you to the correct way…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Thanks @anarch, I didn’t see that🙂

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

  • Thanks Guys but unfortunately nothing helped.

    I reinstalled the system and now I can see beautiful information that

    /boot/grub/x86_64-efi/normal.mod not found and boot is in rescue mode

    I think we can close this topic.

    Thanks once again for try of help.

  • I think you have overwritten your EFI partition. Or even worse your Linux partition.

    The safest thing when it comes to Dualbooting is Installing windows before Linux.

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood Hi,

    I can boot to the Antergos but have to use same commands that I provided above. Now it is just a bit different error. Both Linux and Windows works fine but I have to do a work arround to start Linux which I think is useless.

  • @Carmon

    ok.

    Try this:

    Boot in to Antergos.
    Make sure you have the os-prober package installed.

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    sudo grub-install /dev/sda
    

    Assuming /dev/sda is the drive your BIOS is booting from.

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • Will try after work and give You update 🙂

  • It solved the problem !!

    Thanks a lot !

    @Global-Moderators You can mark topic as Solved 😉

  • Hi!

    If you go to the bottom right corner, you should see “Topic Tools”. From there, I believe you yourself can mark this topic as Solved.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO: https://rebornos.wordpress.com

    Friend's Website: http://nwg.pl

grub101 windows57 creators2 instaling1 Posts 12Views 2852
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.