• Label exceed allowed length


    Hi there, i tried to make Antergos live bootable.
    At boot stage it stuck because it doesn’t find [i:2nwwkp1s]/dev/disk/by-label/ANTERGOS201305[/i:2nwwkp1s] disk, it tells me to try to fix the problem and to prompt ‘exit’ when i’m done, so it can try to boot again.
    So, just for curiosity, i ran ‘ls /dev/disk/by-label/’ which showed me [i:2nwwkp1s]ANTERGOS201[/i:2nwwkp1s]…

    I tried to rename the label from my current distro (mlabel -i /dev/sdXY ::ANTERGOS201305) but i noticed that whatever i put beyond the 11th character is ignored/cut.

    Is it me, or is it a standard that label should not exceed 11 characters?
    In both case, i hope i can boot antergos which seems pretty cool

    Thanks

  • Hi there, i tried to make Antergos live bootable.
    At boot stage it stuck because it doesn’t find [i:2nwwkp1s]/dev/disk/by-label/ANTERGOS201305[/i:2nwwkp1s] disk, it tells me to try to fix the problem and to prompt ‘exit’ when i’m done, so it can try to boot again.
    So, just for curiosity, i ran ‘ls /dev/disk/by-label/’ which showed me [i:2nwwkp1s]ANTERGOS201[/i:2nwwkp1s]…

    I tried to rename the label from my current distro (mlabel -i /dev/sdXY ::ANTERGOS201305) but i noticed that whatever i put beyond the 11th character is ignored/cut.

    Is it me, or is it a standard that label should not exceed 11 characters?
    In both case, i hope i can boot antergos which seems pretty cool

    Thanks

  • Is this happening with unetbooting or also with dd?

  • @“faidoc”:i117c1g2 said:

    Is this happening with unetbooting or also with dd?[/quote:i117c1g2]
    dd. I tried unetbootin but it doesn’t boot at all.
    I also followed a guide on archlinux which made me extract label from archiso-x86_64.conf (from iso image) with awk.
    I get the same error as well.

  • I’ve checked with an USB and using DD and I didn’t have that problem. Could you check the ISO’s checksum?

  • I have the very same problem on my ASUS VivoBook X202E. I have currently installed Ubuntu-GNOME 13.04 there, but I wish to swap it with Antergos.

      
    :: running early hook [udev]  
    :: running hook [udev]  
    :: Triggering uevents...  
    :: running hook [memdisk]  
    :: running hook [archiso]  
    :: running hook [archiso\_loop\_mnt]  
    :: running hook [archiso\_pxe\_common]  
    :: running hook [archiso\_pxe\_ubd]  
    :: running hook [archiso\_pxe\_http]  
    :: running hook [archiso\_pxe\_nfs]  
    :: Mounting '/dev/disk/by-label/ANTERGOS201305' to '/run/archiso/bootmnt'  
    Waiting 30 seconds for device /dev/disk/by-label-ANTERGOS201305 ...  
    ERROR: '/dev/disk/by-label/ANTERGOS201305' device did not show up after 30 seconds...  
    Falling back to interactive prompt  
    You can try to fix the problem manually, log out when you are finished  
    sh: can't access tty: job control turned off  
    [rootfs /]\#  
    
    

    Is it the same for you?

    I downloaded .iso from .torrent file and used [Linux Live USB (LiLi)[/url:39wetg2n] to make my USB bootable.

    @edit:

    Oh, I had the same problem when trying to boot Cinnarch GNOME Edition. But after it failed once I decided to wait for an official release.]0

    Polish Antergos User… and damn proud of it.

  • @“faidoc”:16g0epbw said:

    I’ve checked with an USB and using DD and I didn’t have that problem. Could you check the ISO’s checksum?[/quote:16g0epbw]
    MD5 match is right (352476cca0efc0b6a63ee8deabea6c68)

    @“galkt”:16g0epbw said:

    Is it the same for you?

    I downloaded .iso from .torrent file and used [Linux Live USB (LiLi)[/url:16g0epbw] to make my USB bootable.

    @edit:

    Oh, I had the same problem when trying to boot Cinnarch GNOME Edition. But after it failed once I decided to wait for an official release.[/quote:16g0epbw]

    Yes, it’s exactly the same. Is your notebook [b:16g0epbw]uefi[/b:16g0epbw]? I’m starting to think this could be the issue (?)

    However, even windows doesn’t allow to write a label longer than 11 character. I don’t know what to do.]0

  • Yup, it is UEFI. It was bundled with Windows 8 pre-installed.

    I’m booting from USB3.0 port and USB3.0 pendrive, though I don’t think it has any impact on this. Oh, some time ago I installed Chakra (also Arch-based) and it booted nicely.

    Polish Antergos User… and damn proud of it.

  • @“galkt”:10fmu1fk said:

    Yup, it is UEFI. It was bundled with Windows 8 pre-installed.

    I’m booting from USB3.0 port and USB3.0 pendrive, though I don’t think it has any impact on this. Oh, some time ago I installed Chakra (also Arch-based) and it booted nicely.[/quote:10fmu1fk]
    I never managed to boot chakra (how did you did it?), but i had success in installing arch+kde (since i wasn’t able to make a good configuration i switched to ubuntu).
    The fact is that both chakra and archlinux probably use shorter labels… Arch uses “ARCH_201305” which length is 11

  • It looked like Chakra was not booting in UEFI. It was not like:

      
      
    But:  
      
    
    

    In the BIOS boot menu. For example Ubuntu has both variants listed and Antergos only the UEFI one.

    Polish Antergos User… and damn proud of it.

  • @“galkt”:3l74gicm said:

    It looked like Chakra was not booting in UEFI. It was not like:

      
    >   
    > But:  
    >   
    > 
    

    In the BIOS boot menu. For example Ubuntu has both variants listed and Antergos only the UEFI one.[/quote:3l74gicm]
    Got it, so you also have the possibility to boot using legacy bios.
    Sadly, i can’t disable uefi on my laptop so i’ve only to get used to it.

    I only hope someone can help me/us to boot live Antergos successfully

  • Yes, I have legacy BIOS support. I have Secure Boot disabled. The problem is that I can’t boot Antergos without UEFI. Some support with that bug would be great.

    @edit:
    Any info on that issue?

    Polish Antergos User… and damn proud of it.

  • @“galkt”:1732alru said:

      
    > :: running early hook [udev]  
    > :: running hook [udev]  
    > :: Triggering uevents...  
    > :: running hook [memdisk]  
    > :: running hook [archiso]  
    > :: running hook [archiso\_loop\_mnt]  
    > :: running hook [archiso\_pxe\_common]  
    > :: running hook [archiso\_pxe\_ubd]  
    > :: running hook [archiso\_pxe\_http]  
    > :: running hook [archiso\_pxe\_nfs]  
    > :: Mounting '/dev/disk/by-label/ANTERGOS201305' to '/run/archiso/bootmnt'  
    > Waiting 30 seconds for device /dev/disk/by-label-ANTERGOS201305 ...  
    > ERROR: '/dev/disk/by-label/ANTERGOS201305' device did not show up after 30 seconds...  
    > Falling back to interactive prompt  
    > You can try to fix the problem manually, log out when you are finished  
    > sh: can't access tty: job control turned off  
    > [rootfs /]\#  
    > 
    

    [/quote:1732alru]

    Galkt,

    I had the same problem when trying to create a live USB with Unetbootin (exact same code as you show). Faidoc (many thanks again) referred me to [url:1732alru]https://wiki.archlinux.org/index.php/USB_Installation_Media#Using_UNetbootin[/url:1732alru] where if you go to the middle of the page I followed the following instructions:

    [b:1732alru][u:1732alru]Using UNetbootin[/u:1732alru][/b:1732alru]

    [i:1732alru]You can use UNetbootin on any Linux distribution or Windows to copy your iso on a USB.
    Note: UNetbootin writes over the default syslinux.cfg, which needs to be reverted.

    Edit syslinux.cfg:

    sysconfig.cfg

    default menu.c32
    prompt 0
    menu title Archlinux Installer
    timeout 100[/i:1732alru]

    [i:1732alru]label unetbootindefault
    menu label Archlinux_x86_64
    kernel /arch/boot/x86_64/vmlinuz
    append initrd=/arch/boot/x86_64/archiso.img archisodevice=/dev/sdx1 …/…/

    label ubnentry0
    menu label Archlinux_i686
    kernel /arch/boot/i686/vmlinuz
    append initrd=/arch/boot/i686/archiso.img archisodevice=/dev/sdx1 …/…/

    In /dev/sdx1 you must replace x with the first free letter after last is in use in the system where you would install Arch Linux (e.g. if you have 2 hard drives, use c.). It’s possible to make this change during the first phase of boot pressing Tab when the menu is shown. [/i:1732alru]

    After updating the syslinux.cfg file with the noted updates, saving and rebooting, the live USB booted in about 15 seconds to the Antergos desktop! I know this is not LiLi, but Unetbootin, but at least you can give it a try with Unetbootin until a solution is provided for LiLi.

    I hope this information helps!

  • Thanks for reply, I’ll give it a try right after my morning coffee.

    @edit: Nope, I can’t even boot to my USB now. I tried booting with original Unetbootin file and with the changed one. The effect is the same. BIOS sees the USB but when I try to boot from it - it just goes back to BIOS Setup. I tried two USB sticks just in case.

    Polish Antergos User… and damn proud of it.

  • @“hacs”:adiz3wyr said:

    […] [b:adiz3wyr][u:adiz3wyr]Using UNetbootin[/u:adiz3wyr][/b:adiz3wyr]

    _You can use UNetbootin on any Linux distribution or Windows to copy your iso on a USB.
    Note: UNetbootin writes over the default syslinux.cfg, which needs to be reverted[…][/quote:adiz3wyr]

    Syslinux doesn’t support UEFI yet.
    unetbootin is useless on uefi machines (at the moment), in fact every bootable device it creates isn’t showed on my bootmenu.

    UPDATE:
    I learnt somethings that may clarify the situation.
    First of all, uefi can only boot FAT32 partitions. Second, FAT32 allows max 11 character for the label.

    dd have success in creating the correct volume label (ANTERGOS201305) but, of course, it doesn’t make a FAT32 partition… so uefi won’t identify the pen drive as a bootable device.

    Usually to make a uefi bootable device you just need to create a FAT32 partition, then copy all the files from the image file (iso/etc.) and, if needed, set the right label.
    If the iso contains a valid EFI folder, with valid efi files of course, it will boot.

    Said this, i hope that developers will short/dim the label so that everybody with uefi machine can install Antergos.
    I know, it sound an offense for the GNU/Linux (fat is a proprietary filesystem), but uefi are made in this way and i can’t disable it (and i would if i could)._

  • Yup. I can confirm this. When I use a dd then the label is set correctly, but it doesn’t even show up as a bootable medium in BIOS.

    When using FAT32 then the label is too long and will show up “30 seconds error”. So… the only think we can do for now is to wait for a fix?

    @edit:

    I think I finally found a way to manually force my laptop to boot in legacy BIOS mode not UEFI, I hope it will work!

    YES! For me your tips about FAT32 and NTFS worked. After I managed to forced ASUS X202E to boot in legacy BIOS I was able to use NTFS formatted pendrive with the right label and it booted up nicely. Bootable USB made with dd.

    I wish you luck with your fight with UEFI.

    Polish Antergos User… and damn proud of it.

  • I did it.
    It was easier than i thought…
    archisolabel is a kernel image flag that you can easily changed on antergos bootmenu.
    I pressed E keyboard key and edited the flag to ANTERGOS201

    Im writing from Antergos right now, great

  • Great to hear. Antergos is a great distro, worth the time spent on installing it.

    Polish Antergos User… and damn proud of it.

  • @“galkt”:161q1pis said:

    Great to hear. Antergos is a great distro, worth the time spent on installing it.
    Indeed
    It’s easier than installing archlinux, and i already did it in the past and it took me more than 15 minutes.
    Now i’ve to fix some keyboard shortcut for my laptop (brightness, backlit keyboard) and then it will be awesome.

    During the installation, Grubx64 hasn’t been pushed onto uefi boot list and so i did it on my own through the command ‘efibootmgr’, otherwise i couldn’t boot antergos.

Posts 19Views 4533
Log in to reply