• Server mirror.yandex.ru/mirrors/cinnarch/$repo/$arch not available

    On the territory of Ukraine all servers * .yandex. * Were blocked. Because of this, the server http://mirror.yandex.ru/mirrors/cinnarch/$repo/$arch is also not available.

    As a consequence /var/lib/pacman/sync/antergos.db: has Unrecognized archive format. Because the provider returns an HTML page with a message about blocking access to the resource.

    1. Is there an alternative to this server on the territory of Ukraine?
    2. How can I deny access to this server, or switch to an alternative?
  • @cawa-93 said in Server mirror.yandex.ru/mirrors/cinnarch/$repo/$arch not available:


    hash the server inside yourx /etc/pacman.d/antergos-mirrorlist

    #Server = http://mirror.yandex.ru/mirrors/cinnarch/$repo/$arch

    But from here the server responds normal now…
    I can see a Czech Republic Server and Bulgaria, you can try the Czech one may work good i do not think the Bulgarian will do a good rate.

  • Before creating the topic, I tried to comment on this line

    # Russia
    # Server = http://mirror.yandex.ru/mirrors/cinnarch/$repo/$arch

    Then i remove /var/lib/pacman/sync/antergos.db and run sync:

    sudo rm /var/lib/pacman/sync/antergos.db
    sudo pacman -Syu

    But I still get an error:

    /var/lib/pacman/sync/antergos.db: Unrecognized archive format

    Because /var/lib/pacman/sync/antergos.db is an HTML document

  • @cawa-93 said in Server mirror.yandex.ru/mirrors/cinnarch/$repo/$arch not available:

    $ sudo rm /var/lib/pacman/sync/antergos.db
    $ sudo pacman -Scc
    $ sudo pacman-key --refresh-keys
    $ sudo pacman -Syy
    $ sudo pacman -Syu
  • @joekamprad
    Did not help.
    /var/lib/pacman/sync/antergos.db still loaded as html

  • @joekamprad said in Server mirror.yandex.ru/mirrors/cinnarch/$repo/$arch not available:


    If it is true that when server is not reachable or giving a error page on request, this needs to be handled by pacmanitself( i have no clue about this…) but seems that you have some internet issue at the moment maybe?

    can you open http://mirror.yandex.ru/mirrors/cinnarch/ inside browser?

  • Yes. The reason is in the ISP. As I wrote earlier, access to *.yandex.ru is blocked in Ukraine. My Internet provider returns an HTML page with information about the lock.


  • https://www.ft.com/content/118bd84c-3a39-11e7-821a-6027b8a20f23
    Then talk to your ISP or government, or exclude the russian server …
    or use proxy service onions e.t.c.

  • @joekamprad
    This is my problem: I can not disable the Russian server.
    I completely removed it from the antergos-mirrorlist. And replaced the German server.

    # Germany
    Server = http://mirror.de.leaseweb.net/antergos/$repo/$arch
    Server = http://antergos-mirror-a.alpix.eu/$repo/$arch
    # Russia
    Server = http://mirror.de.leaseweb.net/antergos/$repo/$arch
    Server = http://antergos-mirror-a.alpix.eu/$repo/$arch

    But it did not help.

  • If you have reflector installed:

    sudo pacman-key --refresh-keys && sudo reflector --age 8 --fastest 128 --latest 64 --number 32 --sort rate --save /etc/pacman.d/mirrorlist && yaourt -Syyua && sync
  • @joekamprad

    Also, I ran a test to see which server is being queried

    $ tcpflow -p -c  port 80 
    tcpflow: listening on wlp2s0
    GET /mirrors/cinnarch/antergos/x86_64/antergos.db.tar.gz HTTP/1.1
    Host: mirror.yandex.ru

    As you can see, why does it still try to download the file from the Yandex server. I can not understand why.

  • cat /etc/pacman.d/antergos-mirrorlist | curl -F [email protected] https://ptpb.pw/

    and give the link

  • you can put that one you want to use first on top of the list…
    temporarly comment these two ones out also plz.:

    #Server = http://mirrors.antergos.com/$repo/$arch
    #Server = http://sourceforge.net/projects/antergos/files/mirror/$repo/$arch

    you can also do:

    $ sudo mv /etc/pacman.d/antergos-mirrorlist /etc/pacman.d/antergos-mirrorlist.bak
    $ sudo nano /etc/pacman.d/antergos-mirrorlist

    and put only the server inside you can ping and view in browser

    Then update system:

    $ sudo pacman -Syyu

    Afterwords you can reset by:

    $ sudo mv /etc/pacman.d/antergos-mirrorlist.bak /etc/pacman.d/antergos-mirrorlist
  • @joekamprad
    Hooray! The problem is solved. I commented on the Automated Mirror Selection

    Thank you very much for your help

  • sourceforge.net choose different servers on load… may this was yandex here ;)

Posts 16Views 2729
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.