• Right Click not working on my touchpad after upgrade


    Hello

    Please am having an issue with me touchpad, my right click doesnt work after upgrade, everything else is fine CTRL+C and CTRL+V works perfectly my tap to click and also two finger scrolling works but my right click doesnt work, can some help me with this?

  • I have the same problem after updating. I can only “two finger tab” to right click, and scrolling has become slower.

  • My two finger tab to right click isnt working as well

  • Guys, what DEs do you use? Touchpad is controlled differently in different DEs.

  • @just Gnome. It seems like it started using libinput instead of synaptics

  • How do i get libinput to work please? i use GNOME

  • Please can you help?

  • OK. Assuming you’re all using Gnome:

    • uninstall xf86-input-synaptics pkg
      sudo pacman -Rcnsu xf86-input-synaptics
      
    • check that xf86-input-libinput is installed
      pacman -Qi xf86-input-libinput
      
    • important - logout-login

    Now, when you click Mouse & Touchpad icon in Gnome Settings, you’ll see not only the General and Mouse but also the Touchpad section. It was missing because of installed xf86-input-synaptics:

    0_1495792341562_gnome-touchpad.png

    With the settings, shown on the picture, the right-click works with two-fingers tap, mouse and touchpad speed may be adjusted as you wish.

  • Thanks alot… it worked

  • It did not work for me. I can only left click on the lowest part of the touch pad, and right click does not work. I used to click on the whole touchpad.
    Only touch to click works. And it is the same in X11 and Wayland.

  • Same here🙁 It did not seem to work for me. In fact, after logging in and then out, nothing noticable changed at all (unlike with ANB08)

  • tap the touchpad with your two fingers people u dont have to click the touch pad anymore just tap the touch pad with two finger #TAP

  • I know… but that isn’t working when I tap to right click🙁

  • Do not tap with two fingers with fingers, tightly gathered one to another. Keep two fingers slightly separated, distant 2-4 mm one from another. A tap should be brief and decisive, it shouldn’t be a long and gentle touch.

  • Thanks, but that is how I have been trying it, and it’s still not doing anything

  • Please, post back here the full output of:

    pacman -Q libinput xf86-input-libinput xf86-input-synaptics
    

    Include the command, as it has been typed in in terminal, and the final bash (or zsh) prompt which follows the output on a blank line.

  • Here it is:

     $ pacman -Q libinput xf86-input-libinput xf86-input-synaptics
     libinput 1.7.2-1
     xf86-input-libinput 0.25.1-1
     error: package 'xf86-input-synaptics' was not found
    

    In addition, if I type this

    pacman -Qi xf86-input-libinput
    

    I get

    $ pacman -Qi xf86-input-libinput
    Name            : xf86-input-libinput
    Version         : 0.25.1-1
    Description     : Generic input driver for the X.Org server based on libinput
    Architecture    : x86_64
    URL             : http://xorg.freedesktop.org/
    Licenses        : custom
    Groups          : xorg-drivers
    Provides        : None
    Depends On      : libinput>=1.2.0
    Optional Deps   : None
    Required By     : xorg-server
    Optional For    : None
    Conflicts With  : xorg-server<1.19.0  X-ABI-XINPUT_VERSION<24
                  X-ABI-XINPUT_VERSION>=25
    Replaces        : None
    Installed Size  : 156.00 KiB
    Packager        : Andreas Radke <[email protected]>
    Build Date      : Fri 05 May 2017 08:24:35 AM EDT
    Install Date    : Sat 13 May 2017 07:33:40 AM EDT
    Install Reason  : Installed as a dependency for another package
    Install Script  : No
    Validated By    : SHA-256 Sum
    

    Thank you so much for your help🙂

    Also, I just noticed that when I right click, it is being recognize as a middle click (I think since it automatically copes/ pastes and no right-click menu shows up).

    Thanks again!

  • @A-User said in Right Click not working on my touchpad after upgrade:

    Here it is: …

    That’s OK. My configuration in Antergos and native Arch is the same. Touchpad works as expected in both. I’m out of ideas, I’m afraid.

  • Thank you anyways though🙂

  • Hi!

    Problem is solved 😀
    Apparently, I simply had to shutdown and restart Antergos instead of just logging in and then back out.

    Thank you so much🙂

upgrade73 touchpad49 click16 Posts 27Views 5745
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.