• Error with antergos-keyring


    It worked. Here are the last few lines.

    gpg: Total number processed: 93
    gpg:              unchanged: 3
    gpg:           new user IDs: 1
    gpg:         new signatures: 2449
    gpg: marginals needed: 3  completes needed: 1  trust model: pgp
    gpg: depth: 0  valid:   1  signed:   8  trust: 0-, 0q, 0n, 0m, 0f, 1u
    gpg: depth: 1  valid:   8  signed:  71  trust: 0-, 0q, 0n, 8m, 0f, 0u
    gpg: depth: 2  valid:  70  signed:  10  trust: 70-, 0q, 0n, 0m, 0f, 0u
    gpg: next trustdb check due at 2017-10-20
    
    

    and

    antergos/antergos-keyring 20170524-1 (antergos-base) [installed]
        Antergos PGP keyring
    
    

    @joekamprad What do you mean by “and please reset /etc/pacman.d/gnupg/gpg.conf to before state then.” Re-edit the keyserver address to

    keyserver hkp://pool.sks-keyservers.net
    
  • @triode13 yes right keyserver hkp://pool.sks-keyservers.net

  • Thanks Joe!

  • I tried all of these different solutions and none of them worked for me.

  • Refreshing the keys fixed the issues for me.

  • how to fix this error ?

     antergos is up to date
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (4) llvm-libs-4.0.0-3  openssl-1.0-1.0.2.l-1  opus-1.1.5-1  pango-1.40.6+9+g92cc73c8-1
    
    Total Download Size:   14.47 MiB
    Total Installed Size:  60.74 MiB
    Net Upgrade Size:       0.57 MiB
    
    :: Proceed with installation? [Y/n] y
    :: Retrieving packages...
     llvm-libs-4.0.0-3-x86_64                      12.1 MiB   109K/s 01:53 [#######################################] 100%
     openssl-1.0-1.0.2.l-1-x86_64                1572.1 KiB   110K/s 00:14 [#######################################] 100%
     opus-1.1.5-1-x86_64                          343.3 KiB  75.3K/s 00:05 [#######################################] 100%
     pango-1.40.6+9+g92cc73c8-1-x86_64            501.4 KiB  86.6K/s 00:06 [#######################################] 100%
    (4/4) checking keys in keyring                                         [#######################################] 100%
    (4/4) checking package integrity                                       [#######################################] 100%
    error: llvm-libs: signature from "Evangelos Foutras <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/llvm-libs-4.0.0-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: openssl-1.0: signature from "Pierre Schmitz <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/openssl-1.0-1.0.2.l-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: opus: signature from "Jan Alexander Steffens (heftig) <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/opus-1.1.5-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: pango: signature from "Jan Alexander Steffens (heftig) <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/pango-1.40.6+9+g92cc73c8-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: failed to commit transaction (invalid or corrupted package (PGP signature))
    Errors occurred, no packages were upgraded.
    
  • @joekamprad I had this problem for the first time this morning and this solved it. Thanks a lot :)

  • Other than temporarily modifying /etc/pacman.d/gnupg/gpg.conf, none of the alternative solutions worked for me. Curious, I wanted to see if I could find a another way. Re-installing antergos-keyring and archlinux-keyring worked as well.

    sudo pacman -S antergos-keyring
    sudo pacman -S archlinux-keyring
    sudo pacman-key --populate archlinux antergos
    sudo pacman-key --refresh-keys
    

    If after executing the pacman-key --refresh-keys command throws an error, wait a bit and try again. It worked immediately for me in one of my Antergos installs, but in another one, it didn’t work for me even after an hour. It was bedtime, I powered down the computer, and in the morning, refreshing the keys worked.

  • @ferthelet Thanks!

  • @triode13 said in Error with antergos-keyring:

    gpg: refreshing 94 keys from hkp://pool.sks-keyservers.net
    gpg: keyserver refresh failed: Address family not supported by protocol
    ==> ERROR: A specified local key could not be updated from a keyserver

    if someone have this error like me and triode13 “Address family not supported by protocol” use server with ipv4

    sudo pacman-key --refresh-keys --keyserver ipv4.pool.sks-keyservers.net
    
    
  • I’ve had this error for the past couple of days and the only thing that worked for me was removing the antergos-keyring package (antergos-keyring-20150806-1) and re-installing it from the local package cache. The new package (antergos-keyring-20170524-1) then became available as an update and I ran a normal upgrade.

    sudo pacman -R antergos-keyring
    sudo pacman -U /var/cache/pacman/pkg/antergos-keyring-20150806-1.pkg.tar.xz
    sudo pacman -Syu
    

    Maybe someone else can explain why this worked. I don’t know, but maybe it will help someone who hasn’t had any luck with refreshing keys and cleaning the cache.

  • @dev-null after cleaning cache /var/cache/pacman/pkg/antergos-keyring-20150806-1.pkg.tar.xz
    is not aviable anymore … but you can also download the package manually:
    http://mirrors.antergos.com/antergos/
    and install with pacman -U

  • could anyone help how to fix this?

    sudo pacman-key --refresh-keys
    gpg: refreshing 9 keys from hkp://pool.sks-keyservers.net
    gpg: key BBE43771487328A9: “Bartlomiej Piotrowski [email protected]” not changed
    gpg: key 06096A6AD1CEDDAC: “Laurent Carlier [email protected]” not changed
    gpg: key AFF5D95098BC6FF5: “Maxime Gauduin [email protected]” not changed
    gpg: key AEA529BF122902E5: “Dustin Falgout (Antergos Developer) [email protected]” not changed
    gpg: key 6D6DDA3D2A45C7B4: “Alexandre Filgueira S�nchez (2012/07/15) [email protected]” not changed
    gpg: key A5E9288C4FA415FA: “Jan Alexander Steffens (heftig) [email protected]” not changed
    gpg: key 7F2D434B9741E8AC: “Pierre Schmitz [email protected]” not changed
    gpg: key 51E8B148A9999C34: “Evangelos Foutras [email protected]” not changed
    gpg: key CDBD406AA1AA7A1D: “Antergos Build Server (Automated Package Build System) [email protected]” not changed
    gpg: Total number processed: 9
    gpg: unchanged: 9

    $ sudo pacman -Syyu
    :: Synchronizing package databases…
    antergos 150.2 KiB 115K/s 00:01 [#######################################] 100%
    core 124.9 KiB 110K/s 00:01 [#######################################] 100%
    extra 1683.1 KiB 155K/s 00:11 [#######################################] 100%
    community 3.8 MiB 120K/s 00:33 [#######################################] 100%
    multilib 176.5 KiB 109K/s 00:02 [#######################################] 100%
    :: Starting full system upgrade…
    resolving dependencies…
    looking for conflicting packages…

    Packages (8) lib32-libdrm-2.4.81-1 libdrm-2.4.81-1 libx264-2:148.20170519-1 libx264-all-2:148.20170519-1
    llvm-libs-4.0.0-3 openssl-1.0-1.0.2.l-1 opus-1.1.5-1 pango-1.40.6+9+g92cc73c8-1

    Total Download Size: 15.69 MiB
    Total Installed Size: 64.77 MiB
    Net Upgrade Size: 0.54 MiB

    :: Proceed with installation? [Y/n] y
    :: Retrieving packages…
    libdrm-2.4.81-1-x86_64 226.5 KiB 159K/s 00:01 [#######################################] 100%
    libx264-2:148.20170519-1-x86_64 370.1 KiB 204K/s 00:02 [#######################################] 100%
    libx264-all-2:148.20170519-1-x86_64 512.0 KiB 146K/s 00:04 [#######################################] 100%
    llvm-libs-4.0.0-3-x86_64 12.1 MiB 120K/s 01:43 [#######################################] 100%
    openssl-1.0-1.0.2.l-1-x86_64 1572.1 KiB 119K/s 00:13 [#######################################] 100%
    opus-1.1.5-1-x86_64 343.3 KiB 151K/s 00:02 [#######################################] 100%
    pango-1.40.6+9+g92cc73c8-1-x86_64 501.4 KiB 123K/s 00:04 [#######################################] 100%
    lib32-libdrm-2.4.81-1-x86_64 135.6 KiB 172K/s 00:01 [#######################################] 100%
    (8/8) checking keys in keyring [#######################################] 100%
    (8/8) checking package integrity [#######################################] 100%
    error: libdrm: signature from “Laurent Carlier [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/libdrm-2.4.81-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: lib32-libdrm: signature from “Laurent Carlier [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/lib32-libdrm-2.4.81-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: libx264: signature from “Maxime Gauduin [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/libx264-2:148.20170519-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: libx264-all: signature from “Maxime Gauduin [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/libx264-all-2:148.20170519-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: llvm-libs: signature from “Evangelos Foutras [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/llvm-libs-4.0.0-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: openssl-1.0: signature from “Pierre Schmitz [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/openssl-1.0-1.0.2.l-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: opus: signature from “Jan Alexander Steffens (heftig) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/opus-1.1.5-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: pango: signature from “Jan Alexander Steffens (heftig) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/pango-1.40.6+9+g92cc73c8-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: failed to commit transaction (invalid or corrupted package (PGP signature))
    Errors occurred, no packages were upgraded.

  • No idea if it will help, but I ran pacman -Scc first and it worked fine.

  • @Sam-N

    $ sudo rm -R /var/lib/pacman/sync/
    $ sudo pacman -Syy
    $ sudo pacman-key --refresh-keys
    $ sudo pacman -Syu
    
  • @joekamprad sorry it didnt work boss. same error happening on invalid or corrupt file.
    is anyone from antergos team working on this to push some update to fix this issue ?

    i dont know why they dont test it properly before pushing it for users?

  • it is kind a bit bigger deal with this keyring stuff…

    sudo pacman -U /var/cache/pacman/pkg/antergos-keyring-20150806-1.pkg.tar.xz
    

    If you have this still there if not do a pacman -Syyu
    and do not delete antergos-keyring-20170524-1.pkg.tar.xz
    then install this with :

    sudo pacman -U /var/cache/pacman/pkg/antergos-keyring-20170524-1.pkg.tar.xz
    
  • @joksik said in Error with antergos-keyring:

    @triode13 said in Error with antergos-keyring:

    gpg: refreshing 94 keys from hkp://pool.sks-keyservers.net
    gpg: keyserver refresh failed: Address family not supported by protocol
    ==> ERROR: A specified local key could not be updated from a keyserver

    if someone have this error like me and triode13 “Address family not supported by protocol” use server with ipv4

    sudo pacman-key --refresh-keys --keyserver ipv4.pool.sks-keyservers.net
    
    

    Good to know for future reference. I have the ivp6 stack disabled on both computers, but was still able to get the keyservers refreshed by reinstalling antergos-keyrings and antergos keyrings. I was wondering if the keyserver refresh was pulling from ipv6. If I encounter the same issue in the future, I’ll try your solution. I need to disable the entire ipv6 stack for my VPN to work properly. Re-enabling it temporarily might be a possible solution as well. Anyways, I’ve taken good notes. Thanks to everyone!

  • @joekamprad lol error gone. i succesfully installed it.

    if i use pacman -Syu command in terminal then i get list of all this below packages which gave me error in terminal while installing.
    lib32-libdrm-2.4.81-1 libdrm-2.4.81-1 libx264-2:148.20170519-1 libx264-all-2:148.20170519-1
    llvm-libs-4.0.0-3 openssl-1.0-1.0.2.l-1 opus-1.1.5-1 pango-1.40.6+9+g92cc73c8-1

    but same downloaded tar xz files if i go in var/cache/pacman/pkg and manually mouse right click and install all tar.xz files using graphical pamac end then all installled succesfully.

    this is weird…

    does that mean terminal sucks and pamac frontend rocks ???

  • @Sam-N local install do not check pgp keys by default so you get no errors caus of this only…

error328 Posts 57Views 26411
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.