• Cnchi "Cannot create download package list (metalinks)"


    I am using the Nvidia iso as it is the only way to get Antergos to work (I have no integrated graphics (FX 8350)) and when I try to run the installer, it crashes at the user creation screen, saying it “Cannot create download package list (metalinks)”. I have tried editing Packages.xml (removing xorg-settings and antergos-gsettings because I had seen problems with them elsewhere) to no avail. Is anyone getting similar problems?

  • Hi,

    We’ve had some problems with building some packages lately in the build server (but don’t know if it’s related or not).

    Could try again and post your log? (it’s in /tmp/cnchi.log)

    Use paste2.org or a similar service and put the link here so we can have a look at it.

    Thanks!

  • I created the Paste2 link for the log. https://paste2.org/Uks1EK21

  • 2017-05-24 06:50:49 [ERROR] metalink.py(124) create(): Can't find these packages: lib32-mesa-libgl
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • This package is old. This means you’re using an old packages list. Are you using an old iso? Always use the latest.

    Your Cnchi (Antergos Installer) version is old.

    If you did use the latest iso, It could be to that you didn’t wait for cnchi to update itself or that by some unknown error it didn’t manage to update itself.

    When it opens, please, wait a bit until a message bubble is shown telling that everything is updated.

  • As he say he is using “the Nvidia Iso”

    su
    find /usr/share/cnchi -type f -print0 | xargs -0 sed -i 's/lib32-mesa-libgl/lib32-mesa/g'
    

    may help …

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @bricksey said in Cnchi "Cannot create download package list (metalinks)":

    I am using the Nvidia iso

    Geez… I didn’t see this.

    That’s an old iso. You should use this packages.xml :

    https://raw.githubusercontent.com/Antergos/Cnchi/master/data/packages.xml

    You can download it with wget and use it, or do what @joekamprad suggests.

    Cheers!

  • @joekamprad 's method worked for me. Thanks all!

cnchi105 download15 metalinks10 Posts 8Views 608
Log in to reply