• Stuck at "loading initial ramdisk" after upgrade (kernel update...)


    Hello,

    first of all, I’m a newbie and I haven’t ever experienced such a problem.
    So, I don’t really know what I have to do now…

    After a system update (There was a kernel update to 4.11.2-1 and a few other updates) I restarted my antergos, but it doesn’t boot anymore.
    It stuck at “loading initial ramdisk”.

    I tried the “safe boot”, but it stucks at the same point.

    Now I don’t know which next steps I should do… and how…

    Many thanks in advance.

  • Choose advanced options on Bootscreen and then Fallback.

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @spite1705 said

    After a system update (There was a kernel update to 4.11.2-1

    I always switch to the lts kernel in such cases. So, if you have selected it to be installed during installation , just choose it in the GRUB screen.
    If you haven t, install it now:

    1. Press CTRL+ Alt+ f2 to get to a tty screen.
    2. Type in your username and password when prompted.
    3. Install lts kernel sudo pacman -S linux-lts (also install linux-lts-headers) if you need it
    4. Regenerate your GRUB: grub-mkconfig -o /boot/grub/grub.cfg
    5. Reboot and choose the lts kernel.
      `

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch

    1. Press CTRL+ Alt+ f2 to get to a tty screen.

    Where should I try this?
    In the GRUB screen is this not working.

    @joekamprad said in Stuck at "loading initial ramdisk" after upgrade (kernel update...):

    Choose advanced options on Bootscreen and then Fallback.

    Stucks at same point.

  • CTRL+ Alt+ f2 should passeed after grub …
    If it then too not working you can try to start in non graphical environment:
    Press “e” inside grub and add:

    systemd.unit=multiuser.target
    

    to the kernel parameter line between: rw quiet and resume=UUID.

    like this:
    rw quiet systemd.unit=multiuser.target resume=UUID.
    then pressing ctrl+X to boot
    if you are lucky system starts to CLI and you can do what anarch say: (up from 2.)
    …may you need to use

    dhcpcd
    

    to start network

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad

    I tried it, but didn’t work for me.

    Trying to press ‘ctrl’ and ‘x’, I realized, that pressing ‘ctrl’ removes (sometimes…?) a character in the editor.
    Maybe ctrl + alt + f2 is not working for me, because the ctrl-key ist not working properly in grub…

  • [ctrl + alt + f2] has no function inside grub, only after system has boot…

    to save and boot after adding systemd.unit=multiuser.target you can also use [F10]

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Yes, I used F10 to save, but didn’t work.

    I created a live usb with arch and chroot the filesystem. (https://mzanfardino.wordpress.com/2012/05/24/repairing-broken-arch-linux/)
    Then I installed the lts kernel as @anarch said.

    Now I can boot to my system, if I select the lts kernel.

    How do I repair the old kernel?
    Downgrade or wait for a new kernel update or maybe there is a third option…?

  • @spite1705 said

    How do I repair the old kernel?
    Downgrade or wait for a new kernel update or maybe there is a third option…?

    No real need to hurry. Just wai and a new update will sort it out sooner or later…
    By the way, the lts kernel is by no means inferior to the current one. If you don t run any extra new hardware, actually being on the lts kernel is preferable. More conservative, thus more stable!
    Welcome back!

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Today I updated the kernel to the new version 4.11.3-1
    Unfortunataly I still can’t boot with this one.

  • Kernel update to 4.11.4-1didn’t work as well.

    Any other idea how to fix the current kernel version?

  • Update to kernel 4.11.6-1 fixed it finally.

stuck33 loading22 initial3 ramdisk3 Posts 13Views 3713
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.