• numix-icon-theme - signature ... is unknown trust


    Hi,
    I am getting this error:

    $ sudo pacman -Syu
    :: Synchronizing package databases…
    antergos is up to date
    core is up to date
    extra is up to date
    community is up to date
    multilib is up to date
    seblu is up to date
    :: Starting full system upgrade…
    resolving dependencies…
    looking for conflicting packages…
    
    Packages (1) numix-icon-theme-1:0.r1942-1
    :: Retrieving packages…
    numix-icon-theme-1:0.r1942-1-any 3,6 MiB 7,95M/s 00:00 [########################################] 100%
    (1/1) checking keys in keyring [########################################] 100%
    (1/1) checking package integrity [########################################] 100%
    error: numix-icon-theme: signature from “Antergos Build Server (Automated Package Build System) [email protected] is unknown trust
    Errors occurred, no packages were upgraded.
    

    Please advise.

  • Same here…

    I already tried repopulating keyrings with no joy.

  • Same here, also happens for
    libmateweather-1.18.1-1-x86_64.pkg.tar.xz
    brisk-menu-0.4.0-1-x86_64.pkg.tar.xz

    I also repopulated the keyrings (antergos-keyring-20150806-1 archlinux-keyring-20170320-1)
    Same result.

    Edit: Hmm… antergos keyring sounds a little bit old…

  • I believe I’m running into the same issue:

    error: numix-icon-theme: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/numix-icon-theme-1:0.r1942-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] Y
    error: numix-icon-theme-square: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/numix-icon-theme-square-1:0.r83_9-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] Y
    error: failed to commit transaction (invalid or corrupted package (PGP signature))
    Errors occurred, no packages were upgraded.
    
    

    I just uninstalled both packages using sudo pacman -R numix-icon-theme numix-icon-theme-square so I could get through the other seemingly more important updates :)

    I’m sure someone will figure something out – not a huge deal for me, just need to get some work done!

    Cheers and Good Luck.

  • pub  rsa4096/CDBD406AA1AA7A1D
         created: 2014-08-04  expires: 2019-05-10  usage: SC  
         trust: full          validity: unknown
    sub  rsa4096/5F916D2943567287
         created: 2014-08-04  expired: 2017-05-23  usage: E   
    [ unknown] (1). Antergos Build Server (Automated Package Build System) <[email protected]>
    
    

    expired: 2017-05-23
    @developers ??? !help

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • This appears to be fixed now with an update to the key. Try sudo pacman-key --refresh-keys

  • nop… did

    sudo pacman-key --refresh-keys
    

    no electronic cigar

    did

    $ rm -R /etc/pacman.d/gnupg/
    $ pacman-key --init
    $ pacman-key --populate archlinux antergos
    

    still no white vapor

  • sudo pacman-key --refresh-keys did work for me. This is likely what did it.

    gpg: key CDBD406AA1AA7A1D: "Antergos Build Server (Automated Package Build System) <[email protected]>" 1 new signature
    
  • not to me… 8/
    also did:

    sudo pacman -Sy antergos-keyring 
    

    with no joy

  • I got signature error for for libmateweather and brisk-menu. @alanaktion’s tip with pacman keys refresh, followed by mirrors refresh with reflector, has solved the signature error here.

    A oneliner:

    sudo pacman-key --refresh-keys && sudo reflector --age 8 --fastest 128 --latest 64 --number 32 --sort rate --save /etc/pacman.d/mirrorlist && yaourt -Syyua && sync
    
  • @just said in numix-icon-theme - signature ... is unknown trust:

    sudo pacman-key --refresh-keys

    Sounds good, unfortunately the refreshing is not working for me:

    sudo pacman-key --refresh-keys
    gpg: WARNING: server 'dirmngr' is older than us (2.1.20 < 2.1.21)
    gpg: refreshing 94 keys from hkp://pool.sks-keyservers.net
    gpg: keyserver refresh failed: No keyserver available
    ==> ERROR: A specified local key could not be updated from a keyserver.
    

    Maybe it’s because I’m behind a corporate proxy (http(s)_proxy variables etc. are set)? Can I refresh the keys manually?

  • @kalopsian No need to remove the packages. You can use $ sudo pacman -Syu --ignore numix-icon-theme,numix-icon-theme-square

  • @alanaktion’s tip + mirrors resfresh have solved not only libmateweather and brisk-menu signatures error in Mate, but also the same error with dolphin-root, kate-root and numix-icon-theme pkgs in Plasma.

    @rfor said in numix-icon-theme - signature ... is unknown trust:

    Maybe it’s because I’m behind a corporate proxy (http(s)_proxy variables etc. are set)?

    It’s more than possible. Your system cannot reach a keyserver. It’s not possible to refresh (update) the keys without access to a server which holds them.

    Can I refresh the keys manually?

    Yes, you can. Though it may be risky. This sequence deletes all Antergos and Arch keys, existing in your system, and then re-installs them from scratch. It’s like a heavy bomb dropped down on a computer, but usually it repairs everything.

    Use at your own risk. Better if your system is backed up.

    sudo pacman -Scc  <-- reply with explicit y to the first question
    sudo pacman -Syy
    sudo pacman -S haveged
    sudo haveged -w 1024
    sudo pacman-key --init
    sudo pacman-key --populate archlinux antergos
    sudo pkill haveged
    sudo pacman -S archlinux-keyring antergos-keyring
    sudo pacman -Syu
    
  • I have the same problem but also with pacmac update :

    erreur : numix-icon-theme: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is unknown trust
    :: Le fichier /var/cache/pacman/pkg/numix-icon-theme-1:0.r1942-1-any.pkg.tar.xz est corrompu (paquet invalide ou corrompu (signature PGP)).
    Voulez-vous le supprimer ? [O/n] 
    erreur : pamac: signature from "Antergos Build Server (Automated Package Build System) <[email protected]>" is unknown trust
    :: Le fichier /var/cache/pacman/pkg/pamac-4.3.5-1-x86_64.pkg.tar.xz est corrompu (paquet invalide ou corrompu (signature PGP)).
    Voulez-vous le supprimer ? [O/n]
    
  • Refreshing pacman’s keys with

    sudo pacman-key --refresh-keys
    

    and pacman’s mirrors with

    sudo reflector --age 8 --fastest 128 --latest 64 --number 32 --sort rate --save /etc/pacman.d/mirrorlist
    

    solve all signature errors here. In Antergos and in native Arch, which uses some pkgs from [antergos] repo. Thank you, @alanaktion.

    sudo pacman-key --refresh-keys && sudo reflector --age 8 --fastest 128 --latest 64 --number 32 --sort rate --save /etc/pacman.d/mirrorlist && yaourt -Syyua && sync
    

    If there’s no reflector in the system, install it with:

    sudo pacman -Syu reflector
    

    No other actions or packages are needed. Pacman and reflector do the job.

  • @just I did all your command and i still have the exact same error :/

  • @Ouraios Please, run in termianl (copy-paste):

    export LANG=C && sudo pacman-key --refresh-keys
    

    and post back here the full output. It is a very long output. Pay attention to not miss the final 5-10 lines. Do not expect a quick answer. More commands are needed. It may take a while. Thanks.

  • @just , no problem thank you to help me ! Askminet tell it’s spam if i c/c all the output, so i just post the final lines (the most important one i guess), i tried to upgrade packages after that and still got the error

    > export LANG=C && sudo pacman-key --refresh-keys
    [...]
    gpg: Total number processed: 93
    gpg:              unchanged: 59
    gpg:         new signatures: 816
    gpg: marginals needed: 3  completes needed: 1  trust model: pgp
    gpg: depth: 0  valid:   1  signed:   6  trust: 0-, 0q, 0n, 0m, 0f, 1u
    gpg: depth: 1  valid:   6  signed:  73  trust: 0-, 0q, 0n, 6m, 0f, 0u
    gpg: depth: 2  valid:  70  signed:  10  trust: 70-, 0q, 0n, 0m, 0f, 0u
    gpg: next trustdb check due at 2017-10-20
    
    
  • @Ouraios said in numix-icon-theme - signature ... is unknown trust:

    so i just post the final lines (the most important one i guess),

    That’s fine. Your 93 keys seem to be in good state. Mine are 95, but I don’t remember where 2 more keys are coming from. It doesn’t matter. Your keys are good. Stop.

    Next step. Please, (re)-install reflector. Re-installation of a pkg is the most safe operation that might exist in Arch. Go ahead, run, post back here the full output of:

    export LANG=C && sudo pacman -Syu reflector
    

    Do not expect a quick answer. It’s a dinner break here :) .

  • @rfor said in numix-icon-theme - signature ... is unknown trust:

    @just said in numix-icon-theme - signature ... is unknown trust:

    sudo pacman-key --refresh-keys

    Sounds good, unfortunately the refreshing is not working for me:

    sudo pacman-key --refresh-keys
    gpg: WARNING: server 'dirmngr' is older than us (2.1.20 < 2.1.21)
    gpg: refreshing 94 keys from hkp://pool.sks-keyservers.net
    gpg: keyserver refresh failed: No keyserver available
    ==> ERROR: A specified local key could not be updated from a keyserver.
    

    Maybe it’s because I’m behind a corporate proxy (http(s)_proxy variables etc. are set)? Can I refresh the keys manually?

    I am also behind a corporate proxy, so I changed from hkp to http in the file /etc/pacman.d/gnupg/gpg.conf
    like this:

    #keyserver hkp://pool.sks-keyservers.net
    keyserver http://pool.sks-keyservers.net
    
pgp signature2 numix10 numix-icon-them1 Posts 65Views 6345
Log in to reply