• Samba service not found (smbd.service)


    Title says it all but while setting up samba shares via nano, I go to start or restart the service and it tells me that the service is straight up not found at all

    [[email protected] ~]$ sudo systemctl start smbd.service
    Failed to start smbd.service: Unit smbd.service not found.
    

    I have tried removing and reinstalling samba but no change…

    Let me know of any more info you need to help in this diagnosis.

  • what gives you:

    cat /usr/lib/systemd/system/smbd.service
    

    and:

    pacman -Qs samba
    pacman -Qs systemd
    

    ???

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • cat /usr/lib/systemd/system/smbd.service

    [Unit]
    Description=Samba SMB/CIFS server
    After=network.target nmbd.service winbindd.service
    
    [Service]
    Type=forking
    PIDFile=/var/run/smbd.pid
    ExecStart=/usr/bin/smbd -D
    ExecReload=/bin/kill -HUP $MAINPID
    
    [Install]
    WantedBy=multi-user.target
    

    pacman -Q samba

    Samba 4.5.8-1
    

    pacman -Q systemd

    systemd 232-8
    
  • Do you do configurations inside:

    /etc/samba/smb.conf
    ?

    you can copy defaults with:

    $ sudo cp /etc/samba/smb.conf.default /etc/samba/smb.conf
    
    systemctl list-unit-files | grep .smbd
    

    will also give some more info, as

    journalctl -xb
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • I do have a copy of defaults as thats the first thing to do in all the guides of how to setup Samba

    systemctl list-unit-files | grep .smbd
    gives no output at all.

    journalctl -xb > /home/myname/journal
    generated a 280mb txt file, trying to get only the last few days worth of journal entries.

    you wouldn`t have a script to filter out

    May 23 09:16:40 Arbiter goa-daemon[4483]: Could not set SSL credentials from '/etc/ssl/certs/ca-certificates.crt': Failed to open file '/etc/ssl/certs/ca-certificates.crt': No such file or directory
    

    MILLIONS (NO JOKE) of times from a text file would you? this is the bulk of that 280mb file.

  • journalctl -b1
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • journalctl -b1 is alot more sane giving me this.
    Pastebin Entry

    running journalctl -b -S yesterday gave me the timeframe i’m looking for and found 16 of this set of lines

    May 22 17:59:50 Arbiter sudo[18185]:     ryan : TTY=pts/0 ; PWD=/home/ryan ; USER=root ; COMMAND=/usr/bin/systemctl start smbd.service
    May 22 17:59:50 Arbiter sudo[18185]: pam_unix(sudo:session): session opened for user root by (uid=0)
    May 22 17:59:50 Arbiter sudo[18185]: pam_unix(sudo:session): session closed for user root
    
  • I do not know why your system Logs are insane long 🙂
    I’m on the road and on a smartphone
    It is Kind Impossible to get this reading…
    I will have a Look later

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • @Nymmie said in Samba service not found (smbd.service):

    Failed to start smbd.service: Unit smbd.service not found.
    May simple

    systemctl status smbd.socket
    

    is running???
    Logs say nothing i can bring together with samba…

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • systemctl status smbd.socket

    smbd.socket - Samba SMB/CIFS server socket
       Loaded: loaded (/usr/lib/systemd/system/smbd.socket; disabled; vendor preset:
       Active: inactive (dead)
       Listen: [::]:445 (Stream)
     Accepted: 0; Connected: 0
    

    systemctl status smbd.service
    Unit smbd.service could not be found

    EDIT: WTF??? Just for shits, I tried systemctl enable smbd.service again… and it worked…

    I’m thinking this is like the programmers joke of ‘it doesn’t work… Why?’ and ‘it works… Why?’

  • @Nymmie said in Samba service not found (smbd.service):

    May 23 09:16:40 Arbiter goa-daemon[4483]: Could not set SSL credentials from ‘/etc/ssl/certs/ca-certificates.crt’: Failed to open file ‘/etc/ssl/certs/ca-certificates.crt’: No such file or directory

    There is something messed up on you installation: (some failures from your logs)

    No such file or directory / Unit smbd.service could not be found / 
    
    Mar 17 19:34:47 Arbiter gnome-shell[760]: JS LOG: Failed to launch ibus-daemon: Failed to execute child process "ibus-daemon" (No such file or directory)
    
    Mar 17 19:34:53 Arbiter libcanberra-login-sound.desktop[887]: Failed to play sound: File or data not found
    
    Mar 17 19:34:54 Arbiter gnome-settings-[856]: g_task_return_error: assertion 'error != NULL' failed
    Mar 17 19:34:54 Arbiter gnome-settings-[856]: Failed to StopUnit service: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit gnome-user-share-webdav.service not loaded.
    Mar 17 19:34:54 Arbiter gnome-settings-[856]: Failed to StopUnit service: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit rygel.service not loaded.
    Mar 17 19:34:54 Arbiter gnome-settings-[856]: Failed to StopUnit service: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit vino-server.service not loaded.
    
    Mar 17 19:42:03 Arbiter gnome-photos[15039]: Module '/usr/lib/gegl-0.3/matting-levin.so' load error: libumfpack.so.5: cannot open shared object file: No such file or directory
    Mar 17 19:42:04 Arbiter gnome-photos[15039]: Module '/usr/lib/gegl-0.3/exr-load.so' load error: libIlmImf-2_2.so.22: cannot open shared object file: No such file or directory
    Mar 17 19:42:04 Arbiter gnome-photos[15039]: Module '/usr/lib/gegl-0.3/lens-correct.so' load error: liblensfun.so.1: cannot open shared object file: No such file or directory
    Mar 17 19:42:04 Arbiter gnome-photos[15039]: Module '/usr/lib/gegl-0.3/exr-save.so' load error: libIlmImf-2_2.so.22: cannot open shared object file: No such file or directory
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

samba28 service8 smbd.service1 Posts 11Views 6083
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.