• Xfce - application icons not displayed in 'notification area'


    DELL Inspiron 5559 laptop
    Processor: IntelCore i7-6500U CPU 2 Cores, 4 Logical Processors
    Integrated Graphics Processor: Intel HD Graphics 520
    Discrete Graphics Processor: AMD Radeon R5 M335
    Drive: Crucial CT750MX3 SSD size: 750GB
    Memory: 16GB 1600MHz DDR3

    I have just installed Antergos Xfce and everything went well, but I have just noticed that the ‘pamac-tray’, ‘Network Manager Applet’ and ‘redshift-gtk’ icons are all missing from the ‘notification area’. They were there initially but now all suddenly disappeared when I selected and clicked on one of the icons.

    When I hover the mouse pointer over the ‘Notification Area’ there is a Tooltip info displayed for each icon, so the icons are there but just not displayed. Also the ‘pamac-tray’ icon is displayed when there is an update but then disappears again when system is up-to-date. Appart from that the system is working very well, fast and snappy, so pleased with the performance.

    I checked panel preferences, Items tab, tried to edit ‘Notification Area’ item and toggle the Hidden ‘check-box’ but didn’t make any difference. I also tried to google a solution but couldn’t see anything recent that was relevant to my situation.

    I’m not an expert on Linux but can use terminal if I know the correct syntax. Any help would be appreiated.

  • I was thinking what changes I had made after the original installation that may have caused the icons to behave this way, and the only changes were…

    1. Added the ‘Whisker Menu’ to the top panel and removed the default ‘Applications Menu’

    2. Installed Redshift (adjusts colour temperature of screen in evenings)

    I decided to add the default ‘Applications Menu’ back on the top Panel and rebooted and the three application icons are now visible in the ‘notification area’. So maybe this is needed somehow to display the icons.

    Later, I removed the default ‘Applications Menu’ again to see if it causes the same problem again and after a reboot, the icons are still visible in the ‘notification area’.

    Not sure what’s going on here but the icons are behaving normally again so I will mark this topic as SOLVED.

icons23 xfce50 application19 Posts 2Views 259
Log in to reply