• Lenovo t400 VGA port not working


    Being new to Linux I am also new to asking for help in a Linux forum so please forgive any simple steps I may have missed. For starters here is my video hardware:
    00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller
    (rev 07) (prog-if 00 [VGA controller])
    Subsystem: Lenovo Device 20e4
    Flags: bus master, fast devsel, latency 0, IRQ 32
    Memory at f4400000 (64-bit, non-prefetchable) [size=4M]
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 1800 [size=8]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915
    [1_1495388285046_journal](Uploading 100%) [0_1495388285045_Xorg.0.log](Uploading 100%)

    I have also uploaded those logs that I could manage to attache to an email to get them to this box I am currently working on. I have tried to google for an answer and while I find many many posts on simular subjects never one specific to Antergos + Thinkpads + “No VGA out”. I was however able to find general Arch + Thinkpad + VGA so I tried many of those steps and after downloading all manor of things, restarting each time, and a nasty little bit of trying to run Xorg or something from sudo and getting stuck in a login loop, I figured it was time to ask for help. I got all my file permissions changed and am no longer in a login loop by the way. Google helped a bunch there.

    Currently I am running a T400 and was trying to manually install Arch on it. While Arch was easy enough to install I kept having issues getting a desktop environment loaded so I ended up going with Antergos and choosing XFCE. Big thank you to Antergos, made things so much easier for a noob like myself. I would like to connect a larger external screen while working at my desk so I attach a VGA to DVI adapter to my VGA port and then attach a DVI to HDMI cable from that adapter to my external monitor. However the monitor has no signal and the laptop does not see the monitor even if I use the FN + F7 keys to enable VGA out.

    Can anybody point me in the right direction with search term ideas so I can try google out again?

  • –update–
    verified latest intel drivers are downloaded "xf86-video-intel"
    further more took the time to download "xorg-drivers"
    question is there a way to tell which drivers xorg is using? Because it is working now but I am not sure why.

    note to future noob
    All I did was type the following at the command prompt: “sudo pacman -S xf86-video-intel xorg-drivers”

lenovo16 vga5 port2 t4001 Posts 2Views 526
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.