• HDCP support


    Hey guys,
    when I watch movies via AmazonPrime it wont load them in HD quality as HDCP seems to not be supported on my system, although it is perfectly HDCP compliant. Neither Firefox nor Chromium will work.

    When I run my Windows install, everything works just fine. The information I found so far states that HDCP support is present in the current kernel and proprietary nVidia driver, which I both use.

    Is there some setting I need to enable, to get Amazon to stream in HD? I’d really like to get rid of my Windows install completely, but this still holds me back.

    Cedric

  • @citiroller said in HDCP support:

    HDCP

    Widevine Content Decryption Module is what youn need (as far as i know…)
    Tith is accessable with two solutions:
    chromium-widevine browser package
    vivaldi browser package

    both aviable from Antergos Repo.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • The Widevine Content Decryption Module is installed in Chromium (chromium-widevine browser package) and Firefox (by default). That’s why streaming works at all. Before I enabled this plugin, I got an error message telling me to enable it.
    Now Amazon plays movies but refuses to play in HD quality, as their player thinks my system doesn’t support HDCP.
    Now I get a message like this: “The video is being played in standard resolution, because your hardware, HDMI-cable or Monitor doesn’t support HDCP for HD playback.” (translated from German)
    But my system is perfectly HDCP compliant, as HD streaming works without a problem on my windows install.

    Edit: HD playback doesn’t work with Vivaldi either, only SD playback as in Chromium and Firefox.
    Edit 2: Same issue in Google Chrome, SD playbacks works fine, but Amazon refuses to play in HD with the same info message.

  • user-agent-switcher
    Is what i would try then…
    I do not use Amazon Prime so i can not test…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • This doesn’t help either. When I switch to another “browser” amazon tells me either to install microsoft silverlight for DRM or update my browser to the latest version. With internet explorer, amazon wants me to install activex etc. (The playback doesn’t even start with any other profile than default chrome)
    I think it should be the same for Netflix as they probably use HDCP encryption for HD streams as well.

    Why does this DRM sh*t never works :D Sometimes I get why people pirate, because it’s easier…

  • As you can see no problem here to watch HD AmazonPrime:

    alt text

    So looks like it has something to do with configuration or graphic drivers on your system!

    can you post output from

    $ sudo lspci
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • 00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
    00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
    00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
    00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
    00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
    00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
    00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
    00:1c.5 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 6 (rev c4)
    00:1c.6 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c4)
    00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
    00:1f.0 ISA bridge: Intel Corporation Z77 Express Chipset LPC Controller (rev 04)
    00:1f.2 SATA controller: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
    00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
    01:00.0 VGA compatible controller: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1)
    01:00.1 Audio device: NVIDIA Corporation Device 10f1 (rev a1)
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 09)
    04:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 03)
    
  • @citiroller said in HDCP support:

    GeForce GTX 1060

    so you are using nvidia closed source driver, that should work… do you have pepper flash installed?
    And what is your DE?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • Yes I’m running the proprietary Nvidia drivers (381.22) from the Antergos repo.
    The pepper-flash package from the antergos repos is installed.
    I’m currently using Gnome, but I installed it after I started with KDE, so not the default Antergos Gnome setup I suppose.

  • only thing that comes to my mind is to einstall driver with nvidia-installer from Antergos:

    $ sudo pacman -S nvidia-installer
    nvidia-installer -t
    

    if no error comes out:

    $ sudo nvidia-installer
    

    There is also a package with firmwares for nvidia cards aviable, but i am not shure if there is one for your inside:

    yaourt -S nouveau-fw
    

    This is for nouveau driver but as ArchWiki says this works also for nvidia drivers…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • Well, now I remember why I didn’t use nvidia-installer in the first place and just installed the nvidia package from the repo.
    nvidia-installer -t has the following output:

    2017-05-20 12:35:11 [INFO]: Antergos Nvidia Installer v1.12
    2017-05-20 12:35:11 [INFO]: All logs will be stored in /tmp/nvidia-installer.log
    2017-05-20 12:35:11 [INFO]: Running the installer in testing mode...
    2017-05-20 12:35:11 [ERROR]: Couldn't find a driver suitable for your graphics card.
    

    Is it possible that a GTX 1060 is to new for the Nvidia installer? Seems I’m running into some more problems here, sorry for that…

  • Strange i remember an output wich says card is not in database on cards like yours… if you take a look to nvidia side it gives you not the latest nvidia Driver for your Card… but as i remember we have some users with same cards… can you give the output of:

    nvidia-installer -f -t
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • @joekamprad said in HDCP support:

    nvidia-installer -f -t

    2017-05-21 00:05:27 [INFO]: Antergos Nvidia Installer v1.12
    2017-05-21 00:05:27 [INFO]: All logs will be stored in /tmp/nvidia-installer.log
    2017-05-21 00:05:27 [INFO]: Running the installer in testing mode...
    2017-05-21 00:05:27 [WARNING]: Your graphics card is not in our database. Forcing nvidia driver installation anyways...
    2017-05-21 00:05:27 [INFO]: Installing nvidia driver...
    2017-05-21 00:05:27 [INFO]: Removing conflicting packages...
    2017-05-21 00:05:27 [INFO]: pacman -Rs --noconfirm --noprogressbar --nodeps xf86-video-nouveau
    2017-05-21 00:05:27 [INFO]: Downloading and installing driver packages, please wait...
    2017-05-21 00:05:27 [INFO]: pacman -Sqy --noconfirm --noprogressbar nvidia libvdpau lib32-nvidia-utils lib32-libvdpau
    2017-05-21 00:05:27 [INFO]: Unpatching /usr/share/applications/nvidia-settings.desktop...
    2017-05-21 00:05:27 [INFO]: sed -i s|Exec=optirun -b none /usr/bin/nvidia-settings -c :8|Exec=/usr/bin/nvidia-settings| /usr/share/applications/nvidia-settings.desktop
    2017-05-21 00:05:27 [INFO]: Creating /etc/X11/xorg.conf.d/20-nvidia.conf file...
    2017-05-21 00:05:27 [INFO]: Installation finished. Nothing has been modified as testing mode was ON.
    

    Here you go… My graphics card is indeed not in your database. Should I try running it in normal mode, not testing mode?

  • Yes give it a try!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • Sadly reinstalling the graphics driver nor installing the firmware package did help. I can still watch the stream, but not in HD quality…

  • alt text
    do you sync to your monitor here?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • It was set to Auto before, still no difference… sadly.

  • So no one else can help me solving this problem? I really have no clue why HDCP wont work with my setup as it is working on the same machine under windows.
    Should I ask at the nVidia forums about this issue? Maybe it’s driver related.

  • do you have ffmpeg installed?

    pacman -Qs ffmpeg
    

    But yes i do not have any more idea… :droplet:

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

nvidia100 amazon2 hdcp1 prime5 Posts 19Views 741
Log in to reply