• Cannot change Wallpaper for Login Screen

    Hi everybod,
    I habe a small Problem and I you can help me.
    I cannot change the Background of the Login Screen.
    I choose the correct Wallpaper in the settings, but this is ignored.
    What can I do?

  • Hi @pdr2002 !

    First it would be polite to greet …
    Second we do not know what you use: lightdm, gdm, etc …

    Finally, missing information

    Ahh, Welcome :) ;)

  • H Judd,
    I am sorry, I was in a hurry so I wrote a little bit short.
    I still have the standard Login-Manager which is installed at the beginning. I did not change it.
    I hope this helps?

  • @pdr2002 Hello!

    Change the path to image to the location of the image and image.jpg to the name of your image. Then logout and change the wallpaper.

    $ sudo cp /path/to/Image.jpg /usr/share/antergos/wallpapers

    Hope this helps :)

  • @moredoor
    Hi moredoor,

    Thanks for the help.

    I did what you suggested, but it still does not work…


  • is the standard lightdm-webkit2-greeter not only take random images from that folder (/usr/share/antergos/wallpapers) ?

    background_images = /usr/share/antergos/wallpapers

    do not know if:

    background = /path/to/image


  • @joekamprad Hi!

    I took a look into this directory and there are the standard wallpapers, and in addition the one I want, but it is still chosen just one picture called blossom_by_snipes2.jpg

    Thanks for the help

  • You need to change the wallpaper inside lightdm…
    alt text
    alt text

  • @joekamprad Oh man,
    how could I have overseen that one? This helps a lot, but how do I get “my” wallpaper in there? Or is this selection final?
    Sorry for my questions… 😊

  • @moredoor said in Cannot change Wallpaper for Login Screen:

    $ sudo cp /path/to/Image.jpg /usr/share/antergos/wallpapers

    $ sudo cp /path/to/Image.jpg /usr/share/antergos/wallpapers

    Or you provide another path inside lightdm-webkit2-greeter.conf
    With the menu you can choose random or you select just one you want to use…

  • @joekamprad Thanks a lot for the tips.
    My pictures are already in the directory /usr/share/antergos/wallpapers but they don’t show up on the login Screen.
    Where is the lightdm-webkit2-greeter.conf located?


  • /etc/lightdm/lightdm-webkit2-greeter.conf

    But i must say i am not shure if changing without changing the theme may result in not showing up of the greeter…
    I try put some inside /usr/share/antergos/wallpapers
    and it just works:
    But i got an error message that says something is wrong with theme configuration…may it is simple caused by some pictures with wrong filetype …

    alt text

  • To use your own pictures for the login screen, simply put them into the folder mentioned above (“usr/share/antergos/wallpapers”, and if doing it graphically, simply click on “Other Locations” and then “usr”, “share” “antergos”, “wallpapers” to navigate to the correct folder) and then rename your chosen picture to the name of one that is already in there. Then, get rid of the one that shares its’ name.

    Now your picture should show up as an option at the login screen🙂

    Hope this helps and good luck!

  • @A-User Hi User, yes this was the solution. Thank you very much, now everything is like I wantedt it to be :)

  • Thanks!

    Glad I could help🙂

  • thats a “hacking” solution ;)

  • @joekamprad said in Cannot change Wallpaper for Login Screen:

    thats a “hacking” solution ;)
    Well, better a “hacking” solution than none. 😉

login-screen2 logintheme2 Posts 17Views 5815
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.