• Switch to Non-Graphical GRUB


    How can I switch to the non-graphical grub-menu?

    (EDIT: What I meant was a textbased grub menu. Thanks to @joekamprad for clarification and solution.)

    There is an instruction at the bottom of the graphical grub-menu, which says: “For Non-Graphical Boot: Add systemd.unit=multi-user.target to the kernel command line”.

    How do I do that?

  • @mirco said in Switch to Non-Graphical GRUB:
    non-graphical grub-menu vs. For Non-Graphical Boot

    Non-Graphical Boot will boot into CLI without starting graphical environment.

    To get a textbased grub menu you need only to disable theming inside /etc/default/grub
    (uncomment and commenting with #)

    $ sudo nano /etc/default/grub
    
    #GRUB_THEME="/boot/grub/themes/Antergos-Default/theme.txt"
    

    may you want some more nice colors:

    # Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
    # modes only.  Entries specified as foreground/background.
    GRUB_COLOR_NORMAL="light-blue/black"
    GRUB_COLOR_HIGHLIGHT="light-cyan/blue"
    

    then write the grub.cfg with:

    $ sudo grub-mkconfig -o /boot/grub/grub.cfg
    
  • @joekamprad said in Switch to Non-Graphical GRUB:

    @mirco said in Switch to Non-Graphical GRUB:
    non-graphical grub-menu vs. For Non-Graphical Boot
    Non-Graphical Boot will boot into CLI without starting graphical environment.

    Of course. D’oh! haha Thanks for the clarification. * smile *

    To get a textbased grub menu you need only to disable theming inside /etc/default/grub
    (comment and uncomment with # )

    $ sudo nano /etc/default/grub
    #GRUB_THEME="/boot/grub/themes/Antergos-Default/theme.txt

    I found that, but what about this? (also in the in the /etc/default/grub)

    # Uncomment to disable graphical terminal
    #GRUB_TERMINAL_OUTPUT=console
    

    then write the grub.cfg with:

    $ sudo grub-mkconfig -o /boot/grub/grub.cfg

    It worked. GRUB was text-based. Nice. BUT, it rendered my box unable to boot! After grub did it’s thing, I was thrown to an emergency console. 'Tried to fix grub with an antergos live stick, but since my knowledge is limited and my time yesterday also was, I ended up re-installing Antergos. That was not so pleasant. :-|

  • # Uncomment to disable graphical **terminal**
    

    no need to change this…

    I am sorry that you feel forced to reinstall everything… but… reason for not starting system was something else…

    A black screen does not say system is destroyed, in 99% of cases!!!

  • @joekamprad said in Switch to Non-Graphical GRUB:

    # Uncomment to disable graphical **terminal**
    

    no need to change this…

    I am sorry that you feel forced to reinstall everything… but… reason for not starting system was something else…

    A black screen does not say system is destroyed, in 99% of cases!!!

    Yes, I know. Everything was there. Just something with the grub config was wrong. I was able to access and rescue the data via the live system. I think, next time I’ll play around with configuring grub in a virtual box.

  • Then welcome back, and a good thinking to try thouse stuff first inside a VM!

    SANDBOXING IS A GOOD WAY!

  • Ok, I did it again, this time it worked. I guess, I did something wrong the first time.

grub113 grub226 Posts 7Views 3623
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.