• System Won't Boot After Install

    I have a Mac Mini (Early 2009) that I’m running Antergos on. The installation works fine, but upon reboot the system will load to a black screen (No mouse pointer) and become completely unresponsive. No network activity, no caps lock/num lock toggling, etc. I simply have to hold the power button down until I hard power it off. This seems to be repeatable every time.

    Now, I have found one way to get it to boot, but unfortunately I have to be physically at the machine to do it. If I edit the grub kernel line to include ‘rescue’, I can then authenticate and run commands. This is at a point before the networking stack has initialized, but if I log in and either wait about 10 seconds or run a couple simple commands and then exit (Ctrl+D) the system continues booting and everything works as expected. No black unresponsive screen, and the system will be stable until the next reboot.

    I have tried adding ‘boot_delay=5000’ and ‘rootdelay=10’ but unfortunately that hasn’t helped. I really wonder if I could just put a sleep somewhere if it would solve the issue, but I’m not sure where or how.

    I’m happy to provide any additional logs or anything that might be of help. Thanks!

    [0_1495080217075_logs.tar.gz](Uploading 100%)

    Update: Apparently I don’t have the permissions to upload my logs at this time.

  • Welcome to Antergos!
    How did you make the instillation media? Sometimes there is an issue with that.

  • @moredoor Thanks for the welcome! I’m happy to be here! :)

    I just downloaded the iso and used Rufus on Windows to write the image to a flash drive. I have used it to install on another desktop and a laptop and it’s working great on those systems.

    The installation boots fine every time on the Mac Mini, but after installation when I reboot I get the blank screen without fail. I have re-installed it 3 different times, all with the same results. The reason why I installed it so many times was because I kept thinking I did something wrong. I was very happy when I found out I could consistently boot the system fine if I first went into ‘rescue’ mode. I would just love to figure out why, and really fix it, because it would be nice to reboot the system remotely and not have to worry if it will come back up.

  • may try nomodeset kernel parameter on boot… but without logs , it is hard to see what goes wrong, also as i do not know about the hardware inside…

    echo ---lspci--- > logs && lspci >> logs && echo ---lsusb--- >> logs && lsusb >> logs && echo ---dmesg--- >> logs && dmesg >> logs && echo ---journalctl-b--- >> logs && journalctl -b >> logs && tar -cf logs.tar logs

    you can provide a link to uploaded file (logs.tar) here

  • @joekamprad I can give nomodeset a try when I get home later, but I’m pretty sure that I have tried that without success previously.

    I am still having trouble uploading my logs for some reason, so here is a gist of the logs.

    Thanks for the suggestion, and taking the time to look at this!

  • looks like you are using nvidia driver? do you install nvidia-340xx ?

  • @joekamprad

    I do have those drivers installed.

    sudo pacman -Q | grep nvidia
    nvidia-340xx 340.102-6
    nvidia-340xx-utils 340.102-8

    The weirdest part about all of this for me, is if I run ‘rescue’ mode, log in & wait for 10 seconds, then exit rescue mode and continue with normal boot everything works great. No graphical glitches or anything. But if I just try to boot normally it locks up with the black screen, no network activity, etc. I’m curious if there is just something hardware wise that isn’t initializing fast enough or something like that? I do have an SSD, and the system does boot pretty fast… I would say about 5 seconds after the grub screen to either rescue mode or the frozen black screen. If I do rescue mode and log out it shows the lightdm screen about 2-3 seconds later.

  • @phermium Two questions: do you have LTS Kernel installed? If yes, have you tried booting on it? I had the same issue on a HP Pavilion 14 v064 and it worked like a charm. Also, in order to avoid the grub selection screen, you can also download grub-customizer and set it to boot by default.

  • @raffael I don’t believe I have the lts kernel installed, but I’m not opposed to giving it a try. There is currently a “fallback” kernel, but it exhibited the same behavior.

    $ sudo pacman -Q linux
    linux 4.10.13-1

    I haven’t done this before, but would I follow these steps to install a LTS kernel?

    pacman -S linux-lts
    grub-mkconfig -o /boot/grub/grub.cfg


  • @phermium said in System Won't Boot After Install:

    pacman -S linux-lts

    $ sudo pacman -S linux-lts nvidia-340xx-lts

    and then you need to choose it on bootup like the fallback kernel.
    If you want to make lts kernel default boot grub-customizer is a nice tool but also dangerous if you do not know how it works…

  • The LTS kernel totally worked! I wish I knew more of why, but I’m really happy that it’s working! I will have to read up on grub-customizer to set grub to boot the LTS kernel by default. Thanks for all the help everyone!

  • @phermium Hi! I’m glad that worked. The configs on grub-customizer i used (and is working) is as shown in the attached image:
    0_1495186932156_Screenshot from 2017-05-19 06-40-32.png

    I hope it helps!

  • @raffael Thanks for the info! I actually manage all of my servers with Ansible, so I just ended up just putting this line in /etc/default/grub:

    GRUB_DEFAULT='Advanced options for Antergos Linux>Antergos Linux LTS Kernel'

    I imagine this is what grub-customizer is doing under the hood anyway. It’s still on my list to learn more about it though, because I bet it comes in handy! Thanks again for all the help!

  • @phermium Great! I think it is just like this. I told you to install Grub Customizer because i had the same issue (as i said before) and only adding those lines in grub.cfg did not helped. But i’m glad you got rid of headache!

  • @raffael Thanks for your help! I really appreciate it!

  • I am having trouble booting and getting black screen. I’ve tried the method of installing Linux-lts and nvidia-lts but still got black screen. I have macOS X El Capitan installed on an early 2008 MBP. I have disabled SIP and have installed rEFIind installed. Any and all help is appreciated. I have installed Gnome desktop. Thank you

  • @joekamprad said in System Won't Boot After Install:


    nvidia-340xx-lts is what do the clue for the treat starter…
    Are you able to give the link this command will paste to your terminal?

    lspci | curl -F [email protected] https://ptpb.pw/

    You may can switch to TTY2 with [Ctrl+Alt+F2]

  • Status: created
    Url: http://ptpb.pw/_wn6

  • NVIDIA Corporation G84M [GeForce 8600M GT] (rev a1) needs the 340 Driver too…

    $ sudo pacman -R nvidia-lts 
    $ sudo pacman -S nvidia-340xx-lts


  • I ran those commands and I am still getting black screen with blinking cursor on upper left corner.

boot303 system136 Posts 46Views 14243
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.