• EFI dual boot Windows 8.1 grub doesn't work


    Hi, I have installed antergos with the same configuration previously, but now it doesn’t works. My Antergos partitions go from sda8 to sda11, where sda8 is a FAT32 with boot/efi, sda9 is ext4 with root, sda10 is ext4 with home, and sda11 is swap. I tried to make a live usb using unetbootin, usb writer, linux live usb creator and rufus. The first 2 I read that aren’t recommended for that, even when I remember that previously I installed Antergos using Linux Live USB Creator, unetbootin has never worked. At this time I tried rufus 2.14 and I pressed “Yes” on the messages that were displayed, it was something about some missing files, later I saw on the video recommended on the documentation, that I have to choose “No”.

    Later I changed Rufus version, I used Rufus 2.15, but It doesn’t work. With both versions of rufus everything was fine, until the first boot, I don’t see the classic boot menu, with antergos logo and my installed systems (I have windows 8.1 and Ubuntu mate 14.04) I only see a basic grub menu with 2 options of antergos, and when I select the “default” option wich is “Arch Linux, with Linux core repo kernel”, I see other black screen where there’s a Device ID and it says “not found”, and in other line it says “press enter to retry”, but it never works. With Usb Writer I get a message when antergos installation ends, something about an error with boot files, and if I want to check the wiki for some common errors, but chromium doesn’t works with chnchi. All the Live USB I made were made on windows.

    When I saw that it wasn’t working, I checked in the wiki, but that configuration is so different, and I don’t know if it’ll work or if it’ll break my other systems boot.

    Note: I have never changed to legacy or disabled secure boot, what I do in windows is in Recovery options, use a recovery device and in that category an EFI USB.

  • @masozow said in EFI dual boot Windows 8.1 grub doesn't work:

    At this time I tried rufus 2.14 and I pressed “Yes” on the messages that were displayed, it was something about some missing files, later I saw on the video recommended on the documentation, that I have to choose “No”.

    The tex is hard for me to understand since english is not my native language.

    One thing i can tell you is that i always used rufus to install and always checked the option you mentioned, it install an aditional file to make Antergos boot properly… So i recommend you to mark the option as well.

    Don’t pay much attention to:
    About legacy mode is relative, if you already have OSes installed as UEFI antergos should be installed as EFI too. (you could install as legacy then use Ubuntu bootloader to detect it, i made that in a desperate situation and don’t know exactly how i did it)

    Note: I have never changed to legacy or disabled secure boot, what I do in windows is in Recovery options, use a recovery device and in that category an EFI USB.

    Ok, if windows has an option like that, you should disable safe boot and then set your USB to boot in your BIOS.
    When you set your USB drive to boot you can choose between 2 options like “Your USB legacy” and “Your USB EFI”

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Disableling secure boot is a must do, because otherwise system permit to boot other then windows.

    Also if you have already a EFI-Boot partition (fat) then you do not need to add a new one…
    The existing one needs to be mounted to /boot/efi on your Antergos installation, only make shure to not format this one, only mounting it…then the entry for Antergos will be at the right place.

    If you like you can post a screenshot from your actual partition table out of windows?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Hi!
    If you are having problems with Rufus and can not figure it out, I found that Etcher worked well for me. There aren’t any boxes to check/ uncheck, only a “flash” button (that burns the iso directly to the flash drive). However, if you wish to use Rufus for the live iso creation, here is an article explaining how to do it for Antergos.

    Also, it is ESSENTIAL to NOT format the EFI-Boot (fat) partition and to just use the one that is already sitting there. I can’t remember why exactly, but it creates a definite problem with booting if you create another EFI-Boot (fat) partition.

    In addition, disabling secure boot is a must. It is definitely crucial to dual-booting in most cases.

    Lastly, I found this article extremely helpful in installing Antergos. I don’t know if you need it or not, but I just thought I would bring it up just in case.

    I know that most of this information has been already in this thread, but I thought I would just throw my two cents in:slight_smile:.

    Hope this helps! There is a light at the end of the tunnel, just don’t give up! (guess how I know this… aka. I experienced a similar issue when I attempted to install Antergos a few weeks ago:slight_smile:)

    I wish you the best of luck (And hopefully a nearly painless experience to go along with it)

    Keep trying, never give up. In the end, you will find that it was all worth it

    (NOTE: This is still @A-User, I just changed my username and picture)

  • My bad, I actually have disabled secure boot, what I didn’t changed was UEFI to Legacy. I have tried a few things, the first one was to install mounting boot/efi on the partition that windows already have, as in the installing tutorial that @A-User posted, but it didn’t work, i keep seing this weird boot menu where it says “Arch Linux, with Linux core repo kernel”.

    The second thing I tried is to install Ubuntu 16.04.2 LTS to restore the fat32 boot/efi partition that I accidentaly formatted, so I had 2 boot partitions, one for windows and one for linux, and Ubuntu worked fine and I can choose both windows and the new Ubuntu, but as you can see in my first post, I also had a partition with Ubuntu Mate 14.04, but the grub recognized this one as “Arch” and it didn’t boot.

    Later I tried to install as I always did, using the partitions that I wrote in my first post, keeping two boot/efi partitions, but now without formatting the second boot/efi partition, only mounting it, but it still not working. I’m going to try something related to what @A-User says, I’ll remove the extra boot/efi partition that I created, and follow the “foss” tutorial using only the windows EFI partition.

    Note: In every install cnchi spends like 20 minutes configuring the boot at the end of the installation.

  • @joekamprad This is my partition table, the first partition that is after “OS C:” is my second boot/efi partition, the one that I have created. The next partition, which is 55.88GB is my Antergos root, the one that has 215.37GB is home, the next one with 8.38GB is Swap, “New Volume E:” is a NTFS partition for files, the next partition with 53.23GB is my Ubuntu Mate 14.04 root (and now that one is not working) and the last one is the Windows Recovery. The first partition of the table, which has 500MB is the windows boot. 0_1495350299583_Particiones.png

  • Well, I removed the second fat32 boot/efi partition, created the Live USB with Etcher, used windows boot partition to mount it as boot/efi, and didn’t selected nothing more than the default software in cnchi, but it doesn’t work, I keep seeing the same black screen. By the way, I can enter to Grub console, should I try to repair grub from there? Because the installation through cnchi isn’t working.

  • You are shure?
    When you can see grub menu and you can startup, grub is installed, but may system is not starting correctly, we do not know that…
    You can startup with the Install-Iso (USB) and repair the bootup by chrooting into the system.

    Change_root

    For this you need to mount / (root) under /mnt and the boot/efi under /mnt/boot/efi
    If / root = /dev sda5

    sudo su
    mount /dev/sda5 /mnt
    mount /dev/sda1 /mnt/boot/efi
    arch-chroot /mnt
    pacman -S os-prober
    grub-mkconfig -o /boot/grub/grub.cfg
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Hi again!

    What eventually worked for me when I installed Antergos was to use a previously installed distro that I had on my computer (that was working) such as your new Ubuntu, and just choosing to “format” all of their partitions except the “boot/ efi” one. that way, the Antergos installation should be formatted exactly like your other working Linux distro.

    Hope this helps!

    Keep trying, never give up. In the end, you will find that it was all worth it

    (NOTE: This is still @A-User, I just changed my username and picture)

  • Although I think I had to add the “/home” partition.

    Other than that however, it’s definitely the easy way to go (at least in my case):slight_smile:

    Keep trying, never give up. In the end, you will find that it was all worth it

    (NOTE: This is still @A-User, I just changed my username and picture)

  • @A-User said in EFI dual boot Windows 8.1 grub doesn't work:

    Hi again!

    What eventually worked for me when I installed Antergos was to use a previously installed distro that I had on my computer (that was working) such as your new Ubuntu, and just choosing to “format” all of their partitions except the “boot/ efi” one. that way, the Antergos installation should be formatted exactly like your other working Linux distro.

    Hope this helps!

    I have to do this on my Desktop. I installed windows, all i kept is the EFI partition… This is the manufacturers fault for not doing a proper BIOS.

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @izznogooood said in EFI dual boot Windows 8.1 grub doesn't work:

    @A-User said in EFI dual boot Windows 8.1 grub doesn't work:

    Hi again!

    What eventually worked for me when I installed Antergos was to use a previously installed distro that I had on my computer (that was working) such as your new Ubuntu, and just choosing to “format” all of their partitions except the “boot/ efi” one. that way, the Antergos installation should be formatted exactly like your other working Linux distro.

    Hope this helps!

    I have to do this on my Desktop. I installed windows, all i kept is the EFI partition… (Format is ok, just dont change the filesystem ETC) This is the manufacturers fault for not doing a proper BIOS.

    I make things work…
    My humble wiki: https://anotherlinux.com/

  • @A-User said in EFI dual boot Windows 8.1 grub doesn't work:

    Hi again!

    What eventually worked for me when I installed Antergos was to use a previously installed distro that I had on my computer (that was working) such as your new Ubuntu, and just choosing to “format” all of their partitions except the “boot/ efi” one. that way, the Antergos installation should be formatted exactly like your other working Linux distro.

    Hope this helps!

    @A-User I actually did that and it didn’t work, but gave me a clue, when I saw that my old Ubuntu Mate partition was being recognized as “Arch” I felt that something was wrong, so I decided to delete that partition, I didn’t had nothing relevant there, it was only a root partition who shared Home with Antergos. At this point I had already removed the boot/efi partition that was used with the fresh Ubuntu 16.04.

    I installed again antergos, mounting the boot partition used by windows as my antergos boot/efi, and now it is working, kinda, my only problem is that windows isn’t shown in grub, but I think that is easier to fix. I remember that some of the commands posted by @joekamprad are used to fix it.

  • @masozow Windows is not beeing displayed because you deleted/formated /boot/efi. Now you’ll need to boot windows cd and repair the bootloader (maybe someone will give you some links or videos about how to do it, i won’t since i haven’t tested here)

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • The same thing happened to me also, and I was able to fix it by running the commands:

    sudo os-prober
    

    and then

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    After that, I simply had to reboot and Windows was recognized :slight_smile:
    Good luck and hope this works!

    Keep trying, never give up. In the end, you will find that it was all worth it

    (NOTE: This is still @A-User, I just changed my username and picture)

  • @masozow said in EFI dual boot Windows 8.1 grub doesn't work:

    I remember that some of the commands posted by @joekamprad are used to fix it.

    May this mean that the problem is solved?

    @fernandomaroto: i think that os-prober do the job to find windows partition, and add this one to grub menu.
    this is then not the default from windows but should work too.

    @A-User: and without beeing able to start Antergos he need to use arch-chroot…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @fernandomaroto No, I didn’t removed /boot/efi from windows, the /boot/efi that I removed was the one I have created, I can boot from windows, by pressing “F12” on boot, which is the Key for boot options in my computer, then I select windows from there and it works normally

  • @A-User That worked perfect! Now I can select Windows from grub and both systems boot properly.

    @joekamprad Yes, it is solved, I think cnchi goes nuts when there’s more than one OS installed on the same computer. I remember that I installed Ubuntu Mate after antergos.

  • I’m glad it’s fixed!:slight_smile:
    Welcome to the Antergos community.
    Now your real journey begins!

    Keep trying, never give up. In the end, you will find that it was all worth it

    (NOTE: This is still @A-User, I just changed my username and picture)

  • @A-User Thank you! :D

grub224 dualboot11 dual-boot11 bootefi6 Posts 21Views 790
Log in to reply