• Google calendar not showing up in Gnome calendar

    After connecting my google online account my contacts show up in Gnome contacts but my google calendar doesn’t show in Gnome calendar or the drop down calendar from the panel. Anyone know a fix?

  • @Skiman said in Google calendar not showing up in Gnome calendar:

    After connecting my google online account my contacts show up in Gnome contacts but my google calendar doesn’t show in Gnome calendar or the drop down calendar from the panel. Anyone know a fix?

    You might find your answer in this thread: (https://forum.antergos.com/topic/6215/shared-calendars-are-not-in-my-gnome-gmail-calendar). Occasionally after an upgrade to certain Gnome elements, I’ve also found a reboot is required to restore those calendars (if they were there before and disappeared, as happened to me). Hope this helps.

  • I’ve rebooted several times since adding Google online account and still no calendar sync, but I tried the google sync from the link you provided so I’ll see if it syncs now after some time.

  • alt text
    A picture is worth a thousand words ;)

  • Are you telling me to remove the account, because I have all these turned on. Like I said earlier my google contacts, documents, and photos came thru. Only the calendar didn’t.

  • Yes but as you say only calendar does not show up first idea was a disabled one in settings…
    You may have something permit inside your online calendar (google webside)
    Every device that access to your google account is connected via a keypair and you can also give different rights and securty values on google calendar and devices.

    If not there we can have a look to what starting the calendar log to journal?

    journalctl | grep org.gnome.Calendar > calendar-journal.log

    pastebin the file to a paste service you like and give us the link here…

  • Not sure how to use a “pastebin” service but I copied a few lines that seemed to be common in the log.

    GcalManager: DEBUG: Source Personal (system-calendar) connected
    May 14 19:39:14 john-pc-antergos org.gnome.Calendar[714]: 19:39:14.0496 Gtk: CRITICAL: gtk_container_remove: assertion ‘GTK_IS_WIDGET (widget)’ failed

  • https://filebin.ca can handle files
    But as the file will include emailadress e.t.c. it would be better to do not upload this official viewable…
    You can search into the file with gedit or similar by your self …

    searching for @gmail.com would show you a line where it connect with your calendar, if it does not may you find some with error or fail (gtk errors are not relevant here)

  • I didn’t find any instance of @gmail.com and just about every line had error in it but they were all gtk errors. I’ve checked my google account settings and even turned off secure devices only and still no calendar. I’ve removed my google account many times and re-added it only to see everything but my calendar show up.

  • Thats strange is’nt it?
    you are using evolution too?
    Because calendar is handled by evolution (org.gnome.evolution.dataserver.Calendar7) there can be something wrong with evolution too…

  • No I’m not using Evolution so I don’t know if it would work. I gave up trying and removed my google account. I will just access my calendar and such directly thru Chromium.

  • yes if you completely uninstall evolution, calendar is not aviable, you need to have evolution-data-server running

  • I didn’t install or uninstall anything for evolution, I just wasn’t using it. I just looked and while evolution is not installed, evolution-data-server is installed. I just checked my running processes and all the evolution server processes are running normal. Everything looks like my google calendars should have shown up but they didn’t. Like I said prior I removed google from online accounts and I’m just accessing directly thru chromium and all is well.

  • I am having this same issue. Might be widespread. Ubuntu and Manjaro have the same issue.

    John Vore

  • @john-vore open a new hread, as this one is a grandpa on a rolling distro ;)

    here google online accounts do not work either. But this is a new fail after update to GNOME 3.28!


gnome361 google23 showing13 calendar9 Posts 15Views 6674
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.