• Change yaourt default text editor


    I cant find a way to change the text editor on yaourt, its always nano, i want to change to gedit, but even changing the lines on EDITOR=“gedit” (on yaourtrc) is still using nano

  • It is maybe overrided by ?

    /etc/environment

    #
    # This file is parsed by pam_env module
    #
    # Syntax: simple "KEY=VAL" pairs on separate lines
    #
    # >>> BEGIN ADDED BY CNCHI INSTALLER
    BROWSER=/usr/bin/chromium
    EDITOR=/usr/bin/nano
    # <<< END ADDED BY CNCHI INSTALLER
    

    Oh no i think it is not possible to use a graphical editor… ?

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad I just resolved it on another way

    i just edit my zshrc config file

    gedit ~/.zshrc
    

    Then i added this line

    export EDITOR="gedit"
    

    and is just done

    But thank you for the fast reply

  • @Azur Don’t use neither single- nor double-quotes. My preferred editor is geany, so ~/.yaourtrc has:

    EDITOR=geany
    
  • But both /etc/yaourtrc or ~./yaourtrc does not work on changing the editor…

    # Environment variables
    EDITOR=gedit
    

    setting it inside the Environment variables for terminal works inside yaourt…

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

yaourt27 editor4 Posts 5Views 877
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.