• NZBGet Installation

    I am trying to get NZBGet up and running and not sure how to go about it.

    I want to be able to use this as my regular user where files downloaded don’t need to be edited as root.

    The arch instructions seem to make it so that it requires root to change any files downloaded. Also every tutorial I have found seems to want to copy the config file into a new location (each tutorial having a different location) and I’m not sure why. The nzbget.conf file by default is under /user/share/nzbget…why does it need to be copied somewhere else?

    I have currently only installed nzbget from pacman, nothing else. Any newly updated tutorials?

    What do I need to do exactly?

  • Hi,

    I’ve never managed to setup this. I moved to flexget and it works for me.


    If you manage to setup NZBGet, please share it ;)


  • thats funny i was never able to get it setup either :)

    i been using https://sabnzbd.org for years though. very easy setup and they just released new version. its in the AUR.

  • You guys means you haven’t been able to get it setup as a user or not at all.

    I can get it running as root, but that creates all kinds of annoyances when wanting to edit/move files etc.

    I used to use sabnzbd and moved to NZBGet for the scripts and a few other reasons. I may need to try it again. Though shouldn’t it have the same issues with permissions and users and crap like that?

  • i should note i havent tried in a few years but yes i never got it setup to run right for me. sabnzbd always quick setup and works great. i run sab with sonarr and nzb360 for android and a few nzb sites run everything from my phone all works very sweet.

    what kind of scripts do you need?

  • That is basically it.

    Using a certain website “dog” along with NZBGet you can have NZBGet do all that. All the stuff sonnarr and other types of apps do, can all be done within NZBGet. I like keeping things simple and clean if possible.

    I will keep trying but will probably set up Sabnzbd now to test as well.

  • @noobertroon i use that certain site also ;)

    ya i totally understand keeping things simple as possible. i do hear nzbget uses a lot less resources than sabnzbd.

    i just been using sabnzbd for so many years i just stick with it.

  • Hm, I’ve been thinking about writing a blog post about this. Its not that hard to get this up and running.

    I found this link amongst my bookmarks: https://www.htpcguides.com/configure-nzbget-on-all-platforms/
    I know I used this alot in the beginning.

    I dont know when I have the time but I was thinking about making a a full guide to:
    (I have this running in a LXC container (Optional))
    alt text
    After I made the chart i realized it would be more work than I originally thought :D

    I wont promise anything but I could try and get this done by the end of the weekend.

  • So I installed Sabnzbd from the AUR. When i click on it’s icon nothing happens…

    Am I missing something? (I did reboot already)

  • It was not that simple in terms of clicking that icon, but after a few commands it is installed and running. Thanks

  • I’ve never used Sabnzb so would not know ;)

  • @megaman said in NZBGet Installation:

    @noobertroon i use that certain site also ;)

    ya i totally understand keeping things simple as possible. i do hear nzbget uses a lot less resources than sabnzbd.

    i just been using sabnzbd for so many years i just stick with it.

    @megaman so Sabnzbd is working and all but is setup as it’s own user. Which means my user still does not have easy access to changing the files. I still need to switch to Root to edit/delete files.

    How do you have it setup, how do I change Sabnzbd to be my user instead I guess?

  • @noobertroon im not sure i quite understand. your username does not have access? what files are you trying to edit?

    there isnt any editing of the sab files that i do. i only make a password.txt for it to read from. all i do is install start and download away.

    i think maybe we have different setups.

  • lol

    Once the files are downloaded (fixed, extracted, into the video format) they are in their folder and can not be moved or renamed or deleted.

    I need to load them up as root to do anything. This is because they are created as the Sabnzbd username instead of regular user account.

  • @noobertroon ok i see what you are saying. that is very odd i never had that happen before.

    i did see a few posts on sab forum about permission errors and here is a link from the sab wiki


    ya something got messed up with the permissions. sorry i dont have 1st hand experience of this problem let me know how it goes.

  • For anyone who comes across this.

    I didn’t get it resolved. I ended up going with Sabnzbd which I was able to get to work.

  • @noobertroon sab is great! hope it works well for you.

installation326 nzbget2 Posts 17Views 2499
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.