• Plasma5 trouble, again, needed to reinstall my whole System


    Last week I had problems. I turned off my computer and when i restarted it some hours late, I lost my Plasma DE, I only had the wallpaper and a movable mouse pointer. Deleting the ~/.config and ~/.cache folder solved it though ( I still had to rebuild all my DE modifications though).
    Today, the same happened, again I only had a wallpaper and a movable mouse pointer, but this time deleting the both hidden folders did not solve it.
    I ended up with a OS reinstall and I presume I still need one to two days of work to have everthing ( including printing and scanning) working again.
    In both cases I neither installed/deinstalled or upgraded anything, the plasmashell just refused to start after that reboot process.
    I wonder if anyone else has observed such a strange behaviour with Plasma 5.
    J.

  • @Jeannie____ I also had to reinstall my KDE system last night. All of a sudden, while working with it, the whole desktop became really, really, really big. It was funny my desktop moved around and around whenever I tried to move the cursor. Since it would have been too hard to look deeper into what caused it (guess i d need 4 laptop screens to hold it plus it moved together with the cursor, I tried rebootin, turn it off, switch kernels, removing the battery.
    I then tried to re-install just the / partition. Same result.
    So, I too, also am in the process of configuring my new complete fresh insstall… (neither of my other plasma machines was affected).

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • This provokes the question if there are any similarities in hardware or system set-up that causes this strange behaviour. Especially because @anarch mentioned that his other plasma machines were not affected.

    Never to old to learn.

  • Ok, got the same problem. This needs the attention of the developers.
    Before rebooting the screen began to flicker wildly. I decided to reboot my system and did not get very far. After the Grub screen I got this:

    Inode 2678841
    /usr/share/mime/image/vnd.ms-modi.xml has invalide mode (05116)
    

    It runs fsck but end up with the message to run fsck manually.

    I have ran my Plasma set up for at least a year now without problem. Something went wrong during one of the last update. Yesterday, or the day before yesterday, i was still able to reboot without problem.

    Never to old to learn.

  • Additionally I got the following message when trying to open the Image file from my dual boot:

    Failed to open directory 'image'
    Error when getting information for file '/media/axioma/AntergosRoot/usr/share/mime/image/vnd.ms-modi.xml': Structure needs cleaning.
    

    Not sure if I could open it when in root. Waiting for directions from the developers.

    Never to old to learn.

  • @axioma said in Plasma5 trouble, again, needed to reinstall my whole System:

    /usr/share/mime/image/vnd.ms-modi.xml has invalide mode

    Wow. It’s fun that this is a Microsoft Document Imaging definition MIME file.

    This is how appears this file in my harddisk (I’m not using Plasma atm)

    -rw-r--r-- 1 root root 3,5K 13 mai 10:26 vnd.ms-modi.xml
    

    And its contents:

    <?xml version="1.0" encoding="utf-8"?>
    <mime-type xmlns="http://www.freedesktop.org/standards/shared-mime-info" type="image/vnd.ms-modi">
      <!--Created automatically by update-mime-database. DO NOT EDIT!-->
      <comment>Microsoft Document Imaging format</comment>
      <comment xml:lang="ar">صيغة مستند تصوير مايكروسوفت</comment>
      <comment xml:lang="bg">Изображение — Microsoft Document Imaging</comment>
      <comment xml:lang="ca">format Microsoft Document Imaging</comment>
      <comment xml:lang="cs">formát Microsoft Document Imaging</comment>
      <comment xml:lang="da">Microsofts dokumentbilledformat</comment>
      <comment xml:lang="de">Microsoft-Document-Imaging-Bildformat</comment>
      <comment xml:lang="el">Μορφή Microsoft Document Imaging</comment>
      <comment xml:lang="en_GB">Microsoft Document Imaging format</comment>
      <comment xml:lang="es">formato de imagen para documentos de Microsoft</comment>
      <comment xml:lang="eu">Microsoft Document Imaging formatua</comment>
      <comment xml:lang="fi">Microsoft Document Imaging -muoto</comment>
      <comment xml:lang="fo">Microsoft Document Imaging snið</comment>
      <comment xml:lang="fr">format Document Imaging Microsoft</comment>
      <comment xml:lang="ga">formáid Microsoft Document Imaging</comment>
      <comment xml:lang="gl">formato de Microsoft Document Imaging</comment>
      <comment xml:lang="he">תבנית של Microsoft Document Imaging</comment>
      <comment xml:lang="hr">Microsoft Document Imaging format</comment>
      <comment xml:lang="hu">Microsoft Document Imaging formátum</comment>
      <comment xml:lang="ia">File in formato Microsoft Document Imaging</comment>
      <comment xml:lang="id">Format Microsoft Document Imaging</comment>
      <comment xml:lang="it">Formato MDI (Microsoft Document Imaging)</comment>
      <comment xml:lang="ja">Microsoft ドキュメントイメージフォーマット</comment>
      <comment xml:lang="kk">Microsoft Document Imaging пішімі</comment>
      <comment xml:lang="ko">Microsoft 문서 이미지 형식</comment>
      <comment xml:lang="lt">Microsoft Document Imaging formatas</comment>
      <comment xml:lang="lv">Microsoft dokumentu attēlošanas formāts</comment>
      <comment xml:lang="nl">Microsoft Document Imaging</comment>
      <comment xml:lang="oc">format Document Imaging Microsoft</comment>
      <comment xml:lang="pl">Format Microsoft Document Imaging</comment>
      <comment xml:lang="pt">formato Microsoft Document Imaging</comment>
      <comment xml:lang="pt_BR">Formato do Microsoft Document Imaging</comment>
      <comment xml:lang="ro">Format Microsoft Document Imaging</comment>
      <comment xml:lang="ru">формат Microsoft Document Imaging</comment>
      <comment xml:lang="sk">Formát Microsoft Document Imaging</comment>
      <comment xml:lang="sl">Zapis Microsoft Document Imaging</comment>
      <comment xml:lang="sr">запис слика Мајкрософтовог документа</comment>
      <comment xml:lang="sv">Microsoft Document Imaging-format</comment>
      <comment xml:lang="tr">Microsoft Belge Görüntüleme biçimi</comment>
      <comment xml:lang="uk">формат Microsoft Document Imaging</comment>
      <comment xml:lang="vi">Định dạng tạo ảnh tài liệu Microsoft</comment>
      <comment xml:lang="zh_CN">Microsoft Document Imaging 扫描图像</comment>
      <comment xml:lang="zh_TW">微軟文件影像格式</comment>
      <acronym>MDI</acronym>
      <expanded-acronym>Microsoft Document Imaging</expanded-acronym>
      <glob pattern="*.mdi"/>
    </mime-type>
    
    
  • @axioma which filesystem are you using?

  • @karasu I am using Ext4
    I have reinstalled my whole system again. Then I checked the mime folder; the same file was there. The mime folder contains a whole bunch of image related files. I guess this makes it possible for the system to encode different image files, including MS image files.
    Just curious how this got corrupted.

    Never to old to learn.

  • @karasu
    My /usr/share/mime/image/vnd.ms-modi.xml looks exactly like this too.
    Freshly installed Antergos 17.5-x86_64 with Plasma5.
    Is there any explanation why my old plasma system got corrupted during a reboot yet? Or will this remain a mystery forever?
    J.

  • @Jeannie____ said in Plasma5 trouble, again, needed to reinstall my whole System:

    @karasu
    The contents of my /usr/share/mime/image/vnd.ms-modi.xml look exactly like this too.
    Freshly installed Antergos 17.5-x86_64 with Plasma5.
    Is there any explanation why my old plasma system got corrupted during a reboot yet? Or will this remain a mystery forever?
    J.

trouble14 plasma512 needed10 reinstall7 Posts 10Views 1697
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.