• Lagging mouse and window movement.


    Using Gnome I have terrible lag/stuttering when moving windows around the desktop. Scrolling and mouse pointer selection is also sometimes erratic.

    I downloaded the Plasma desktop then enabled “force full composition pipeline” in Nvidia Settings, this resulted in a very smooth desktop experience.

    The force composition pipeline does not work with Gnome, in fact it makes it worse.

    AMD Phenom ii x4 965
    Nvidia Geforce GTX 650ti

    Gnome 3.24.2
    Linux 4.10.13-1
    Nvidia driver 381.22-1

    I have also downgraded to all the available Nvidia drivers with no improvement.

    Can’t seem to figure out how to try Nouveau without encountering errors. Although I don’t think this is the best solution as I make use of OpenCL for photo editing.

    Any ideas/help much appreciated as I prefer the Gnome environment.

    Thanks.

  • setting force full composition pipeline do not harm here on gnome with nvidia driver.
    Do you have installed on help from ArchWiki or do you use nvidia-installer to install nvidia driver?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • HI, I installed the nvidia driver automatically during the Antergos installation.

    I tried the other Nvidia drivers using -

    sudo pacman -Rdd nvidia-***xx nvidia-***xx-utils
    sudo pacman -S linux-headers nvidia-***xx nvidia-***xx-utils

  • You should use the right driver for your card…and this is the latest one…
    may you give nvidia-installer a try?

    $ sudo pacman -S nvidia-installer
    nvidia-installer -t
    

    when -t (testing) do not give errors install it:

    $ sudo nvidia-installer
    

    May you have something not at the right place or nouveau is not complete erased…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • I followed your commands with no errors. Latest Nvidia drivers installed.

    xf86-video-nouveau is not installed.

    Still the same jittery window movement. All other animations work fine.

  • I have this issue to all of my PC and I get the same lag. It’s definitely a gnome issue that also affects cinnamon and budgie. With KDE I get the smoothest experience I have ever had with Linux, though I’m not the biggest fan :confused:

    • AMD RX550 (tried both amdgpu and amdgpu-pro driver)
    • Nvidia 1050ti (nouveau and nvidia)
    • Intel HD 620
  • OK. So I got rid of Antergos and Installed Fedora…

    A beautifully smooth Wayland experience, but from a software point of view a pain in the arse. Tried to install Nvidia and killed the system.

    I know! I’ll try Installing Antergos again from fresh but instead of installing Nvidia during the installation process I’ll start with Nouveau then install Nvidia using joekamprad’s method above.

    The fresh Antergos with Nouveau had bad screen tearing but I used the nvidia-installer recommended by joekamprad and voila! It worked!

    Much better, quite smooth mouse/window movement, not as smooth as the Wayland experience on Fedora, and I still get the odd jitter, but I can live with that.

    Really pleased with Antergos in general. Hopefully graphics performance will improve further in the future with Wayland/Gnome/Nvidia compatibility.

  • UPDATE

    Not solved. Only reason things seemed to be fairly smooth (although not perfect) was due to reinstall and no extensions enabled.

    Once I had all my extensions loaded things were back to laggy/jerky window movement. If I disable all extensions then alt F2 r then it’s back to fairly smooth.

    Have tried to ascertain if it is a particular extension causing the problem, by individually disabling one at a time with no luck.

    Really annoying.

  • That bug is for Wayland. I’m defaulting to x11.

    Wayland is still generally buggy and doesn’t work with Nvidia.

    A modern desktop like Gnome on x11 should be buttery smooth.

  • @anivegmin said in Lagging mouse and window movement.:

    That bug is for Wayland. I’m defaulting to x11.

    Wayland is still generally buggy and doesn’t work with Nvidia.

    A modern desktop like Gnome on x11 should be buttery smooth.

    Yes sure it’s for wayland but if you see the few last comments you’ll see that people argue for xorg as well.
    Wayland is still a beta software and is laggy and buggy, it’s much worse than xorg currently in almost every aspect.
    Gnome isn’t smooth at all on X, I get this laggy/jerky window movement even without extensions. I have tried gnome 3.24.1 and nothing has been fixed yet. It becomes more noticeable if you use graphics-intensive apps.

  • Oh OK thanks. I just read the rest of the comments.

    Surely this kind of bug should be a top priority? Having a good user experience of the desktop is vital.

  • @anivegmin said in Lagging mouse and window movement.:

    Oh OK thanks. I just read the rest of the comments.

    Surely this kind of bug should be a top priority? Having a good user experience of the desktop is vital.

    In my opinion yes that should be top priority and it should be fixed a long time ago because performance is a vital part of usability, it’s not that gnome is totally unusable right now but it’s definitely the most laggy/jerky desktop around along with its forks and that’s sad because gnome used to be relatively fast back then and now it’s the slowest :cry:
    I really want to use it but just can’t stand that jerkiness. It seems I will stay with kde for a long time since it’s the smoothest tear-free and actively developing desktop environment.

nvidia103 gnome219 Posts 13Views 942
Log in to reply