• Black screen and mouse pointer after login


    I can login, but after that I only see the mouse pointer, and also there’s a MegaSync error notification, where I can click on the buttons and I get a message after that, and I can close that message. When I try to boot with Gnome Classic, selecting it on login screen, I can see the desktop, but there’s no panels, and also the windows hasn’t close and minimize buttons, I can open a terminal and it works correctly, but nothing else works.

    I have tried to downgrade webkit to a previous version, as I did before, because in January I had a similar problem, but after doing that it get’s freezed on the boot instructions screen that is shown at the beginning. I have also tried to install gdm and use it instead of lightdm, it passes the boot instructions screen, but the login screen isn’t shown.

    Note: After having the similiar problem in January, I haven’t upgraded my system, because I had important projects to do, this is my first updgrade after that.

    Note 2: My graphics are Intel HD 5000.

    Hope you can help me.

  • So you do a complete update before this happens?
    There are some big updates on Gnome (next Version) and openssl, and gtk3, since last month.
    Do you check that update went without error?

    To see if something is wrong with gnome-shell starting up:
    [ctlg+AltF2] TTY2 - prompt > login

    journalctl --since "5 minutes ago" /usr/bin/gnome-shell
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad Yes, it was a complete update. But something happened, I tried to update using the graphic interface but there was an error, something about certificates.crt, or something like that, so I rebooted and at the next start I had this problem. So I followed the Archlinux guide and mannualy removed the conflict file, later I updated in TTY2 using pacman -Syu and everything was updated, I just had some warnings but at the end no errors was shown, but the graphics problem still happening.

    I’ll check that and post here the results in a moment.

  • @joekamprad I tried with 2, 3, 5, 10, 12 and 20 minutes, just in case, but with everything I had the same result:

    -- No entries --
    
  • pacman -S gnome
    

    should help.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad I tried that and the problem persists. I just had a message and a warning while installing it, the message was that there was 46 members of gnome group, so I installed all of them, the warning was something about network manager permissions. I keep seeing the same, the mouse pointer and the MegaSync notification, and Gnome Classic keeps working partially.

  • can you try to add a new user may there is something wrong with configs:

    useradd -m -G wheel -s /bin/bash nameyouwant
    

    if you can login with new user, it should be a permission issue ore something around configurations, but i bet the first…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • If so then repair permissions:

    chown masozow -R /home/masozow
    
    chmod u+w -R /home/masozow
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad I had to use “passwd” to login, because a password was required, but with the new user I keep seeing the same, after login only the black screen with the pointer, and the MEGA Sync notification, the only different thing is that a MEGA Sync window was displayed, showing the last files I uploaded, but after closing the initial notification everything went black again.

  • New created user can not have your last “Mega Sync Uploads” if you done them with another user…

    Only idea comes to my mind is to iinstall a minimal Desktop Environment like fluxbox, and see if you can get intoit, so you can open webbrowser e.t.c. makes it more easy to investigate.

    $ sudo pacman -S fluxbox
    

    then try login to fluxbox session with your user.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad fluxbox didn’t work, I right clicked the destkop and tried to run firefox and xterm, none of them worked, so I installed “xfce4” and “xfce-goodies”, it loads, but very slow, and everything else is kinda slow, before it tooks like 1 or 2 seconds to open a window, now it takes like 6 seconds. And I realized that the MEGA Sync notification was an actual error, something related to “libcurl.so, libssl.so, libpthread.so, libQt5Core.so” and MEGA sync isn’t working.

  • @joekamprad It is working with XFCE, but I tried to enter on a Gnome Session and over TTY2 I ran “dmesg -k” and had the next result:

    gnome-session-f[905]: segfault at 0 ip 00007fe764adcd79 sp 00007ffc4dc6bc90 error 4 in libgtk-3.so.0.2200.15[7fe7647fa000+6fb000]
    
  • Do you reinstall to the latest gtk3 package? Do you have Spotify installed from AUR?
    What say

    pacman -Qs openssl
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad Yes, that was the first thing I tried when I saw that error, reinstall gtk3, but didn’t fixed the problem. Actually yes, I installed Spotify from AUR. And the result of “pacman -Qs openssl” is this:

    local/lib32-openssl 1:1.1.0.e-1
        The Open Source toolkit for Secure Sockets Layer and Transport Layer
        Security (32-bit)
    local/openssl 1.1.0.e-1
        The Open Source toolkit for Secure Sockets Layer and Transport Layer
        Security
    local/openssl-1.0 1.0.2.k-3
        The Open Source toolkit for Secure Sockets Layer and Transport Layer
        Security
    local/pkcs11-helper 1.22-2
        A library that simplifies the interaction with PKCS11 providers for end-user
        applications using a simple API and optional OpenSSL engine
    
  • Hi,
    I have exact same problem.

    [ 6896.957554] gnome-session-f[1489]: segfault at 0 ip 00007f0fade28d79 sp 00007fffd51d3b20 error 4 in libgtk-3.so.0.2200.15[7f0fadb46000+6fb000]

    Updating gdm, gnome, gtk3 doesn’t help. I’ve reinstalled gnome from scratch, but still getting segfaults and can’t open gnome session.

    When opening gnome-session-binary in gdb it shows, that at some point unhandled exception is thrown and this causes problems.

    (gdb) where
    #0 0x00007ffff68e9900 in raise () at /usr/lib/libc.so.6
    #1 0x00007ffff6ca1044 in () at /usr/lib/libglib-2.0.so.0
    #2 0x00007ffff6ca466a in g_main_context_dispatch ()
    at /usr/lib/libglib-2.0.so.0
    #3 0x00007ffff6ca4a20 in () at /usr/lib/libglib-2.0.so.0
    #4 0x00007ffff6ca4d42 in g_main_loop_run () at /usr/lib/libglib-2.0.so.0
    #5 0x0000000000409f49 in ()
    #6 0x00007ffff68d6511 in __libc_start_main () at /usr/lib/libc.so.6
    #7 0x000000000040a2ca in ()

    (gdb) n
    Single stepping until exit from function raise,
    which has no line number information.

    Thread 1 “gnome-session-b” received signal SIGTERM, Terminated.
    0x00007ffff68e9a10 in raise () from /usr/lib/libc.so.6
    (gdb)

  • @joekamprad I removed “megasync” package and its dependencies, and reinstalled it, now is working in XFCE. I removed spotify and when I tried to reinstall it I had an error with a package: “libcurl-openssl” I tried to install it individually but had the same error. So, there’s no more Spotify in my computer. Later I tried to start a session in Gnome, and saw a MEGA Sync error, something that it didn’t found the tray where the icon is supposed to be.

    Also I found this: https://forum.antergos.com/topic/6454/gnome-2-34-how-to-install-on-antergos/51?_=1494574054246&page=3

    I just want to know, if I reinstall all the packages in my system, all of them will be installed? And, my configurations will be the same? Because I have steam, android studio, virtualbox, genymotion, and an apache server for tests with DJango.

gnome187 lightdm80 gdm32 lightdm-webkit28 Posts 16Views 303
Log in to reply