• Linux on MSI GL62 6qf 1606xfr


    Hello everyone !

    I’m new with Linux, and I choose Antergos to start with it. I downloaded the latest version, and install it both in a USB stick and on a CD.
    But I can’t managed to install it on my computer (MSI as you can see above). Antergos freeze systematically before it started. The 5 blinking dots suddently stop, and then, nothing happens, the only thing I can do is shuting down the computer.
    Can somebody help me ?

    P.S.: I already have a partition with W10, and i create one of 50 GB to install Linux
    P.P.S.: i’m french, sorry if there is some grammatical mistakes.

  • @Zone

    the 5 blinking dots suddently stop, and then, nothing happens, the only thing I can do is shuting down the computer.

    Hi! Welcome to Antergos world!
    Here takes a long time to boot also, i’d say for you to wait at least 5 minutes to see if is booting or if it’s freezing

  • @Zone Try to boot with additional parameter:

    modprobe.blacklist=nouveau
    
  • Thanks for your fast answers !

    @fernandomaroto I can say when the boot is freezing or not : The CD/USB stick stop running when the dots stop. I managed to boot on my old HP, and it boot only few seconds after the dots stop.

    @just I’l really new on Linux community, I don’t know what this additional parameter means, and even less how to add it !

    I forget to say, but when i say “Start Antergos Live”, there are some errors that disappear automatically before the loading screen (see picture)0_1494435046303_20170510_183608.jpg

  • @Zone said in Linux on MSI GL62 6qf 1606xfr:

    @fernandomaroto I can say when the boot is freezing or not : The CD/USB stick stop running when the dots stop. I managed to boot on my old HP, and it boot only few seconds after the dots stop.

    Then i don’t know…

  • Power up the computer with LiveMedia inserted. LiveMedia startup screen will appear. It is made of 3 options:

    • Boot from Hard Disk
    • Start Antergos Live
    • Non-Graphical Boot

    The 1st option is selected. Press the CursorDown key once to select the 2nd option - Start Antergos Live. A long line with boot parameters will automagically appear at the bottom of the screen. It ends up with

    ...=loop udev.log.priority=crit rd.udev.log-priority=crit quiet splash [space]
    

    Without pressing any other key just start typing in:

    modprobe.blacklist=nouveau
    

    The text you typed in will be added at the end of existing boot parameters. Pay attention to not delete the [space] which follows the splash parameter.

    Press Enter to boot.

    All this has sense only if your video card is Nvidia Optimus. Otherwise, ignore this advice.

  • It worked…
    Thank you so much ! I’m now installing it on my HDD !
    The solution was to add the parameter you talked about !

  • @Zone said in Linux on MSI GL62 6qf 1606xfr:

    It worked…
    Thank you so much ! I’m now installing it on my HDD !
    The solution was to add the parameter you talked about !

    Doт’t celebrate too early. Read and follow Antergos Wiki here. Briefly: until nouveau video driver is removed, you should always boot with this parameter.

    Among other things, the article explains how to remove nouveau.

  • Oh… The installation was completed, i reboot my laptop, and then grub ask me to choose what i want to boot (Antergos or W10), W10 works but not Antergos. Always boot with this parameter isn’t a problem for me, i just need to know where to write it now…

  • @Zone said in Linux on MSI GL62 6qf 1606xfr:

    …Always boot with this parameter isn’t a problem for me, i just need to know where to write it now…

    First. I do not use use Grub 2. Sorry for possible inaccurances.
    Second. To not add the parameter by hand on every boot, you may include it in Grub 2 configuration file.

    Two steps are needed to do it.

    1. As root, modify /etc/default/grub file

      It has the line

      GRUB_CMDLINE_LINUX=""
      

      The line may already contain other parameters between double-quotes.

      Add modprobe.blacklist=nouveau at the end of existing parameters. Or, if other params don’t exist, simply add modprobe.blacklist=nouveau between double-quotes:

      GRUB_CMDLINE_LINUX="modprobe.blacklist=nouveau "
      
    2. Regenerate /etc/grub/grub.cfg file, which is actually used by Grub 2 on boot, with the command:

      sudo grub-mkconfig -o /boot/grub/grub.cfg
      
    3. Done

    From now on, the added parameter will be used on every boot.

    There’s no need to remove the parameter when you’ll uninstall the nouveau package.

  • I can’t boot anymore on linux, i got the following error![0_1494508411541_20170511_151317.jpg](Uploading 100%)

  • Here it is
    0_1494508463899_1494508441471896542115.jpg

  • do you choose manual partition?

  • Yes, i choose manual, because automatic partition would destroy my whole data, including W10.
    This afternoon, Linux had a big crashes, and grub didn’t work anymore. I had no more Windows or Linux. I managed to bring back W10, but linux is lost. I think i will wait a little more to install Linux, and i will install it directly on a dedicated external HDD.

    Thanks you for your help anyway,
    Zone

  • you are welcome!
    Hope to see you back soon!

installation292 msi4 Posts 15Views 3460
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.