• inhibit power management when watching videos


    i’ve tried the lightson script and the html5 fork but these don’t work. im using the latest version of gnome on wayland. how can i automatically prevent the screen turning off when watching videos? i need it to be automatic because i tend to watch videos when im in bed and i would like the power management to kick in after the video is finished because by then id probably have fallen asleep.
    #WindowsAndMacReallyDoSomeThingsBetter

  • Not exactly as specified, but the Caffeine extension for GNOME has a feature for applications to auto enable Caffeine. But I guess that needs the application to close after video ends to work as you want. I don’t have GNOME available atm to test myself unfortunately, but thought I would post the closest thing I could think of to what you want.

  • thanks, but you’re right. that won’t work because if i fall asleep the computer won’t.

  • Ok, so I reinstalled from scratch and this seems to work out of the box. Before i installed antergos with KDE but i had since removed KDE and installed Gnome with GDM. I reckon there must be something in the antergos installer that is different to just installing gnome separately. it may have something to do with gdm.

  • alrighty then, false alarm. now the opposite is happening.

    • i put light-locker-settings to blank screen after 1 min -> this works
    • i go to youtube and watch a video and the screen does not blank after 1 min -> this works
    • youtube video finishes and i wait for 1 min -> screen does not blank! (even if i quite chrome and leave the computer alone)
    • i check light-locker settings and it seems the blank screen after 1 min setting has been changed to “never”.

    so it seems the problem now is that watching the youtube video changes to light-locker setting to blank screen to “never” but when the video finishes it does not change the setting back to 1 min.

  • @christianbrooker
    Hi!
    you can try to install the caffeine-ng from AUR and set specific programs to work with it like not suspend if your browser is opened.

    Is just an workaround off course.

    OBS: You need to start the app everytime you login (make a script, set autostart etc)

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • thanks but like i mentioned in the OP i need this to be automatic due to the whole falling asleep thing and not wanting to wake up in the middle of the night with a glaring laptop in my face.

  • @christianbrooker yes, but you can set to only work with your browser, but as i said is an workaround.

    OBS: i saw a similiar problem like yours somewhere else in our forum this week.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • its not a workaround because it wont work. if im watching a video in my browser and i fall asleep the browser wont close and the screen wont blank. i’d have to close the browser for the screen to blank and i can’t do that if im alseep.

management4 inhibit1 watching2 power9 Posts 9Views 325
Log in to reply