• Display turns off on startup but not without activitiy. Suspend ok.


    Hi. After i installed some new updates several days ago the problem appears. I dont know what updates. Display turns off not like in settings after 3 miinutes but almost outright at startup. And it dont turns off without activity anymore. At the same time suspend by time works. Can you give me advice plz how to fix this problem without changing lightdm to gdm. Because with gdm and wayland i have huge mouse acceleration in game that i run from wine. I dont know how to turn it off. And after googling i found out that it is old bug and anyone dont know how to fix it. Thank you for your time. Sorry for bad english )

  • Hi. Could you please be clearer? You are greeted by a black screen or your screen turns off after some time?. In the 2nd case, have you checked if your power management settings are ok?

    @Mega said i

    with gdm and wayland i have

    Are you under wayland now? If not (I believe nothing has changed in gnome 3.24) there should be an x11 session in gdm, too.

    @Mega said i

    After i installed some new updates several days ago the problem appears…
    …Can you give me advice plz

    Give the lts kernel a try and see if it gets rectified.

    1. sudo pacman -S linux-lts
      (if you have linux-headers installed, then also install linux-lts-headers with:
      sudo pacman linux-lts-headers

    2. Regenerate your GRUB:
      sudo grub-mkconfig -o /boot/grub/grub.cfg

    3. Reboot and choose the lts kernel to boot.
      Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Hi.
    When the system boots everything is ok. The display turns off like there is no activity after some seconds of inactivity. Faster than in settings. After that when there is no activity display does not turns off. The power settings are ok.

    I am not at wayland, i use x11. I dont want to switch to wayland. I read that such powersave problems solves with changing to wayland.

    I use different boot loader not grub. Dont remember how it named. It is more like Gummiboot.

  • I see, but I understand that you fon t want to try GDM because you have problems under wayland. What about GDM in x11 session, then. Did you try it?
    And what about running the lts linux kernel?
    *** Sorry I know nothing besides GRUB

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I tried GDM. And installed it by your instruction. But with GDM i got wayland. https://forum.antergos.com/topic/6064/turn-screen-off-after-inactivity/7#

    I dont know how to change kernel and fix boot loader. I chose Gummiboot because it is easy way to run system on UEFI after installation.

    Thank you for trying to help me )

  • @Mega said

    But with GDM i got wayland

    That s because wayland is the default session.
    So when you reach the ligin screen and click on the time, don t enter your password. Instead click on the tab on the bottom left hand side of the greeter. You should look for an option Gnome on X11, or something like this. Check the picture below.

    0_1494415878628_upload-9b308659-714d-4950-b483-c2042166ffdf https://s14-eu5.ixquick.com/cgi-bin/serveimage?url=http:%2F%2Fwww.linuxbsdos.com%2Fwp-content%2Fuploads%2F2014%2F06%2FGNOMELogin3-600x348.png&sp=6f3675da63208b068e6b48c626043f32

    Sorry, I cannot help you with Gummiboot…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • anarch, thank you very much ) This problem botherd me for a long time. I make one more donation ) Donation ID: 27527
    Minor comment ) Login screen looks different now ) I couldnn’t find this setting at once. And thinked that it is missing ) Good luck ;)

  • Is the problem solved, then? If so, will you mark it as “SOLVED”, please?
    Here s how to do it:
    0_1494453546213_markedassolved.png

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

activitiy1 startup12 turns1 display26 Posts 8Views 367
Log in to reply