• Imposible to build package on yaourt, eats all RAM


    I’m trying to install iridium browser from yaourt but its impossible, doesn’t matter if there is a tmp folder for PKGBUILD and yaourt in middle of the compilation its just goes to 100% ( i have 4GB of RAM and detects only 3.8 btw )

  • @Azur
    Hi!
    Ii just read about it… It seems yaourt uses the folder /tmp to compile the packages and that usually is half of your ram, so it would be around 2GB.

    It’s possible to redirect to another folder like /opt/tmp:
    yaourt --tmp /opt/tmp
    Then install
    yaourt -S your_package
    later on revert the process:
    yaourt --tmp /tmp

    SOURCE https://github.com/archlinuxfr/yaourt/issues/47

    Since you don’t specified if you get a message like “Not enough space” (that should cover the solution above) i can’t help you further.

    AND i’m just reading about it, so you can wait for someone else to help you.
    AND do you have swap?

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto

    Sorry for the lack of details, yes i have swap, even i created a swapfile of 7GB just in case

    i have a tmp folder for yaourt and makedpkg each one on my home folder
    there is not error message, is total freeze, i have to hard restart the PC

  • /tmp is tmpfs by default. This means that uses RAM and not your harddisk. Big programs will eat all your RAM and will made compilation impossible.

    Freezing has never happened to me, but I don’t see why it cannot happen.

  • @karasu Is there a way for him to workaround it?

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • two ways:

    1.)
    disable automatic mount of tmpfs > https://wiki.archlinux.org/index.php/Tmpfs#Disable_automatic_mount

    2.)
    As you say that EATS ALL RAM it looks like you do not use a /tmp folder inside your homedir…

    edit yaourt to use folder instead of tmpfs:

    $ sudo nano /etc/yaourtrc
    

    change:

    TMPDIR="/tmp"

    to something like:

    TMPDIR="/home/USERNAME/.local/tmp"

    But using not RAM for yaourt does not mean that system takes RAM, as far as i know yaourt /tmp dir is only for unpacking sourcefiles e.t.c. the buildprocess depending on wich programms and libs are used will take tmpfs also…

    So first option is best if you do not have much RAM (4GB) is not much today ;)

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • alternative /tmp for yaourt:
    Bild Text
    mask tmpfs:
    Bild Text

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • I took a screenshot before the freeze

    alt text

    @joekamprad said in Imposible to build package on yaourt, eats all RAM:

    two ways:

    1.)
    disable automatic mount of tmpfs > https://wiki.archlinux.org/index.php/Tmpfs#Disable_automatic_mount

    I did that, still happening

    2.)
    As you say that EATS ALL RAM it looks like you do not use a /tmp folder inside your homedir…

    edit yaourt to use folder instead of tmpfs:

    $ sudo nano /etc/yaourtrc
    

    change:

    TMPDIR="/tmp"

    to something like:

    TMPDIR="/home/USERNAME/.local/tmp"

    alt text

    i did that too, the tmp is there but still eating all the ram

    there isn’t a way to make to eat less ram? or this is more the package problem?

    @joekamprad said in Imposible to build package on yaourt, eats all RAM:

    mask tmpfs:

    explain

  • Standard behavior is that /tmp is mounted inside the RAM, you can change this by masking the service that will do this:

    $ sudo systemctl mask tmp.mount
    

    Files will no longer be stored in a tmpfs (inside your RAM), but your block device instead. The /tmp contents will now be preserved between reboots, which you might not want. To regain the previous behavior and clean the /tmp folder automatically when restarting your machine:
    create this file:

    $ sudo nano /etc/tmpfiles.d/tmp.conf
    

    paste this content:

    # see tmpfiles.d(5)
    # always enable /tmp folder cleaning
    D! /tmp 1777 root root 0
    
    # remove files in /var/tmp older than 10 days
    D /var/tmp 1777 root root 10d
    
    # namespace mountpoints (PrivateTmp=yes) are excluded from removal
    x /tmp/systemd-private-*
    x /var/tmp/systemd-private-*
    X /tmp/systemd-private-*/tmp
    X /var/tmp/systemd-private-*/tmp
    

    Save the file [ctlg+X] and reboot.

    4GB for 4 Core CPU is a bit underpowered also… i saw steam at you dash ;)

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in Imposible to build package on yaourt, eats all RAM:

    Standard behavior is that /tmp is mounted inside the RAM, you can change this by masking the service that will do this:
    $ sudo systemctl mask tmp.mount

    i said that i did that, but nothing changes, is still the same ( eating all the ram )

  • Yes missunderstand that …

    But what i should explain then?
    On my system load is around 1.6GB Ram usage all the build long with masked tmpfs… (1GB is from gnome alone) and i have 4 cores CPU like you, and 6GB of Ram installed…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

imposible2 eats1 ram7 yaourt23 Posts 11Views 1071
Log in to reply