• Cinnamon 3.x.x hightly unstable with nVidia Quadro NVS 5100m


    recently I’ve installed Antergos with cinnamon on a HP EliteBook 8540p. The Laptop have a Quadro NVS 5100m.
    On this laptop Cinnamon is highty unstable and crash a lot. WIth Cinnamon < 3.4.x changing TTY would resolve the problem but with Cinnamon > 3.4.x the system has gotten way more ustable (changinf TTY does nothing).

    I use the nVdia proprietary driver (340xx) but the problem is worse with nouveau (the computer won’t even load Light DM).

    I think its a problem with Cinnamon and this particular card, I’va gor an other laptopn (old Asus) with a GeForce GT220m with the same driver installed and everything is fine.

    Have some one any idea about that? Going file an issue in Cinnamon GitHUb? some packet to install?

  • So may the problem is not related to cinnamon itself it can be a driver/hardware issue, but without any logs we can not say anything.

    echo ---lspci--- > logs && lspci >> logs && echo ---lsusb--- >> logs && lsusb >> logs && echo ---dmesg--- >> logs && dmesg >> logs && echo ---journalctl-b--- >> logs && journalctl -b >> logs && tar -cf logs.tar logs

    plz post the logs.tar link https://filebin.ca/

  • Sorry and thank you I did not remembered the log command. Here is your link.


    (I prefere to use framadrop a service part of “degoogling” action in my country, its done with FOSS softwares and free and secure)

    I first though of cinnamon because after the recent uptadte to the last version of it the situation has gotten worse.

  • No idea?

    I don’t know anymore where do it come most of the time changing TTY make it work bu I have to “button” reboot a lot. When comming back to Xorg TTY some time Cinnamon show a message like “would you like to restart cinnamon”, some time it restart every thing nvidia splash screen > lightDM > Cinnamon, most of the time it goes back were it stoped.

    I don’t know any more what to do.

  • How you are install graphics Driver?
    Looks like Hybrid graphics? Bumblebee???
    May you try this:

    $ sudo pacman -S nvidia-installer
    nvidia-installer -t -b

    And have a Look what it give you.

  • Both with Cnchi and manual way following Archwiki. The two methods give the same results.

    I don’t think there is any hybrid graphics, I’m not sure the i5 m560 and the nvs 5100m are compatible with that. And I don’t recall any of this on windows when I still used it on this laptop. Also it worked is worked without problem till this autumn that’s what the most disturbing for me, I never have used this before even when I still did manual Arch install.

    [[email protected] ~]$ nvidia-installer -t -b
    2017-05-12 13:52:38 [INFO]: Antergos Nvidia Installer v1.12
    2017-05-12 13:52:38 [INFO]: All logs will be stored in /tmp/nvidia-installer.log
    2017-05-12 13:52:38 [INFO]: Running the installer in testing mode...
    2017-05-12 13:52:38 [INFO]: Installing bumblebee driver...
    2017-05-12 13:52:38 [INFO]: Removing conflicting packages...
    2017-05-12 13:52:38 [INFO]: pacman -Rs --noconfirm --noprogressbar --nodeps xf86-video-nouveau
    2017-05-12 13:52:38 [INFO]: pacman -Rs --noconfirm --noprogressbar --nodeps nvidia-340xx-utils
    2017-05-12 13:52:38 [INFO]: pacman -Rs --noconfirm --noprogressbar --nodeps lib32-nvidia-340xx-utils
    2017-05-12 13:52:38 [INFO]: Downloading and installing driver packages, please wait...
    2017-05-12 13:52:38 [INFO]: pacman -Sqy --noconfirm --noprogressbar bumblebee mesa xf86-video-intel nvidia virtualgl nvidia-settings bbswitch lib32-nvidia-utils lib32-virtualgl lib32-mesa
    2017-05-12 13:52:38 [INFO]: Adding user nekosan to bumblebee group...
    2017-05-12 13:52:38 [INFO]: gpasswd -a nekosan bumblebee
    2017-05-12 13:52:38 [INFO]: Adding user nekosan to video group...
    2017-05-12 13:52:38 [INFO]: gpasswd -a nekosan video
    2017-05-12 13:52:38 [INFO]: Patching /usr/share/applications/nvidia-settings.desktop...
    2017-05-12 13:52:38 [INFO]: sed -i s|Exec=/usr/bin/nvidia-settings|Exec=optirun -b none /usr/bin/nvidia-settings -c :8| /usr/share/applications/nvidia-settings.desktop
    2017-05-12 13:52:38 [INFO]: /etc/X11/xorg.conf.d/20-nvidia.conf not found. That's ok.
    2017-05-12 13:52:38 [INFO]: Installation finished. Nothing has been modified as testing mode was ON.

    I don’t understand that out put at all because this would install nvidia driver but this card need nvidia-340xx.

cinnamon90 unstable3 3.x.x1 hightly1 Posts 6Views 1452
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.