• URXVT / Vim 256colors with Base16 refuses to work


    I know this question has been asked and answered many times on many forums, but I’ve tried multiple solutions and can’t seem to get my colours working properly in my vim via urxvt.

    The urxt I am using was installed with pacman. Specifically, it is rxvt-unicode 9.22-2 from community and it is my understanding that this version should support 256color.

    .Xresources

    !--- URXVT ---!
    URxvt.font: xft:Inconsolata:size=12:antialias=true:hinting=true
    URxvt.boldFont: xft:Inconsolata:size=12:antialias=true:hinting=true
    
    URxvt.transparent: false
    URxvt.depth: 32
    
    !fonts spacing
    !URxvt.letterSpace: -6
    
    URxvt.scrollBar: false
    
    ! Add inner padding
    URxvt.internalBorder: 10
    
    URxvt*termName:rxvt-unicode-256color
    
    !--- COLOURS ---!
    
    ! Base16 Flat
    ! Scheme: Chris Kempson (http://chriskempson.com)
    
    #define base00 #2C3E50
    #define base01 #34495E
    #define base02 #7F8C8D
    #define base03 #95A5A6
    #define base04 #BDC3C7
    #define base05 #e0e0e0
    #define base06 #f5f5f5
    #define base07 #ECF0F1
    #define base08 #E74C3C
    #define base09 #E67E22
    #define base0A #F1C40F
    #define base0B #2ECC71
    #define base0C #1ABC9C
    #define base0D #3498DB
    #define base0E #9B59B6
    #define base0F #be643c
    
    *.foreground:   base05
    #ifdef background_opacity
    *.background:   [background_opacity]base00
    #else
    *.background:   base00
    #endif
    *.cursorColor:  base05
    
    
    *.color0:       base00
    *.color1:       base08
    *.color2:       base0B
    *.color3:       base0A
    *.color4:       base0D
    *.color5:       base0E
    *.color6:       base0C
    *.color7:       base05
    
    *.color8:       base03
    *.color9:       base08
    *.color10:      base0B
    *.color11:      base0A
    *.color12:      base0D
    *.color13:      base0E
    *.color14:      base0C
    *.color15:      base07
    
    ! Note: colors beyond 15 might not be loaded (e.g., xterm, urxvt),
    ! use 'shell' template to set these if necessary
    *.color16:      base09
    *.color17:      base0F
    *.color18:      base01
    *.color19:      base02
    *.color20:      base04
    *.color21:      base06
    

    .vimrc

    " --- PLUGINS --- "
    set nocompatible              " be iMproved, required
    filetype off                  " required
    
    " set the runtime path to include Vundle and initialize
    set rtp+=~/.vim/bundle/Vundle.vim
    
    call vundle#begin()
    " alternatively, pass a path where Vundle should install plugins
    "call vundle#begin('~/some/path/here')
    
    " let Vundle manage Vundle, required
    Plugin 'VundleVim/Vundle.vim'
    
    Plugin 'chriskempson/base16-vim'
    Plugin 'tpope/vim-fugitive'
    Plugin 'scrooloose/nerdcommenter'
    Plugin 'scrooloose/nerdtree'
    Plugin 'bling/vim-airline'
    Plugin 'vim-airline/vim-airline-themes'
    Plugin 'pangloss/vim-javascript'
    Plugin 'jiangmiao/auto-pairs'
    Plugin 'vim-syntastic/syntastic'
    Plugin 'tpope/vim-surround'
    Plugin 'valloric/youcompleteme'
    
    " All of your Plugins must be added before the following line
    call vundle#end()            " required
    
    filetype plugin indent on    " required
    " To ignore plugin indent changes, instead use:
    "filetype plugin on
    
    " --- END PLUGIN --- "
    
    " Set 256 colours
    "set t_Co=256
    
    set background=dark
    let base16colorspace=256
    color base16-flat
    
    syntax enable
    
    set number
    set hls
    set nowrap
    
    
    " Indent settings
    set tabstop=3
    set shiftwidth=3
    set softtabstop=3
    set expandtab
    
    " The following are commented out as they cause vim to behave a lot
    " differently from regular Vi. They are highly recommended though.
    set showcmd		" Show (partial) command in status line.
    set showmatch		" Show matching brackets.
    set ignorecase		" Do case insensitive matching
    set smartcase		" Do smart case matching
    set incsearch		" Incremental search
    set autowrite		" Automatically save before commands like :next and :make
    set hidden		" Hide buffers when they are abandoned
    set mouse=a		" Enable mouse usage (all modes)
    

    $TERM: rxvt-unicode-256color
    tput colors: 256

    Screenshot
    0_1494091433852_vim.png

    Let me know if I missed any details.

    Thanks in advance!

    Coder / Tech enthusiast / Linux convert / Motocross fan / Master Procrastinator

  • @Wheelzz have you tried the version in AUR already?
    https://aur.archlinux.org/packages/rxvt-unicode-256xresources/
    I think it is there for a reason, but I don’t know exactly.

    mutze

    eternal noob

  • @mutze Oh damn, I feel so silly now. For some reason I was under the impression that the rxvt-unicode from pacman now supported 256 via Xresources and that the aur package was deprecated. However I was wrong. Installing that via yaourt solved my issue. Thanks.

    Coder / Tech enthusiast / Linux convert / Motocross fan / Master Procrastinator

terminal27 shell10 colors4 vim3 Posts 3Views 168
Log in to reply