• Mic not working


    Hello
    I have a laptop Asus A55V, when I installed antergos (cinnamon) I had the mic working just fine.
    At some point it stopped working, I’ve tried following many guides I found on the net but none of them worked for me.
    Can anyone help me please?
    Thank you in advance

  • Since I have no magic glass ball, I can not know what has already been tried everything. ;)
    But searching for the Asus A55V mostly it goes around unmuting and choosing the right mic channel with the common tools solve the problem.

    the command:

    pactl list sources
    

    will give information about sound devices.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    This is the output of that command.

    Source #0
    	State: SUSPENDED
    	Name: alsa_output.pci-0000_00_1b.0.analog-stereo.monitor
    	Description: Monitor of Audio interno Stereo analogico
    	Driver: module-alsa-card.c
    	Sample Specification: s16le 2ch 44100Hz
    	Channel Map: front-left,front-right
    	Owner Module: 6
    	Mute: no
    	Volume: front-left: 29987 /  46% / -20.37 dB,   front-right: 29987 /  46% / -20.37 dB
    	        balance 0.00
    	Base Volume: 65536 / 100% / 0.00 dB
    	Monitor of Sink: alsa_output.pci-0000_00_1b.0.analog-stereo
    	Latency: 0 usec, configured 0 usec
    	Flags: DECIBEL_VOLUME LATENCY 
    	Properties:
    		device.description = "Monitor of Audio interno Stereo analogico"
    		device.class = "monitor"
    		alsa.card = "0"
    		alsa.card_name = "HDA Intel PCH"
    		alsa.long_card_name = "HDA Intel PCH at 0xf7a10000 irq 30"
    		alsa.driver_name = "snd_hda_intel"
    		device.bus_path = "pci-0000:00:1b.0"
    		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
    		device.bus = "pci"
    		device.vendor.id = "8086"
    		device.vendor.name = "Intel Corporation"
    		device.product.id = "1e20"
    		device.product.name = "7 Series/C216 Chipset Family High Definition Audio Controller"
    		device.form_factor = "internal"
    		device.string = "0"
    		module-udev-detect.discovered = "1"
    		device.icon_name = "audio-card-pci"
    	Formats:
    		pcm
    
    
  • can you provide alsamixer inside terminal try pressing [F6] you may can choose the HDA Intel device instead of dummy device.
    With [F5] you can show all channels (input/output)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Bild Text

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    Yeah, tried setting those to the maximum value even but the mic keeps not working

  • What you mean ? it does not stream to Monitor or it does not get any sound input?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Bild Text
    pavucontrol

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • It doesn’t get any sound input, in the settings panel the system recognises and finds it but for example some programs like wire tell me that i don’t have a mic, or if i try to send a vocal message via telegram in the message there’s no sound at all

    this is what i see in the settings and it doesn’t let me raise the volume up
    http://imgur.com/a/mwwxN

  • this is may caused by this programs itself then.
    You can try the following:

    padsp /usr/bin/telegram-desktop
    

    "this is what i see in the settings and it doesn’t let me raise the volume up"
    because it is muted

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    The command doen’t work but i’m pretty sure it’s not the program

    Also if it’s muted, how do i unmute it?

  • Bild Text
    pressing “M” for mute/unmute the channel

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • But as long you do not say what you do/try before it is searching for needles in the hay…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    OK for the moment i’m following what you say, unmuting it with m didn’t work out
    these are the things i’ve tried already:
    https://bbs.archlinux.org/viewtopic.php?id=141929
    https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting
    https://unix.stackexchange.com/questions/293876/microphone-not-working-on-archlinux
    https://www.reddit.com/r/archlinux/comments/3lngka/microphone_not_working_in_applications/

    also I’ve tried with pavucontrol and reinstalling pulseaudio but it didn’t work out

  • @joekamprad
    If you need any log I’ll provide you

    The unfortunate thing is that i realised that the mic is not working probably after a long time after something cause its current state since I don’t often use it, otherwhise It would have been way easier to troubleshoot the problem.

  • And do you try to check if the wring mic is choosen?
    alsamixer > F6 choose intel-hda > F4 input Source choose the right mic with up/down button

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • what gives you this:

    head -n 1 /proc/asound/card0/codec*
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad

    ==> /proc/asound/card0/codec#0 <==
    Codec: Realtek ALC270
    
    ==> /proc/asound/card0/codec#3 <==
    Codec: Intel PantherPoint HDMI
    
    
mic2 Posts 27Views 906
Log in to reply