• Has anyone had any luck getting Mycroft to work?


    I installed Mycroft from the AUR, but it doesn’t just run. I don’t want to put in a lot of time on this if no one has it working on Arch. Please let me know if you have it running and you think it works well.

    Thanks

    'Could be worse. 'Could be raining.
    Mike Bee

  • HI!
    For me, the short answer is no. Granted, I have not tried it on Arch, but instead on an Ubuntu derivative, which was an officially supported platform for Mycroft. Even that did not work entirely, All I got was “Hello” and something about “Insufficient data to process blah blah blah” I tried multiple times on that distro, but the closest I ever got to functionality was that. It could have been me, but I would suspect that if that did not work on a supported platform, the one from the AUR would not either. The long answer is possibly. As I said, I have not tried it on Arch, and I am no coder. I did not mess with the Mycroft packages at all and only attempted to install them. Like you, I didn’t feel the need to spend hours of my time on it.
    I know that probably did not help much, but I didn’t see anyone responding so I did. Hope that helps and good luck!

  • @Mike-Bee You should try to run mycroft through terminal, then the errors will be displayed and you copy/paste them here for adding more info to your post. Maybe someone will be able to help you.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto I’ve decided not to pursue Mycroft. All my research says that even if I getting working, it’s not very good. Yesterday I got PocketSphinx to run, and it’s awful. So for now I will forget my dream of a keyboardless system ;)

    'Could be worse. 'Could be raining.
    Mike Bee

  • @Mike-Bee i searched a lot about it and didn’t find a solution some time ago too.
    One thing you can try is to use easystroke after configured you can do many things with it and save a lot of time. It’s a mouse gesture recognition software, and there is a very good series on youtube about it.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

mycroft1 assistant3 a.i1 Posts 5Views 120
Log in to reply