• Installing Antergos to USB

    I recently came across Antergos and wish to install it😀. However, I don’t have much room on my computer and was hoping to install it to my USB drive instead. I have never done this before, and so was hoping for some help. Although I have used Linux for awhile, I am not very good at the command line (yet) and so am hoping there is a way to do it in Cnchi easily. Any help would be appreciated. Thank you very much!

  • Why don’t you try then installing in Virtualbox?
    If you get a powerfull System this will be a more easy option.

  • Thank you very much for the help, but I have already installed it in Virtualbox. Due to its’ lag and other shortcomings though, I was hoping to be able to run it natively on my computer. Since I don’t have a ton of room, I wanted to store it on a USB instead of directly on my computer. Any way to do this would be appreciated😃

  • @A-User
    there are some ways for do what you’re planning.

    1. using 2 USB drivers
      1.1) one with the bootable livecd (or burn a dvd with the liveiso)
      1.2) an empty/partitioned USB

    boot the liveUSB and install at the other pendrive

    If you can’t do that you can use virtualbox

    First way:
    Add the livecd to virtualbox
    Connect your pendrive > go to devices and add the pendrive (be sure that your user is in /etc/group at the line vboxusers, otherwise you won’t be able to add devices beyond cd/dvd)
    install in USBdrive

    There are others ways of installing, but is an unecessary reading for you, i’m sure one of the above methods are going to work.

    OBS: I wouldn’t recommend installing a persistent OS in pendrives (just for testing purposes, better to use an external HD/SDD) , specially a rolling release distro as Antergos, you know that flash drives has a limited number of writing/rewriting cycles, that means your pendrive will burn some day.

  • Thank you so much! I’m about to go and try it. If I get lost part way through I’ll be sure to ask. I really appreciate all of the helpful responses and people who have taken the time to help answer this.

  • So… how do I “install at the other pendrive” as Fernandomaroto mentioned? I’m a bit confused😕

  • @A-User
    Boot the pendrive with liveiso and connect also the other pendrive (both are plugged)
    when you are installing inside cnchi choose the empty pendrive at the partitions options (is an option like “Choose exactly where to install Antergos”)

  • @fernandomaroto said in Installing Antergos to USB:

    Boot the pendrive with liveiso and connect also the other pendrive (both are plugged)

    So I need 2 pendrive to install antergos and then bootearlos in a computer ???

  • So I’m at “Choose exactly where Antergos should be installed”, but I don’t quite understand what to do from there (I’m a bit of a newbie at this, not that you would have ever guessed😀) I see “sdc” as one of the options and I read at [this] website,(http://ubuntuhandbook.org/index.php/2014/11/install-real-ubuntu-os-usb-drive/)
    that I should use Gparted to free all the space on my drive. So I followed the instructions until Step 6, at which I got confused, sadly, at the most important step. I understand this article is a little outdated and made for Ubuntu, but was the most recent one I could find. Thank you for all of your help and time. And patience.

  • I spent a bit more time scouring the internet for instructions, and found this. I know it is for Ubuntu, but it definitely helped me with 2 out of 3 of the partitions. However, I am still stumped on the 3rd partition located at “Mount Partitions” near the bottom of the screen which indicates that I need a partition for “EFI ( /boot/EFI)” which I don’t quite understand. I’d just wing it, (like I normally do when I come to something I don’t get on Linux, and then learn along the way) but am worried about screwing up something as crucial as my partitions.

  • @judd
    Yes. As I understand it, one is needed for booting Antergos (aka. a “live usb”) and another to install it onto. On my computer at least, when I pick “Choose exactly where Antergos should be installed” it does not even show my Live USB (“sdb” option), and goes straight to “sdc” (the second USB).

  • Yay! I think I finally did it! For those that need help (if you are like me) I found the EFI information on Archwiki at this site. It says the recommended minimum is 512 GB, but that a little more is best. Thanks everyone for all of the help, and if I have any problems, I guess I’ll be back.😀

  • @A-User Hi!
    I just came back now, sorry.
    Ok i’m happy you did it, if you plan to boot your new OS on other machines i’d recommend you to install in “legacy mode” (not sure if you heard about it) instead of “EFI mode”, since only new Motherboards suport it.
    But if you have new pcs is not a problem at all.

    On my computer at least, when I pick “Choose exactly where Antergos should be installed” it does not even show my Live USB (“sdb” option), and goes straight to “sdc” (the second USB).

    I didn’t remember that before, if you booted from pendrive only the empty one is recognized, easier then.

    Again i’m glad you made it!

  • @judd said in Installing Antergos to USB:

    @fernandomaroto said in Installing Antergos to USB:

    Boot the pendrive with liveiso and connect also the other pendrive (both are plugged)

    So I need 2 pendrive to install antergos and then bootearlos in a computer ???

    Yes, or do it through virtualbox, it’s easier (if you know how to play with VM) and you can keep on using the computer while installing.
    I guess there are some tutorials on youtube about it.

  • so… I thought that I had installed it correctly because after I installed I rebooted successfully into Antergos. However, this morning (morning over here for me at least) it would’t boot. When I tried to, it said that there where “incorrect partitions” and stopped there. I know I didn’t do anything in my sleep!😀 What happened!? Did I truly do something wrong?

    If you were wondering, here’s what I did (as far as I can recall):

    1. I followed the instructions from here up to the point where he presses “Install Now” (at 10:36 into the video)
    2. As for the swap partition, I did not have the choice of picking “Logical” at first, so I picked “extended”, which grayed everything out underneath it. Then, when I finished editing it, I noticed that underneath the “extended” partition as its’ sub-category, there was now an equal amount of “allocated space” as the “extended” partition. So I clicked that, and began editing. Now, it finally showed me the “Logical” choice with everything else the same. I assumed I just had to jump through these hoops, so I wasn’t that worried.
    3. I made a “/boot/efi” partition that was 524 MB large and defined as “fat32”. It matched my “fat32 partition” on my actual computer in size exactly. I didn’t know if this was right but decided to give it a go since I knew it would only foul up my USB and not my computer.

    …and that’s what I did, in 3 very long steps. I thought I had done it correctly when I rebooted and everything went well, so I shut back down and unplugged my USB for the night and went to bed all excited…for my hopes to be dashed the next morning when I booted back up from my USB. I hope this helps, but as I said, I have no idea exactly where I went wrong. Thanks for the help, I wouldn’t have gotten this far without you.

  • @A-User I’ll check the video you pointed and get back to you.
    Is it possible that your Bios came back to previous options? i mean, try again; connect your usb, turn on your pc and check if boot options is set to boot from USB.

    OBS: i never mixed logical/extended partition always used one or another, but i guessing swap wouldn’t prevent you from booting…

    here is one tutorial for installing Antergos EFI

    Only found videos about legacy mode

  • Thank you so much! I will check out your links now. As for the Boot Sequence, I have already checked in my Bios, but thanks for mentioning it. Maybe one of your links will help me.

  • I just finished looking at your articles and found the tutorial VERY helpful. I am re-installing Antergos again and am now hoping it works. Here’s hoping! If it doesn’t, I’ll try Legacy mode. Thanks again for all your time.

  • Well, I tried installing once again, and the exact same thing happened as when I tried it yesterday and it booted once but was nowhere to be seen after that. I checked the Boot Sequence, but there was nothing out of the normal, I set it to boot from my USB, but it refused to do so. I followed the tutorial exactly, but one thing came to mind. There was a notice on the tutorial that said NOT to format the “/boot/efi”, but when I attempted not to, it showed the “Mount Checklist” as not meeting the requirement of “/boot/efi” until I made my own partition of it and agreed to format it. Would this be the cause of the disappearing system? Thanks again for all your help, it is one of the things I appreciate most about Linux, the way the community helps each other. (really beats Microsoft tech support, or lack there of)!

  • @A-User The warning about NOT formating the /boot/efi partition is only for installing in a real pc, where windows or other OS is installed, meaning that formating the mentioned partition would erase all windows boot config.
    Since you’re installing in a pendrive, where you only want Antergos, there is no problem about erasing that partition and recreating it.
    I never installed Antergos EFI in pendrive, so i’m not sure if you’re experiencing a bug.
    With Legacy mode i already installed with the methods in my first post, and they all worked here.

    I’m not experienced in fixing boot problems (luckily i never faced one), so i can’t help you with that.

    OBS: if you want to give another try, where you get to that partition options, you should erase all current partitions and choose “Create a new partition table”, then choose MBR/DOS (legacy mode) instead of GPT (UEFI).

    Don’t hesitate of asking help, we’re here to help each other.

installation326 usb117 cinchi2 pendrive2 Posts 24Views 5185
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.