• After switching language I got mixed input from both languages


    Hello

    I got this issue when I switch from English to Bulgarian. If English is my default language and switch to Bulgarian then what i got as input for letter д is either the English d or the Bulgarian д. And this goes with all other letter. Deleting Bulgarian and then adding it back doesn’t fix the issue. And it is the same problem with any other language. Strangely enough, when I changed the Bulgarian to be a default language - nothing happens. The Bulgarian input was just English one, and the English was this mixture of English and Bulgarian letters (like: дддddddddddддdддdддdd). I have no idea what could went wrong and how to debug it.

    Here is a copy of /etc/X11/xorg.conf.d/00-keyboard.conf

    Section "InputClass"
            Identifier "system-keyboard"
            MatchIsKeyboard "on"
            Option "XkbLayout" "us,bg"
            Option "XkbVariant" ",phonetic"
    EndSection
    

    PS: I’m using GNOME and have everything up to date.

    Тhanк you.

  • Is it possible that you use a single key to switch to another input source (for example, Left Alt) and press it inadvertisingly? Try to use a double-key switch, for example, both Shift keys together.

    Is there a particular reason to use Bulgarian (traditional phonetic) keyboard layout? Maybe Bulgarian corresponds better to your physical keyboard?

    Anyhow, I added Bulgarian (traditional phonetic) to my English (UK), Russian, Italian, English (US), Finnish input sources. Bulgarian works flawlessly. It is not mixed in when I use either Englisn, or Finnish, or Russian, or Italian layouts. I’m using Both Shift keys together to switch between layouts.

    Don’t pay much attention to 00-keyboard.conf. It is fully controlled by Gnome and automagically adjusted as needed. Mine is similar to yours:

    Section "InputClass"
            Identifier "system-keyboard"
            MatchIsKeyboard "on"
            Option "XkbLayout" "gb,ru,it,us,fi,bg"
            Option "XkbVariant" ",,,,phonetic"
    EndSection
    
    
  • Thank you for your answer.

    I’m switching languages with super + space or alt + shift, and the problem is reproduced by both ways. Also a single key press does not switch languages as I would the following input if I’m pressing f key : фfфf while I’m getting absolutely random фfффффfффffфf, holding the f will result in something like fфffффfffффffффффffffфf . Also this happens not only with Bulgarian but any other language that is not primary (default) and in the same time (as I mentioned above) the primary language is always English (no matter that I’m setting it to be Bulgarian).

  • Sorry, I can’t reproduce your issue. I’m switching between various input sources and hold down English d and f keys. All input sources work as they should:

    English (UK)

    • ddddddddddddddddddddddd
    • fffffffffffffffffffffff

    Russian

    • вввввввввввввввввввв
    • ааааааааааааааааааа

    Italian

    • ddddddddddddddddddddddd
    • fffffffffffffffffffffff

    English (US)

    • ddddddddddddddddddddddd
    • fffffffffffffffffffffff

    Finnish

    • ddddddddddddddddddddddd
    • fffffffffffffffffffffff

    Bulgarian (traditional phonetic)

    • ддддддддддддддддд
    • фффффффффффффф

    Works only one input source at a time. Other input sources are not mixed in.

  • Yes, that is how it should work. But since today I have this weird issue.
    I found something new. If I add Bulgarian (new phonetic) it has no issues. So it has to be something with conflict with the Bulgarian (traditional phonetic).

    Do you know where I can check the files which has the key mapping of the letter for each language (I’m not sure if it is called mapping).

    Thank you.

  • Oh, Disregard the previous one. It has nothing to do with the type of the Bulgarian. It is this that if I add 3 new language layout the third one will work properly so I have:
    1.English
    2.Bulgarian
    3.Bulgarian (new phonetic)
    4.Bulgarian (traditional phonetic)

    2 and 3 are with mixed input (english and bulgarian) but 4 is ok. What matters is the order.
    So I will use it like this, may be one day there will be a magic update that will make everything in its own place.

    Thank you for the support

  • Good that the workaround works for you. Though the issue still remains unclear for me. I’m not satisfied - but it’s only my problem :-)

  • Yes, I’m also not happy with the current solution but still it works. Hope I had more time to investigate.
    Thanks again.

  • I don’t know if this will help, but what if you run “sudo pacman -Sc” to autoremove any unwanted packages that are not being used. Perhaps this could alleviate the package confliction without having to uninstall either of them. I have no idea if this would work, it is only an idea.
    Good luck!

    Keep trying, never give up. In the end, you will find that it was all worth it

    https://sourceforge.net/projects/antergos-deepin
    https://linuxbasicssite.wordpress.com

language14 keyboard layout5 Posts 9Views 283
Log in to reply