• \[solved\] 64 bits Antergos install on Acer 720p chromebook


    here I am again,

    this time, I am trying to install antergos on a Acer 720p chromebook after seeing a podcast from JupiterBroadcasting saying that this was a perfect antergos laptop.

    Here is my problem.
    It is not possible to boot this chromebook with the latest Antergos 64bits iso.
    This is a known bug with Arch iso images newer than 2013.10.01 (see [url:1zqtfhhe]https://wiki.archlinux.org/index.php/Acer_C720_Chromebook[/url:1zqtfhhe]). By chance I still have an Antergos ISO from August 2013. This time, the laptop booted up flawlessly.

    I was not able to perform the installation as cnchi stopped, complaining about an error during package list recovering (if I remember well).

    I installed the latest version of cnchi either as described [url:1zqtfhhe]http://forum.antergos.com/viewtopic.php?f=5&t=1285[/url:1zqtfhhe] or modifying the default antergos repo to the french one that includes a recent version of cnchi. Unfortunately cnchi refused to be launched complaining about GTK version (a variable not found in the python script line 129).

    Is it possible to use a newest cnchi version on an old Antergos ISO?

    Thank you for your help (Mr Lots.0.logs perhaps?).

    O-p

    [Edit] Install/Guideline:

    1. See Arch wiki web page for preparing install
    2. Boot using Antergos 2013-08-2 64 bit iso (I still have a copy of it if someone need it)
    3. Download latest CLI installer: [url:1zqtfhhe]https://raw.githubusercontent.com/Antergos/antergos-iso/master/configs/antergos/root-image/arch/setup[/url:1zqtfhhe] and copy the setup file to "/arch/setup"
      I chose btfrs file system with compression enabled to have more room on the “small” 32 Gb SSD.
    4. After install, reboot. If unable to log in switch to tty console (Ctrl+Alt+F2) and symlink gnome.desktop to default.desktop
    sudo ln -s /usr/share/xsessions/gnome.desktop /usr/share/xsessions/default.desktop
    

    then reboot and it shoud work.

    1. go back to Arch wiki web page to install screen/touchpad driver and fix suspend.

    Personally I installed antergos this way then changed lightdm to gdm. I backed up my install using Clonezilla then restored chrome os allowing me to remove the write protecting screw and enable default seabios boot. Then I restored my antergos install and that’s it.

    [Edit #2]
    For those who would like (need) to use Antergos 2013-08-2 64 bit iso (for chromebooks essentially) I put it there : [url:1zqtfhhe]https://mega.co.nz/#!JBAnVSAa!Jf0OjTjz-SZ3K82owuIa-O2y40yDbrDlbvhtoTJ3TKc[/url:1zqtfhhe]

  • here I am again,

    this time, I am trying to install antergos on a Acer 720p chromebook after seeing a podcast from JupiterBroadcasting saying that this was a perfect antergos laptop.

    Here is my problem.
    It is not possible to boot this chromebook with the latest Antergos 64bits iso.
    This is a known bug with Arch iso images newer than 2013.10.01 (see [url:1zqtfhhe]https://wiki.archlinux.org/index.php/Acer_C720_Chromebook[/url:1zqtfhhe]). By chance I still have an Antergos ISO from August 2013. This time, the laptop booted up flawlessly.

    I was not able to perform the installation as cnchi stopped, complaining about an error during package list recovering (if I remember well).

    I installed the latest version of cnchi either as described [url:1zqtfhhe]http://forum.antergos.com/viewtopic.php?f=5&t=1285[/url:1zqtfhhe] or modifying the default antergos repo to the french one that includes a recent version of cnchi. Unfortunately cnchi refused to be launched complaining about GTK version (a variable not found in the python script line 129).

    Is it possible to use a newest cnchi version on an old Antergos ISO?

    Thank you for your help (Mr Lots.0.logs perhaps?).

    O-p

    [Edit] Install/Guideline:

    1. See Arch wiki web page for preparing install
    2. Boot using Antergos 2013-08-2 64 bit iso (I still have a copy of it if someone need it)
    3. Download latest CLI installer: [url:1zqtfhhe]https://raw.githubusercontent.com/Antergos/antergos-iso/master/configs/antergos/root-image/arch/setup[/url:1zqtfhhe] and copy the setup file to "/arch/setup"
      I chose btfrs file system with compression enabled to have more room on the “small” 32 Gb SSD.
    4. After install, reboot. If unable to log in switch to tty console (Ctrl+Alt+F2) and symlink gnome.desktop to default.desktop
    sudo ln -s /usr/share/xsessions/gnome.desktop /usr/share/xsessions/default.desktop
    

    then reboot and it shoud work.

    1. go back to Arch wiki web page to install screen/touchpad driver and fix suspend.

    Personally I installed antergos this way then changed lightdm to gdm. I backed up my install using Clonezilla then restored chrome os allowing me to remove the write protecting screw and enable default seabios boot. Then I restored my antergos install and that’s it.

    [Edit #2]
    For those who would like (need) to use Antergos 2013-08-2 64 bit iso (for chromebooks essentially) I put it there : [url:1zqtfhhe]https://mega.co.nz/#!JBAnVSAa!Jf0OjTjz-SZ3K82owuIa-O2y40yDbrDlbvhtoTJ3TKc[/url:1zqtfhhe]

  • you could try this. Bootup the 2013 ISO and open the terminal.

    then do the following commands.

    wget http://antergos.info/testing.sh  
      
    chmod +x testing.sh  
      
    sudo -E ./testing.sh  
    
    
  • Hi,

    You can but you will need to update the packages on the iso first:

    sudo pacman -Syyu
    

    Then you can run the testing.sh script as described in the “Cnchi Bug Hunters” thread. Let us know if you have any questions.

    Cheers!

  • @“pseudonym”:2i33nuo9 said:

    you could try this. Bootup the 2013 ISO and open the terminal.

    then do the following commands.

    wget http://antergos.info/testing.sh  
    >   
    > chmod +x testing.sh  
    >   
    > sudo -E ./testing.sh  
    > 
    

    Thanks, I have already done that but the installer does not start.

    @Lots.0.logs
    Thank you, I will try this evening and keep you posted.

    O-p

  • Maybe the cli-installer is a better option for your case

  • @“lots.0.logs”:2gv4hvom said:

    Hi,

    You can but you will need to update the packages on the iso first:

    sudo pacman -Syyu
    

    Then you can run the testing.sh script as described in the “Cnchi Bug Hunters” thread. Let us know if you have any questions.

    Cheers![/quote:2gv4hvom]
    Arg!
    could not update… I suppose that the 2Gb of ram are not enough for that…
    I don’t exactly how it works, maybe I need a bigger USB drive (this one is a 1Gb).

    O-p

  • Nah 2GB wont be enough to allow updating the packages on the iso. Like @faidoc mentioned, You could use the CLI instead. Download the latest version from here: [https://raw.githubusercontent.com/Antergos/antergos-iso/master/configs/antergos/root-image/arch/setup][0]">[https://raw.githubusercontent.com/Anter][1] … arch/setup You can overwrite the old one at “/arch/setup”. Hope it helps!

    [0]: <a href=
    [1]: https://raw.githubusercontent.com/Anter

  • Thanks, I will try that…

    Cheers

    O-p

  • Carrramba!
    using CLI allowed me to install antergos + Gnome… but I cannot log in…
    the new greater (which is very nice by the way) ask me my password but nothing happen after pressing “enter” or clicking the the white arrow… (the log window indicate that I am authenticated!)
    I switched to an other console (Ctrl+Alt+F2) and could log in with my username/password

    Grrrrrr… I was so close!

    Ps: one of my major problem came from my various attempts to format manually my hardrive… I had to zeroed and recreate partition table / partitions for Grub to install properly.

    Any little more help please?

    O-p

  • After booting up, change the tty and install proprietary graphics drivers. I think yours should be Intel.

    Sounds like my notebooks behavior. It also fails to login/startx after installation because of nouveau. After installing nvidia and rebooting I can login without problems.

    Please give a feedback after you get help so the thread can be set to solved.

  • In my case xorg is started…
    I will to install gdm .

    Have a good day.

    O-p

    Edit: in fact my skills were not sufficient… I am installing Antergos, using the old CLI (that install gnome + gdm) to see if it works

  • Hi,

    Actually, there are no proprietary Intel drivers. Intel contributes directly to the open source drivers. After you have made an attempt to enter your password in the greeter, switch to another VT and grab the following logs:

    [list:hoe8z2zw][*:hoe8z2zw]/var/log/lightdm/lightdm.log[/*:m:hoe8z2zw][/list:u:hoe8z2zw]
    [list:hoe8z2zw][*:hoe8z2zw]/var/log/lightdm/x-0-greeter.log[/*:m:hoe8z2zw][/list:u:hoe8z2zw]
    [list:hoe8z2zw][*:hoe8z2zw]/var/log/Xorg.0.log[/*:m:hoe8z2zw][/list:u:hoe8z2zw]

    Best Regards,

  • I am sorry not being able to past full logs as requested but I cannot log in except from tty console and have no internet connection as it is a wifi only laptop… if I am not logged in… no internet…

    The end of /var/log/lightdm/lightdm.log populate with the infos above after login trial:

    Authentication complete with return value 0: Sucess
    Authentication result for user patrick: Sucess
    User patrick authorized
    Greeter requests session default
    Failed to find session configuration default
    Can’t find session ‘default’

    So I think that the problem is there… now, is it possible to generate a “session configuration default”?

    Thank for the time you kindly spend answering me.

    Cheers.

    O-p

  • Try this:

    sudo nano /etc/lightdm/lightdm.conf

    There you look for the line

    user-session=default (I assume it is default because the error message calls it default)

    Change the line to this:

    user-session=gnome-shell

    Then CTRL+X to exit and then “y” to save. Reboot and look if it works.

    Please give a feedback after you get help so the thread can be set to solved.

  • @“b1n0ry”:3o5brs7f said:

    Try this:

    sudo nano /etc/lightdm/lightdm.conf

    There you look for the line

    user-session=default (I assume it is default because the error message calls it default)

    Change the line to this:

    user-session=gnome-shell

    Then CTRL+X to exit and then “y” to save. Reboot and look if it works.[/quote:3o5brs7f]

    Thanks I just had the very same idea except that I created a symbolic link in /usr/share/xsessions/ named default.desktop and pointing to gnome.desktop

    And it works…

    But I don’t know where this problem comes from.

    Thanks again…

    O-p

  • Nice to hear that

    Please give a feedback after you get help so the thread can be set to solved.

  • Sorry about that. It will be corrected

    Cheers!

  • Thanks!

    there is also a problem with the repos…
    using pacman -Syyu returns synchronization error for all repos (core, extra, community and multilib) except the antergos one.

    I’ll have to find how to correct that

    Cheers.

    O-p

    Edit: done! I copy/past the from my main Antergos/Arch box

Posts 19Views 3963
Log in to reply