• GRUB problem


    Hi!

    I had fedora on my notebook as dual boot with my win10.

    I deleted fedora and wanted to try antergos but it seems that i made a mistake :)

    I created 3 partitions ( /, /home, /swap) and pointed boot-efi to my boot partition

    This is what it looks like (booted with live system):
    0_1493805748169_IMG_20170503_114503.jpg

    p5 = /
    p6 = /home
    p7 = /swap

    When I try to boot grub gives me:
    0_1493805819776_IMG_20170503_114608.jpg

    How do I repair this? :)

    Anyone can help?

    Thx in advance

  • First time i see nvme device naming.
    You say:
    I created 3 partitions ( /, /home, /swap) and pointed boot-efi to my boot partition
    You need a /boot partition for grub if you want to use grub, the EFI -Boot partition will be mounted to /boot/efi then

  • The tutorial in wiki (How to dual boot antergos windows uefi expanded)
    says:
    << Next is to create the /boot/efi partition. Actually, we don’t need to create it. Windows already have it. We can just specify the path to it. Just make sure to NOT format it. >>

    Thats a bit confusing then…

    p.s. I even cant post links to your own wiki :) Flagged as spam…

  • /boot/efi is the mountpoint where you have to mount the efi-boot partition.
    /boot can also stay on the same partition as / (root) but this is less secure, but no problem…
    But you say only :“and pointed boot-efi to my boot partition!” it have to “point=mounted” to /boot/efi (a directory) and this is inside the root partition if you do not have a extra /boot partition.
    This is needed for grub to write to /boot directory if you mount efi-boot to /boot grub will write data to this and you will loose windows start…

  • You will need to chroot into your system then and reinstall grub.
    After you LuksOpen your devices, you have to mount system and efi to /mnt > /mnt/boot/efi
    then chrooting into your HD Antergos and reinstall grub.

    sudo su
    mount /dev/nvme0n1p5 /mnt
    mount /dev/nvme0n1p1 /mnt/boot/efi
    

    If you did not get errors:

    arch-chroot /mnt
    pacman -S os-prober
    os-prober
    

    Once this is done it should list something similar to what I have below:
    /dev/[email protected]/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
    Great! You found it. Now to update your grub so that it can see it.
    Update grub:

    grub-mkconfig -o /boot/grub/grub.cfg
    
  • @redbear said in GRUB problem:

    << Next is to create the /boot/efi partition. Actually, we don’t need to create it. Windows already have it. We can just specify the path to it. Just make sure to NOT format it. >>

    Just to add something…

    Example: imagine i want to reinstall Antergos, i already have a /root and /home partition installed, in cnchi i choose the same /root and /home partition, but choosing NOT to format /home, since i want to keep my old configs. and files.

    Conclusion: the same thing about /boot/efi, you have windows already using it, and you just want to add Antergos, then select to use the partition as /efi/boot but select to NOT format it, otherwise you’ll lose windows boot configuration.

    I hope i was clear enough.
    Cheers!

  • Ok, reinstalled, this time with /boot-efi as fat…

    But I cant edit grub.

    Everytime I want to mount a partition in live mode I get “device does not exist”. Did a rescan, but still the same…

    This is really horrible and the badest installation of a linux since long long ago…

    for example mint comes with an installer option for dual boot iirc…

  • I do not understand what you are trying to do…

    Antergos is capable to install dualboot with windows without any intervention from user…

    EFI partition already was there before…

grub111 Posts 8Views 1385
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.