• Failed to start light display manager, boot up black screen


    It seems like it’s due to the nvidia-setting. I installed it and then system boot up as a black screen. I uninstalled it but still not working…

    I have the following info generated.
    Systemctl status lightdm.service:
    lightdm status
    When I update the system, there are some conflicting packages.
    conflicts

    Thanks!!

  • always have a look that you need to upgrade linux and nvidia at the same time.
    You can still boot to X from fallback Image i think.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad said in Failed to start light display manager, boot up black screen:

    boot to X from fallback Image

    No. Still not working for me to get in the system…

  • My Xoeg.0.log, lspci, and X11 files info right here.
    https://gist.github.com/ztlevi/9d01205c923906a88883107f0ae40291

  • So nvidia-xconfig is bad to use under Arch-based systems ;)
    please erase the xorg.conf file, and i am shure you will be able to start X.
    You can also use the package nvidia-installer from Antergos to reinstall driver and write needed configs to system.
    startup go to TTY2 [ctlg+Alt+F2] login as your user>

    $ sudo pacman -Syu
    $ sudo pacman -S nvidia-installer
    nvidia-installer -t
    

    If it say working and no error reported:

    $ sudo nvidia-installer
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    Thanks!
    but still:sun_with_face:
    nvidia-installer

  • @ztlevi1993 do you
    remove xorg.conf ???

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    Yep. I renamed it just in case I need it later. It’s just another terminal after I reboot…

  • This is one of the strange behavior of lightdm i will never understand…
    I have this several times before switching to gdm…

    $ sudo pacman -S gdm
    $ sudo systemctl disable lightdm
    $ sudo systemctl -f enable gdm
    $ sudo systemctl reboot
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    Actually I’m using kde. So it’s supposed to be kde?

  • @ztlevi1993 then sddm instead of gdm
    Commands are the same

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    Not working…

  • sddm do not start also? or installing and enable sddm do not work?
    do you try to start X without DM already?

    To start Plasma with startx (xinit), append exec startkde to your .xinitrc file.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    I edited the file in the /etc/X11/xinit/ folder. But still not working…

  • https://wiki.archlinux.org/index.php/Xinit#xinitrc
    .xinitrc in your homefolder…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad
    Thanks.
    I tried that before and then tried to do in the /etc/X11/xinit but still not working for me. I just give up on fixing this issue. Reinstall and restore the system…:cry:

  • sorry for that, but needs time to find solution sometimes, and at the moment there are some serious issues with starting X…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • I reckon your problem is similar to what I was experiencing. I could not load the desktop either as lightdm would not load. The way I worked around this to to bring up another tty, install gdm, disable lightdm and enable GDM.

    sudo pacman -S gdm
    sudo systemctl disable lightdm && sudo systemctl enable gdm
    reboot

    Try this and hopefully this will let you load up GDM and you can then select your session be that Wayland or Gnome.

    Do note that the default is Wayland and autologin does not seem to work with Wayland.

  • he try to change the DM but no way to get X started, b.t.w. he was using KDE ;)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • I think for the purposes of testing out whether or not he can actually load another DM might be worthwhile to try something like GDM.
    Also would go about maybe uninstalling and reinstalling the arch nvidia packages which has the X dependencies.

    For me after I did a base (or gnome) install, I followed up by running:
    sudo pacman -S nvidia nvidia-libgl nvidia-utils lib32-nvidia-libgl
    reboot

    I have a GTX 1060 btw with no onboard graphics.

    PS: try: nvidia-smi
    This will show you current driver installed

light9 display31 manager42 boot159 Posts 28Views 2260
Log in to reply