• How to make secondary HDD go to sleep/spin down?


    I have an SSD as primary drive where Antergos is installed on. I have a second drive, an HDD, which contains some bigger data which is only accessed when needed. The thing is that this secondary disk doesn’t go to sleep after some time of inactivity in Antergos. In Windows it does go to sleep after X minutes.

    I found something about hdparm on the Arch wiki. To enable the sleep/spin down feature after 20 minutes, I’d have to install hdparm and use this command:

    sudo hdparm -S 240 /dev/sdc
    

    Is this the correct and safe way to do this? Will this setting also be remembered by the OS?

  • @EarthMind
    according to man hdparm
    -S Put the drive into idle (low-power) mode, and also set the standby (spindown) timeout for the drive
    so, yes.
    is /dev/sdc your data drive?

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc Yes it is, but I never saw it working. To be honest, I didn’t pay attention after I used that command. And now I rebooted, it certainly doesn’t work because I always hear it spinning. When accessing it, there’s no engine-like power on sound, which it otherwise has.

    I set it again to 20 minutes now:

    /dev/sdc:
     setting standby to 240 (20 minutes)
    

    I will see if it spinned down after I come back. If it works, then the issue is that my preference is not saved anywhere and I’d have to find a solution to that.

  • So I’ve been away from the computer for more than an hour and when I came back I noticed that the HDD didn’t go to sleep. So that doesn’t work for me unfortunately

    When I do sudo hdparm -I /dev/sdc | grep level
    I don’t see any setting, while I should get some value for Advance Power Management level


    Edit: actually it does seem to work. I tested it with hdparm -Y /dev/sdc to hear my HDD go to standby mode

    All the information can be found here: https://wiki.archlinux.org/index.php/hdparm#Benchmarking

    Another edit: I just noticed that you can also set the standby for each drive in the Drives (for me “Schijven”) GUI. See:
    alt text

    I’ve verified it working now and WOW, is my computer quiet now like in Windows when these drives are sleeping… I’ve enabled a standby after 15 minutes for my (useless for now in Linux) Windows RAID (they’re old Hitachi enterprise 2TB HDDs but loud as hell!) and my other TB HDD. As already said, it works wonderfully!

  • @EarthMind
    Wonderful. I"m happy to hear that it worked out for you.
    And thanks for marking the thread as solved, too. :)

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

sleep7 secondary4 hdd4 Posts 5Views 135
Log in to reply