• Pacman segmentation fault error


    After the recent huge Antergos update I’ve gotten into real trouble. One of the packages broke my desktop so I started rolling back to previous versions. I fixed that but then suddenly Pacman stopped working. Now I’m getting a segmentation fault error. I’ve tried searching for the solution but nothing really helps. Has anyone else experienced that? I’d be grateful for any help.

    Here’s my pacman.conf:

    [options]
    HoldPkg     = pacman glibc
    Architecture = auto
    
    CheckSpace
    
    SigLevel    = Required DatabaseOptional
    LocalFileSigLevel = Optional
    
    [antergos]
    SigLevel = PackageRequired
    Include = /etc/pacman.d/antergos-mirrorlist
    
    [core]
    Include = /etc/pacman.d/mirrorlist
    
    [extra]
    Include = /etc/pacman.d/mirrorlist
    
    [community]
    Include = /etc/pacman.d/mirrorlist
    
    [multilib]
    Include = /etc/pacman.d/mirrorlist
    
  • Here’s the debug log (I couldn’t include it in the previous message as it was being marked as spam):
    https://pastebin.com/AqUH4SYP

  • After a few days the problem disappeared. No idea what happened.
    In case someone else struggles with the same issue this may be useful:
    https://wiki.archlinux.org/index.php/pacman#Manually_reinstalling_pacman

pacman109 update55 segfault8 Posts 3Views 807
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.