• [Solved] Post-Install Cinnamon: Missing Icons


    Fixed! TL:DR
    @“lots.0.logs”:627hd3q8 said:

    For those having the issue with no menu or icons in cinnamon, run this command:

    sudo chown -R ${USER}:users /home/${USER}
    

    Replace ${USER} with your username.

    [/quote:627hd3q8]
    Then reboot/logout.

    @“Zenzou”:627hd3q8 said:

    Hello all.
    I’m not sure if this is an install problem or a cinnamon problem, but my test installation(s) are missing the menu and date-time.

    The menu icon is missing, but hovering over it with the mouse indicates it is there, but cannot access it; super-key does not work either.
    :exclamation:Sorry, this attachment is unavailable.

    Time/Date and a few other things that are normally in the top right corner are also missing.
    :exclamation:Sorry, this attachment is unavailable.

    Thanks,
    Zenzou
    [/quote:627hd3q8]

  • Fixed! TL:DR
    @“lots.0.logs”:627hd3q8 said:

    For those having the issue with no menu or icons in cinnamon, run this command:

    sudo chown -R ${USER}:users /home/${USER}
    

    Replace ${USER} with your username.

    [/quote:627hd3q8]
    Then reboot/logout.

    @“Zenzou”:627hd3q8 said:

    Hello all.
    I’m not sure if this is an install problem or a cinnamon problem, but my test installation(s) are missing the menu and date-time.

    The menu icon is missing, but hovering over it with the mouse indicates it is there, but cannot access it; super-key does not work either.
    :exclamation:Sorry, this attachment is unavailable.

    Time/Date and a few other things that are normally in the top right corner are also missing.
    :exclamation:Sorry, this attachment is unavailable.

    Thanks,
    Zenzou
    [/quote:627hd3q8]

  • Hi,

    I will check on this ASAP. Try running this command to revert everything to default cinnamon settings:

    gsettings reset- org.cinnamon
    
  • Hello everyone, I follow a little Antergos but lately I also found the lack of the error menu of cinnamon 2.2.3 I installed the same version on ArchLinux without that annoying problem … the installation of cinnamon on Antergos is based on Arch repository or Antergos??
    How can I fix this??
    Thanks to all and sorry for my english

  • @“lots.0.logs”:1rvvor6v said:

    gsettings reset- org.cinnamon
    

    incorrect syntax. I’ll play with it when I get back.

  • Hi,

    I can’t test it now because I’m not using Cinnamon, but maybe this helps:

    gsettings reset-recursively org.cinnamon
    

    (In fact, this may well be what lots.0.logs meant

  • @“karasu”:31i83ijw said:

    gsettings reset-recursively org.cinnamon
    

    [/quote:31i83ijw]
    No go, still missing. Using 4.27 iso, cnchi 5.38 now, same problem.

  • Try this:

    sudo pacman -S librsvg

    Please give a feedback after you get help so the thread can be set to solved.

  • @“b1n0ry”:dp9sqsa7 said:

    sudo pacman -S librsvg[/quote:dp9sqsa7]
    Unfortunately not; already installed and up to date.

  • I will try to reproduce this tonight and hopefully have a solution for you soon

  • So cinnamon from my older installation of Antergos is up-to-date and fixed, however new installations/test installations are having the issue described. Tested in VMWare as well as on an actual laptop.

  • For those having the issue with no menu or icons in cinnamon, run this command:

    sudo chown -R ${USER}:users /home/${USER}
    

    Replace ${USER} with your username.

    Cheers!

  • @“lots.0.logs”:1nv1m2kv said:

    For those having the issue with no menu or icons in cinnamon, run this command:

    sudo chown -R ${USER}:users /home/${USER}
    

    Replace ${USER} with your username.

    Cheers![/quote:1nv1m2kv]
    Worked after reboot/logging out! Thanks. Renamed title for clarity and marked as solved. Only problem is that the menu icon is significantly larger than everything else but that’s unimportant for this thread.

  • @Zenzou

    Working for me today (March 2016) :)

Posts 15Views 2973
Log in to reply