• Firefox-KDE is broken


    Firefox KDE fails to launch.

    Does the following when I try:

    XPCOMGlueLoad error for file /usr/lib/firefox/libxul.so:
    libicui18n.so.58: cannot open shared object file: No such file or directory
    Couldn't load XPCOM.
    

    Regular Firefox launches and runs perfectly, so I imagine it’s somehow qt related. But other qt4 and qt5 applications also work just fine. I’ve tried refreshing my mirrors and updating, as well as reinstalling firefox and icu, but hasn’t helped.

  • looks like lib32-icu package does not provide libicui18n.so.58 anymore, instead libicui18n.so.59

    You may try symlinking 59 to 58, might work. Or, you just need to wait for the package maintainer to fix it. You can type your issue here, https://aur.archlinux.org/packages/firefox-kde-opensuse/ to speed things up.

  • Same issue here. Symlinking is not enough, when libicui18n.so.58/59 is dealt with, FF complains about missing /usr/lib/libicuuc.so.58, and if this is done, it complains about »libhunspell-1.5.so.0: cannot open shared object file: No such file or directory« at which point I gave up.

    Went to plain firefox for now, I need to work somehow ;)

  • An icu58 package can be found in the aur.
    J.

  • From what I can tell, the Firefox KDE version is fixed to work with the newer icu in the AUR, but for whatever reason the package hasn’t been updated in the Antergos repo.

firefox-kde1 broken12 Posts 5Views 272
Log in to reply