• PROBLEMAS PARA ABRIR LA TERMINAL


    Buenos dias comunidad, estoy presentando desde hace dias que no puedo abrir la terminal le doy clic y esta simplemente hace como que va abrir pero no termina de hacerlo.

    Estoy me viene pasando desde mucho antes de la actualización de gnome.

    Si alguien me puede ayudar por favor :(

  • Hola,

    En Gnome, la terminal es gnome-terminal.

    Puedes probar a instalar otra terminal (xfce4-terminal por ejemplo) y ejecutar desde la nueva terminal gnome-terminal para ver si muestra algún mensaje

    Saludos!

  • Que tal @karasu

    intente abrirla desde otra terminal y me arroja el siguiente mensaje:

    /usr/bin/terminal: error while loading shared libraries: /usr/lib/libpcre2-8-so-0: file too short

    Casualmente intente instalar la terminal que me dijiste pero pasa lo mismo que con la gnome terminal.

  • @argenisrod borre este archivo y luego me manda un error de que este archivo no existe, lo restaure y me dice el error anterior.

    Lo abrí para ver su contenido pero es un archivo vació no tiene nada.

  • No debería estar vacío, es un enlace a una librería…

    En la terminal que funciona, qué te devuelve la siguiente orden?
    ls -l /usr/lib/libpcre2-8*

    Puedes volver a instalar la librería con:
    sudo pacman -S pcre2

  • 0_1493500418587_Captura de pantalla de 2017-04-29 17-12-34.png

    Esto me arroja la listar.

    Y al intentar reinstalar las librerías me dice que hay conflicto entre paquetes.

  • Hola de nuevo…

    Pues algo anda mal. El fichero /usr/lib/libpcre2-8.so.0.5.0 ocupa unos 491K, y tú lo tienes a cero!

    Qué conflicto te sale? Puedes poner exactamente el mensaje ?

    Y por cierto, te parecerá una tontería, pero ya has mirado que tengas suficiente espacio libre en disco?

  • 0_1493561683753_Captura de pantalla de 2017-04-30 10-13-10.png

    Este es el error que me arroja al intentar reinstalar.

    También revise la memoria pero aun tengo bastante.

  • Hola,

    Ayer estuve todo el día fuera de casa y no pude mirar el foro, lo siento.

    Bueno, por la imagen parece que alguna cosa fué mal en la instalación de pcre2

    ¿ Puede ser que lo instalaras manualmente, o que tengas alguna versión de AUR?

    Si no es así, puedes probar a forzar la instalación con:
    sudo pacman -S --force pcre2

    Saludos!

    EDIT: He encontrado esto en la wiki de Arch, quizás es lo que te ha pasado. Se debería solucionar con el comando --force que te he puesto arriba: “Every installed package provides a /var/lib/pacman/local/$package-$version/files file that contains metadata about this package. If this file gets corrupted, is empty or goes missing, it results in file exists in filesystem errors when trying to update the package. Such an error usually concerns only one package. Instead of manually renaming and later removing all the files that belong to the package in question, you may exceptionally run pacman -S --force $package to force pacman to overwrite these files.”

  • Hola, ya eramos dos que estábamos fuera de casa jajaja.

    Probé hacer la re-instalación del pcre2 con sudo pacman -S --force pcre2 y como se logro ejecutar sin problemas, ya la terminal de gnome me abre como debería ser.

    Muchas gracias crack!

problemas9 abrir4 para4 terminal27 Posts 10Views 285
Log in to reply