• error: failed to prepare transaction (could not satisfy dependencies)


    Running pacman -Syyu gives:

    error: failed to prepare transaction (could not satisfy dependencies)
    :: banshee: installing libsoup (2.58.0-1) breaks dependency 'libsoup-gnome'
    :: gstreamer0.10-good-plugins: installing libsoup (2.58.0-1) breaks dependency 'libsoup-gnome'
    

    I ran pacman -Qs gstreamer0.10 as been suggested elsewhere. It didn’t help.

    Any solution, please?

  • @gagarin said in error: failed to prepare transaction (could not satisfy dependencies):

    Running pacman -Syyu gives:

    error: failed to prepare transaction (could not satisfy dependencies)
    :: banshee: installing libsoup (2.58.0-1) breaks dependency 'libsoup-gnome'
    :: gstreamer0.10-good-plugins: installing libsoup (2.58.0-1) breaks dependency 'libsoup-gnome'
    

    I ran pacman -Qs gstreamer0.10 as been suggested elsewhere. It didn’t help.

    Is there a particular reason to still use gstreamer0.10? It is logically dead 3 months ago, at the end of January 2017, when it was moved from regular repos to AUR. The outdated gstreamer0.10 may be still used by some legacy software.

    A modern gstreamer 1.10 is used instead of obsoleted gstreamer0.10. Gstreamer 1.10 is contained within gst-* packages. Its main package is called simply gstreamer, without a number in the name. Antergos uses gstreamer 1.10 (gstreamer and gst-* pkgs) for ages. Take a look at this thread.

    Any solution, please?

    Only a general outline. I don’t use any of the mentioned software.

    1. Make a full backup of the / (root) partition(s) with your Antergos(es)

    2. Fully remove outdated gstreamer0.10; confirm removal of all pkgs that pacman will propose to remove

      yaourt -Rcnsu gstreamer0.10 gstreamer0.10-bad gstreamer0.10-bad-plugins gstreamer0.10-base gstreamer0.10-base-plugins gstreamer0.10-ffmpeg gstreamer0.10-good gstreamer0.10-good-plugins gstreamer0.10-mm gstreamer0.10-python gstreamer0.10-ugly gstreamer0.10-ugly-plugins
      
    3. Install modern gstreamer

      sudo pacman -Syu ffmpegthumbnailer gst-libav gst-plugins-bad gst-plugins-base gst-plugins-good gst-plugins-ugly gstreamer-vaapi libdvdcss
      
    4. Done

  • All good, thanks.

pacman updates5 Posts 3Views 609
Log in to reply