• screen turns off when watching videos


    hi,
    this didn’t happen when i was using manjaro and I can’t work out why it’s happening in antergos. manjaro must do something post install to configure the screen.

    so, when i’m watching videos in a web browser such as youtube, plex, etc. the power management kicks in and the screen turns off mid-show. shouldn’t the OS realise that a video is being watched, especially if it’s fullscreen, and postpone power management?

    i don’t want to use the cop-out caffeine, i want this to be automatic, both full screen and within window.

    is my system stuffed and i need to fix it, or is this normal and there’s nothing i can do about it?

    cheers!

  • hi.
    no this is not normal.
    what have you so far done with power management in the settings if at all?
    If something like this is applicable, you could try this: https://github.com/unhammer/lightsOn

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • my DE is KDE - almost fresh install. on top of built in power management in KDE i’ve installed powertop and tlp. settings in power management (on AC) is to “dim screen” after 10 mins which is exactly when my screen turns off while watching a video. it also does the whole auto reduce brightness thing before that though.
    my browser is Chrome. i haven’t tried in firefox but i don’t want to.
    again, i don’t really want to install something to achieve a workaround. i was hoping to be able to “fix” the root cause of the problem if you know what i mean. that’s assuming there is a problem…

  • I completely agree that you shouldn’t have to install something just in order to fix something.
    The type of browser your using makes no difference. The fact that you have tlp installed is great for some power consumption reduction but it has nothing to do with dimming or preventing dimming of your screen.

    Regardless, I’m on the road at the moment for the next day or so, so if you could give me some time to do a bit of research I might be able to help you.
    However, in case you are interested in installing the script from the link above, you could try from Settings>Energy Savings and on the AC power savings Tab there is a dialogue box that allows you to select a script for preventing of dimming of your screen while your watching videos via your browser.

    This issue of your screen dimming after 10 mins when it should not should be automatic and your system should be recognizing it. However, for some reason or other it isn’t.

    So just bear with me for a bit but I’ll help you as best as my knowledge is able to. Again, give me a day or so.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hello.
    Sorry for this late reply. I have not been able to find much other than the suggestion that you access the ENERGY SAVING on your KDE DE. From there, you should be able to access of how long you want the screen to not dim before it does go dim.
    You could also try xset -dpms or see man xset first to get an idea of what the options mean for xset.
    Or you could add to autostart a script.
    If you want to add to autostart a script, you can try to do this:

    Create a new file in ~/bin.
    Name this file whatever you like.

    Example: no_dimming.sh
    Put the following two lines in

    #!/bin/bash
    xset s noblank -dpms
    

    then give it these permissions.
    chmod 755 ~/bin/no_dimming.sh

    then go and log out.
    Log back in.

    I hope this has helped.
    I understand you’d rather not install a script but it’s the only solution that i was able to come up with.
    Perhaps someone else has a better idea than I was able to supply you with.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc thanks for the research you have put into this. thats wonderful and i appreciate the help.

    what you suggests works but it also disables my screen turning off completely. i need my screen energy saving to come into effect after ive watched the video. for example if i happen to be watching a video while im lying in bed late a night. i dont want to fall asleep and wake to find my screen still on.

  • @christianbrooker

    I understand what your saying.
    So when you went to your ENERGY SAVING>AC POWER, were there these settings that you might have been able to configure?
    This is my settings imaged below.

    0_1493821360465_snapshot1.png

    This is for KDE, correct?

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc

    yes, I have the same settings as you. i installed the script from https://github.com/iye/lightsOn/pull/14/files and put it in my startup and it seems to work pretty well. i have it set to check every 10 seconds before the screen is supposed to turn off.

    is this a KDE thing, an Arch thing, or an Antergos thing? Does anyone run KDE Neon and have this problem?

    I must say, the activity in this forum is wonderful!

  • @christianbrooker
    I"m glad something got working correctly.
    As for if it’s a distro thing, a KDE thing, an Arch thing…you got me :worried:
    Regardless, if this solves the issue for you, would you be ok to mark this thread as ‘solved’ ?
    Should be under TOPIC TOOLS (lower right corner of your last post).

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

kde107 video22 power10 screen17 Posts 9Views 615
Log in to reply